Welcome to the North American Subaru Impreza Owners Club Wednesday October 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-01-2009, 06:51 PM   #1
apkarian100
Scooby Specialist
 
Member#: 207053
Join Date: Mar 2009
Chapter/Region: NESIC
Location: Alton Bay, NH
Vehicle:
2013 XV Crosstrek
DGM

Default Rough Idle For Baja?

Hi,

I have noticed, driving my Mom's Baja that the idle is not as smooth as i think it should be. When I sitting still, and the car is on, it feels like the car starts to jerk rapidly to one side or the other. Could it be bad fuel injectors?

What do you guys think?
* Registered users of the site do not see these ads.
apkarian100 is offline   Reply With Quote
Old 05-02-2009, 06:46 AM   #2
BajaGuy68
Scooby Newbie
 
Member#: 127720
Join Date: Oct 2006
Chapter/Region: Tri-State
Location: Western, NY
Vehicle:
2015 WRX
Lightning Red

Default

It may be many things; dirty/bad fuel injectors, bad gas-water in the gas, bad wires-plugs, sensors, etc... I would try putting in some gas treatment/fuel injector cleaner in first. Then go to a friend or an auto parts store(Autozone,Pep Boys) and have them use a code scanner on the Subie and see if there are any codes showing up.---Its a start in the right direction. I hope it helps.
BajaGuy68 is offline   Reply With Quote
Old 05-07-2009, 07:55 PM   #3
machinegreen
Scooby Newbie
 
Member#: 100818
Join Date: Nov 2005
Chapter/Region: MAIC
Location: West Virgina
Vehicle:
2005 Baja Sport
Dark Blue Pearl

Default

I used fuel injector cleaner and a good oil change with anti sludge in the new oil. Runs smoother now.
machinegreen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough idle, intermitent and rough cold starts... carter_wrx Pre-2002 Factory Turbo Powertrain 26 10-28-2009 01:03 PM
How Rough is a Rough Idle Go350zGo Factory 2.5L Turbo Powertrain 11 10-22-2009 11:28 PM
rough idle, misfire, CEL funky high idle carter_wrx Factory 2.0L Turbo Powertrain 1 10-04-2009 02:44 PM
very rough idle lean afr's at idle TDagen Open Source Reflashes 8 07-07-2008 04:28 PM
High Idle, Rough Idle? Brettweiser Factory 2.5L Turbo Powertrain 3 04-09-2007 11:10 PM


All times are GMT -4. The time now is 07:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.