Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-05-2009, 01:55 AM   #1
platnumn
Scooby Specialist
 
Member#: 91996
Join Date: Jul 2005
Chapter/Region: Tri-State
Location: Stamford, CT.... New York, NY
Vehicle:
2009 Audi R8
06 WRX Ltd. - Sold

Default Help! DIM CEL!!!

Hey guys,

I was coming home from a friends house late at night, and noticed that my Check engine light could be seen ever so faintly. Now it was really dark out, and I may have been imagining, but the light seemed to become more visible over the drive, but still dim enough that I was trying to figure out if it was normal or not. I have an 06 WRX with full CBE and Protuned to stage 2.

What's going on? I NEED an oil change (5-600 miles overdue), and it has been raining here in CT/NY (but not when I noticed the dim light). The CEL is the only light that is barely visible, so I did not think it was the oil, and the car has held up in rain for years with no problems.

I hate that I am seeing things go wrong after it is out of warranty and after I got the pro-tune. Hopefully this is not a major problem, but any suggestions would be helpful.
* Registered users of the site do not see these ads.
platnumn is offline   Reply With Quote
Old 05-05-2009, 11:22 AM   #2
platnumn
Scooby Specialist
 
Member#: 91996
Join Date: Jul 2005
Chapter/Region: Tri-State
Location: Stamford, CT.... New York, NY
Vehicle:
2009 Audi R8
06 WRX Ltd. - Sold

Default

Nothing?

Is this similiar to the oil light being on or do I have a different problem?
platnumn is offline   Reply With Quote
Old 05-05-2009, 11:29 AM   #3
anickode
Scooby Specialist
 
Member#: 141633
Join Date: Feb 2007
Chapter/Region: MWSOC
Location: Ann Arbor, MI
Vehicle:
2002 WRX Wagon
Shiny new silver!!!

Default

hm. are you having any issues with needles twitching r anything? Could just be voltage leaking across a ground or something..
anickode is offline   Reply With Quote
Old 05-05-2009, 01:36 PM   #4
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

Check to see if there is any AC voltage coming from the alternator while the engine is running around 2000 RPM. If there is more than .1 volt replace the alternator.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help!!! flashing cel and no one can help tommy 02wrx Factory 2.0L Turbo Powertrain 21 06-05-2010 07:26 PM
HELP!! flashing cel tommy 02wrx Factory 2.0L Turbo Powertrain 2 06-04-2010 01:38 PM
****need Help With Cel Codes-please Help************** stito Subaru Conversions 4 07-29-2007 04:55 AM
help help help, the CEL is back Qbushido Tri-State Area Forum 6 06-06-2002 08:51 PM
Need help with CELs BluJay Tri-State Area Forum 3 11-03-2001 08:31 PM


All times are GMT -4. The time now is 08:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.