Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-06-2009, 01:54 AM   #1
sleepysubie
Scooby Specialist
 
Member#: 81069
Join Date: Feb 2005
Chapter/Region: RMIC
Location: The land full of Bounty
Vehicle:
1998 ej257 gm6 ewg
A/R .60 Rotated

Default illumination problem

My 99 rs the illumination in the dash and my alarm started acting funny and when i put in a fuse it, it blows instantly. The alarm fuses keep blowing. I can't figure it out. any help would be appreciated
* Registered users of the site do not see these ads.
sleepysubie is offline   Reply With Quote
Old 05-06-2009, 11:15 AM   #2
Cougar4
Scooby Guru
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

It would help to know what the fuse number is that is having the trouble.

You are going to have to disconnect things you suspect are causing the trouble to see if that clears the shorting problem.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Defi illumination problem greysave Electrical & Lighting 7 11-20-2007 09:27 PM
06 factory boost gauge illumination problem Psybin Interior & Exterior Modification 2 12-06-2006 09:51 AM
Dash/Climate Control/Radio display illumination problem!! TyR1 Electrical & Lighting 16 07-27-2006 01:32 PM
Dash illumination problem bbrewer Service & Maintenance 0 01-30-2002 04:46 PM


All times are GMT -4. The time now is 03:25 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.