Welcome to the North American Subaru Impreza Owners Club Friday October 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 05-06-2009, 12:54 AM   #1
Scooby Specialist
Member#: 81069
Join Date: Feb 2005
Chapter/Region: RMIC
Location: The land full of Bounty
1998 ej257 gm6 ewg
A/R .60 Rotated

Default illumination problem

My 99 rs the illumination in the dash and my alarm started acting funny and when i put in a fuse it, it blows instantly. The alarm fuses keep blowing. I can't figure it out. any help would be appreciated
* Registered users of the site do not see these ads.
sleepysubie is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-06-2009, 10:15 AM   #2
Scooby Guru
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
2001 LL Bean Outback


It would help to know what the fuse number is that is having the trouble.

You are going to have to disconnect things you suspect are causing the trouble to see if that clears the shorting problem.
Cougar4 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Defi illumination problem greysave Electrical & Lighting 7 11-20-2007 08:27 PM
06 factory boost gauge illumination problem Psybin Interior & Exterior Modification 2 12-06-2006 08:51 AM
Dash/Climate Control/Radio display illumination problem!! TyR1 Electrical & Lighting 16 07-27-2006 12:32 PM
Dash illumination problem bbrewer Service & Maintenance 0 01-30-2002 03:46 PM

All times are GMT -4. The time now is 07:51 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.