Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-07-2009, 04:48 PM   #1
sniper512
Scooby Newbie
 
Member#: 189923
Join Date: Sep 2008
Chapter/Region: W. Canada
Location: Cranbrook, BC
Vehicle:
1993 JDM WRX
Black

Default Car is fixed

So I finally got my car running good. Rob tuned me a Z4 ECU. I got it in the car the other day and it was perfect. Car was running 14.5 psi, but I installed a MBC and upped it to 15psi. The car is very strong. Other supporting mods are a USDM WRX TMIC, HKS Turboback Exhaust, and upgraded usdm wrx coils.

The tune definitely cleaned the fueling up and my timing is not fluctuating anymore. The car is a completely new beast. I highly recommend this to anyone looking for the most out of their stock ECUs. The tune is great Rob thanks Muchly.
* Registered users of the site do not see these ads.
sniper512 is offline   Reply With Quote
Old 05-07-2009, 10:24 PM   #2
beaviscih
Scooby Specialist
 
Member#: 123362
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Dorothy's House
Vehicle:
'93 Crapcan, '98L
Sold, '04 STi - Sold

Default

I'm envious; At this point I just want my engine to start. Pardon my ignorance, but what motor are you running?
beaviscih is offline   Reply With Quote
Old 05-07-2009, 10:34 PM   #3
bape-ape
Scooby Specialist
 
Member#: 136009
Join Date: Dec 2006
Chapter/Region: TXIC
Vehicle:
96 RapeWagon
Ugly

Default

If its got a Z4 it should be a 20g.
bape-ape is offline   Reply With Quote
Old 05-07-2009, 10:46 PM   #4
beaviscih
Scooby Specialist
 
Member#: 123362
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Dorothy's House
Vehicle:
'93 Crapcan, '98L
Sold, '04 STi - Sold

Default

Quote:
Originally Posted by bape-ape View Post
If its got a Z4 it should be a 20g.
That's what I was thinking but didn't know for sure...thanks.
beaviscih is offline   Reply With Quote
Old 05-07-2009, 11:04 PM   #5
subartender
Scooby Newbie
 
Member#: 135652
Join Date: Dec 2006
Chapter/Region: MAIC
Location: King of Prussia, PA/Hong Kong
Vehicle:
2004 WRX
JBP

Default

Yea. Rob's tune made almost the same power as my Apexi powerfc that is tuned!
subartender is offline   Reply With Quote
Old 05-08-2009, 09:20 AM   #6
sniper512
Scooby Newbie
 
Member#: 189923
Join Date: Sep 2008
Chapter/Region: W. Canada
Location: Cranbrook, BC
Vehicle:
1993 JDM WRX
Black

Default

Yuppers Its an early 20g. Car responded very well to the tune. Definitely feels like it has 250whp like so many others have netted with my mods.

I will be going to his 550 injectors tune when its done. I am hoping for 270whp with that. I will be getting a dyno in the next month to see where I sit now compared to the 550 tune.
sniper512 is offline   Reply With Quote
Old 05-08-2009, 04:03 PM   #7
xlur8ed
Scooby Newbie
 
Member#: 147812
Join Date: May 2007
Location: Fargo, ND
Vehicle:
1998 2.5RS
Brilliant Red

Default

I also have a chipped Z4 from 'rob' and after 10k miles, I have had nothing be great results. Very strong and very worth it. I have been running 1.1 bar (~16psi) on 92 octane since the day I got it back from 'rob' with ZERO issues.
xlur8ed is offline   Reply With Quote
Old 05-09-2009, 10:40 PM   #8
GregBolby
Scooby Specialist
 
Member#: 498
Join Date: Nov 1999
Chapter/Region: South East
Location: Charleston, SC
Vehicle:
1981 jdm swapped gc
sniklfritz

Default

so he can reflash a z4 ecu?, im doing my swap now ej20g with tdo5, front mount 3" downpipe and turbo back, intake and greddy type rs bov vented to atmosphere. would his reflash work well with my setup and 93 octane?

thanks

Greg
GregBolby is offline   Reply With Quote
Old 05-10-2009, 12:01 AM   #9
azn0boi04
Scooby Specialist
 
Member#: 164172
Join Date: Nov 2007
Chapter/Region: NWIC
Location: Covington, WA
Vehicle:
97 OBS EJ20G ZILLA
87 GL

Default

dam.. i was about to get this... but then someone HIT MY CAR!!! AND TOTALLED IT!!!!!!!.... DAm... u make me SOOO jealous
azn0boi04 is offline   Reply With Quote
Old 05-10-2009, 01:13 AM   #10
sniper512
Scooby Newbie
 
Member#: 189923
Join Date: Sep 2008
Chapter/Region: W. Canada
Location: Cranbrook, BC
Vehicle:
1993 JDM WRX
Black

Default

He can flash any 4 plug ecu I believe.
sniper512 is offline   Reply With Quote
Old 05-11-2009, 12:59 PM   #11
rob
n00b Moderator
Moderator
 
Member#: 811
Join Date: Jan 2000
Location: WA
Vehicle:
2000 RS-Ej20G
It tastes like burning

Default

Techincally speaking, it's not a reflash. You have to add a special EPROM to the main board.

Greg, send me an email and we can talk further;
rob.files @ gmail.com

-Rob
rob is offline   Reply With Quote
Old 05-11-2009, 09:22 PM   #12
azn0boi04
Scooby Specialist
 
Member#: 164172
Join Date: Nov 2007
Chapter/Region: NWIC
Location: Covington, WA
Vehicle:
97 OBS EJ20G ZILLA
87 GL

Default

i take it that rob fixed that timing problem...?
azn0boi04 is offline   Reply With Quote
Old 05-12-2009, 03:44 AM   #13
sniper512
Scooby Newbie
 
Member#: 189923
Join Date: Sep 2008
Chapter/Region: W. Canada
Location: Cranbrook, BC
Vehicle:
1993 JDM WRX
Black

Default

Well the car is certainly not doing what it was doing and is running great. To me it was like the other ECU couldn't learn properly. The one I got from Rob is much better.

Ya sorry about that Rob I meant flash as in burn chip not flash the ECU itself.
sniper512 is offline   Reply With Quote
Old 05-12-2009, 01:57 PM   #14
rob
n00b Moderator
Moderator
 
Member#: 811
Join Date: Jan 2000
Location: WA
Vehicle:
2000 RS-Ej20G
It tastes like burning

Default

Quote:
Originally Posted by azn0boi04 View Post
i take it that rob fixed that timing problem...?
Its a different tune that what I had on the dyno (with STi injectors).
rob is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
car is fixed :) with a new part smkm1023 Off-Topic 29 04-30-2004 02:04 AM
My car is fixed AK_2002_WRX Alaskan Impreza Club Forum -- AKIC 11 04-12-2004 10:01 PM
Woot! Car is fixed! Zapix New England Impreza Club Forum -- NESIC 8 10-07-2003 05:05 AM
My Car is fixed. dj_noose Mid Atlantic Impreza Club -- MAIC 8 09-29-2003 04:48 PM
My car is fixed!!!! but feel like an moron VSM EXtasy Mid Atlantic Impreza Club -- MAIC 13 02-21-2003 01:46 PM


All times are GMT -4. The time now is 01:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.