Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-08-2009, 05:28 AM   #1
shadysalezmen
Scooby Newbie
 
Member#: 111162
Join Date: Mar 2006
Chapter/Region: BAIC
Location: Oakland, CA
Vehicle:
2004 WRX
Silver

Default AIRBAG light on, turbo timer not working.

help! i got a problem for a few days now, its weird, while driving my airbag light suddenly came on, and after it came on, my turbo timer stopped working, i dont get whats going on, i drive a 2004 subaru wrx, what could it be? thanks!
* Registered users of the site do not see these ads.
shadysalezmen is offline   Reply With Quote
Old 05-18-2009, 05:18 PM   #2
clint4502
Scooby Newbie
 
Member#: 136905
Join Date: Jan 2007
Chapter/Region: Tri-State
Vehicle:
2004 WRX
WRB

Default

not sure about the turbo timer... as for the airbag light, check under your driver and passenger seats for the yellow wiring harness. make sure those connections are both tight. mine came loose and caused my airbag light to come on.
clint4502 is offline   Reply With Quote
Old 05-19-2009, 05:35 PM   #3
andyboi677
Scooby Newbie
 
Member#: 179049
Join Date: May 2008
Chapter/Region: SCIC
Location: Westminster
Vehicle:
2005 Imperza Wrx
Aspen White

Default

how did u hook up ur turbo timer? Did u wire it to some yellow harness wire?
andyboi677 is offline   Reply With Quote
Old 05-20-2009, 12:02 AM   #4
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

check connectors for the airbags under the seats like above person said
as for the turbo timer, just take it out and make your car less cluttered
Jncominco2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
turbo timer not working. unhooked and car still won't turn on nxthxn Interior & Exterior Modification 4 08-07-2009 08:59 PM
Viper 5900 Turbo Timer not working SWRT_22B Car Audio, Video & Security 11 04-15-2008 03:24 PM
Lights on decklid do not work...Help! JasonRan Legacy Forum 5 08-26-2007 11:31 AM
Apexi Turbo Timer not working!? NewShockerGuy Interior & Exterior Modification 0 08-21-2005 06:34 PM
Apexi Turbo Timer Not Working. veedubaholicvr6 Electrical & Lighting 1 10-22-2002 04:45 AM


All times are GMT -4. The time now is 01:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.