Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-10-2009, 09:12 PM   #1
gindobuck
Scooby Newbie
 
Member#: 141650
Join Date: Feb 2007
Default lights no longer work help please

so i recently installed some subwoofers into my 07 wrx tr

4 days afterwards two sets of lights stop working.

the front i think their called parking lights. you turn them on with one turn of the light switch.

also the rear lights you turn on by turning the light switch two times to be on.
when i press on the brakes the brake lights turn on, when i turn the blinkers on they turn on too.

the front two lights (parking lights are brand new, the rear is the stock ones.) i dont think its a coincident that the rear two just blew out and no longer works but i will get new bulbs to replace them just incase it is that case. that still doesnt explain why the front two no longer work. if there is a fuse specifically for the front two lights and the rear light?

when i put the switch thats on steering wheel area, that no longer turns on the parking light and rear lights also. ( not the emergency light, the one right behind the steering wheel in 07 wrxs not sure if other models have it as well.

what do you guys think?
* Registered users of the site do not see these ads.
gindobuck is offline   Reply With Quote
Old 05-11-2009, 09:08 PM   #2
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

You either have a blown fuse in the panel under the hood or the dash, or a wire disconnected for the lights.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fog light mod no longer works cueball89 Electrical & Lighting 6 04-14-2010 08:37 AM
Horn no longer working hacman Normally Aspirated Powertrain 1 07-16-2002 05:18 PM
left fog no longer works KillerTHC Interior & Exterior Modification 7 02-03-2002 07:22 PM
('93-'01) Help, the old URLs no longer work! Caron Impreza Forum 3 06-28-2001 06:59 PM
Well, my trunk's keyhole no longer works! Snoopy General Forum Archive 11 05-16-2000 12:48 AM


All times are GMT -4. The time now is 04:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.