Welcome to the North American Subaru Impreza Owners Club Sunday August 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-11-2009, 02:02 AM   #1
burtonchild05
Scooby Newbie
 
Member#: 191708
Join Date: Oct 2008
Chapter/Region: MWSOC
Vehicle:
2002 WRX Wagon

Default Dead Battery or worse?

Right, so a couple weeks ago i go to turn the car on, and it gives me an odd response, it makes all these buzzing noises, the starter doesn't do a damn think, and my lights flicker and stuff. But then it started right up and i drove away thinking nothing of it. it was fine for like a month, and then it did it again, only this time it would start at all, so i drove it to recharge it, but that didn't do a damn thing. but the car turned off and i did something stupid to set the alarm off, but since it had little to no power it was a pitiful honk, all you could hear was the relay going, but i had to go to work and didn't have a car to mooch a jump off so i just let it pathetically try to alarm me for about 2 or so hours.
Me and a friend have some trouble jumping it but it eventually goes, and whenever i hit something simple like a radio button, or a window button all my lights dim and go weird, and my dome light always flickers if its on. Then on the way home i was toying with the windows just to see if i could get a better understanding, then out off the blue my ABS light comes on and starts toying with my brakes, that scared the piss out of me, so i turned everything except the headlights off and drove home, and there she sits.

the only thing that really scared me was the ABS bit, is there anything bigger or is that just little to no power playing tricks on the car?

i apologize for the lack of grammar and spelling and what not

Evan
* Registered users of the site do not see these ads.
burtonchild05 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-11-2009, 02:24 AM   #2
MonikAWD
Scooby Newbie
 
Member#: 201488
Join Date: Jan 2009
Chapter/Region: South East
Location: Tampa, FL
Vehicle:
99 JDM V5 RA
STM

Default

Crazzyness happening, um..all i can say is to test your battery, and test your alternator is where you want to start.
MonikAWD is offline   Reply With Quote
Old 05-11-2009, 11:59 AM   #3
cMags
Scooby Specialist
 
Member#: 88668
Join Date: Jun 2005
Chapter/Region: NESIC
Location: Lowell, MA
Vehicle:
'05 Outback Sport
5MT - Regal Blue / Grey

Outback Sport

Yea I agree with the above post. I had some really strange issues with a bad battery recently - it wouldn't run well, would stall at idle, and the timing seemed way off. I thought I had fried the ECU or something. Ended up just being the battery fortunately. Definitely get it and your alt. tested. They do it for free at most auto-parts stores.
cMags is offline   Reply With Quote
Old 05-11-2009, 03:48 PM   #4
JavaBot
Scooby Guru
 
Member#: 156723
Join Date: Aug 2007
Chapter/Region: Tri-State
Location: Illadelph
Vehicle:
05 crp foresterX
rip 2.0i/2.5rs

Default

Alternator! Any charging issues usually are related to that and they don't really just 'go' they kinda die on you and then wackiness happens. If it hasn't killed your battery already you may be able to salvage it but sounds like its about to lose it's juice. New Alt/Batt is prob round 200 total with labor. GL they are a relatively easy fix.
JavaBot is offline   Reply With Quote
Old 05-11-2009, 07:37 PM   #5
burtonchild05
Scooby Newbie
 
Member#: 191708
Join Date: Oct 2008
Chapter/Region: MWSOC
Vehicle:
2002 WRX Wagon

Default

right, so the battery is perfect, in every way. so i do believe my alternator has hit the wall
burtonchild05 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead battery or bad battery Texas25RS Texas Impreza Club Forum -- TXIC 1 01-26-2004 10:24 AM
Dead Battery Yotsuya Mid West Subaru Owners Club Forum -- MWSOC 4 04-28-2002 11:09 PM
Tial or Deltagate? Better or worse? hayscoob Normally Aspirated with bolt-on Forced Induction Powertrain 19 02-01-2002 08:02 PM
('93-'01) Week old 2002 2.5 with a dead battery deke Impreza Forum 5 08-30-2001 05:00 AM
Dead Battery = Dead Alarm? 2yLiTe Car Audio, Video & Security 3 01-16-2001 01:33 PM

All times are GMT -4. The time now is 09:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.