Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-11-2009, 10:39 AM   #1
maciek
Scooby Newbie
 
Member#: 11216
Join Date: Oct 2001
Location: Denver CO
Vehicle:
1991 SS 1998 BG
1996 BD

Default 99 2.5L overheating

My 99 Legacy GT has started to overheat at 113K miles. At first I thought it might be the HG but the symptoms seem different.
It overheats randomly, usually when on the highway. When it overheats the heater blows cold air. At the same time the coolant overflow fills up and spills over. The lower radiator hose is cold and the upper is hot.

I just replaced the thermostat which was definitelly busted...thought that would fix it, but it overheated the same way yesterday.

I am thinking it could be the water pump, but I thought they leaked when going out.

Could a bad radiator cap be causing this?

Thanks
* Registered users of the site do not see these ads.
maciek is offline   Reply With Quote
Old 05-12-2009, 12:10 AM   #2
ballitch
Scooby Specialist
 
Member#: 74907
Join Date: Nov 2004
Chapter/Region: NWIC
Location: salem, OR
Vehicle:
98 cam'd EJ251
Wrx Tranny,slowr than ish

Default

Are you sure you got all the air out of the cooling system?


~Josh~
ballitch is offline   Reply With Quote
Old 05-12-2009, 01:26 AM   #3
maciek
Scooby Newbie
 
Member#: 11216
Join Date: Oct 2001
Location: Denver CO
Vehicle:
1991 SS 1998 BG
1996 BD

Default

I am pretty sure all the air is gone...it's been weeks since the new thermostat and no overheating until yesterday.
maciek is offline   Reply With Quote
Old 05-12-2009, 02:03 AM   #4
rivman05
Scooby Specialist
 
Member#: 159986
Join Date: Sep 2007
Chapter/Region: AKIC
Location: YK Delta
Vehicle:
1994 Acura Integra
Milano Red

Default

If the upper is hot, lower is cold....id take out ur thermostat (possibly bad thermo) and see what happens. It sounds like whats happening is theres an obstruction somewhere, and the question about your water pump, take the cap off and see if coolant moves or not. Long shot here, have u checked your dipstick to see if u have a water jacket crack or blow out? Talking from experience with a fully blue printed motor, and they didnt replace diverter inserts and all the sudden it did the same thing.....hope its your thermostat, GL
rivman05 is offline   Reply With Quote
Old 05-12-2009, 03:14 PM   #5
WcW
Scooby Newbie
 
Member#: 209963
Join Date: Apr 2009
Default

the problem sounds like classic HG. All the symptoms mentioned were clear HG problems.
WcW is offline   Reply With Quote
Old 05-12-2009, 04:55 PM   #6
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

I have a 91 2.2 Legacy and a 98 2.5 outback with the same symptons. It is the headgasket in both of these cars.
ciper is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.5L overheating + coolant leak 05co92x Newbies & FAQs 6 06-10-2009 10:24 PM
WTB: MN Area, 97-99 2.5L DOHC longblock MadDogSTi Private 'Wanted' Classifieds 1 07-23-2008 01:20 AM
I need 2 '97-99 2.5L DOHC people for a blind taste test Patrick Olsen New England Impreza Club Forum -- NESIC 18 05-14-2007 06:18 PM
NY: 99 2.5L Forester Engine and intake manifold txl146 Engine/Power/Exhaust 2 09-13-2006 12:12 PM
WTB 99 2.5L Intake Manifold D-Speed 2.5 Private 'Wanted' Classifieds 1 10-19-2003 04:13 PM


All times are GMT -4. The time now is 09:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.