Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-20-2009, 02:33 AM   #1
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default 98 RS running rich

I just put a new motor in my 98 RS the motor was from a leggy GT and is also a 2.5 dohc but its running rich and won't idle I replaced the long block but not in the intake manifold I can smell gas and i know i have an exhaust leak on the header so any ideas as to why its running rich thanks
* Registered users of the site do not see these ads.
bigjoshsubyfan is offline   Reply With Quote
Old 05-20-2009, 01:55 PM   #2
watchunglava
Scooby Specialist
 
Member#: 168862
Join Date: Jan 2008
Chapter/Region: NESIC
Location: Portland Maine
Vehicle:
2007 ej253n/a 5speed
Red Sox Nation Lifer

Default

the 98 rs had a dohc?
watchunglava is offline   Reply With Quote
Old 05-20-2009, 03:04 PM   #3
UkNuck
Scooby Guru
 
Member#: 21808
Join Date: Jul 2002
Chapter/Region: E. Canada
Location: National Capital Region
Vehicle:
02 GroceryGettAr
Nonemore Black

Default

is this just based on the gas smell are you actually logging AFR? are we talking closed loop or open loop?

if the exhaust is leaking in the vicinity of the O2 sensor I think that can throw off the reading e.g. the sensor reads lean because of the exhaust and the ECU compensates by adding fuel
UkNuck is offline   Reply With Quote
Old 05-20-2009, 07:38 PM   #4
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

wow, that was just one big run-on sentence. And yes, the 98 had DOHC.
yarrgh is offline   Reply With Quote
Old 05-20-2009, 11:44 PM   #5
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default

yeah i do have an exhaust leek at the headers would that make it that bad though?
bigjoshsubyfan is offline   Reply With Quote
Old 05-21-2009, 12:53 AM   #6
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default

well its running better still way rich but i fixed the exhaust leak reset the ECU and i'll try agains tomorrow so if anyone has futher sugestions i'm still looking for some help thanks
bigjoshsubyfan is offline   Reply With Quote
Old 05-21-2009, 11:45 AM   #7
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default

bump still really rich runs fine at higher rms and on the first start up will idle very poorly for a while then chokes out
bigjoshsubyfan is offline   Reply With Quote
Old 05-21-2009, 08:16 PM   #8
GrundleJuice
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

how are you diagnosing that its rich?
GrundleJuice is online now   Reply With Quote
Old 05-22-2009, 02:39 AM   #9
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default

well theres alot of unburnt gas coming out and it smells bad and then theres the smoke and also the spark plugs where wet when i pulled them out and the where brand now and now have tons of build up so any help please
bigjoshsubyfan is offline   Reply With Quote
Old 05-24-2009, 10:58 AM   #10
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default

bumop for new ideas???
bigjoshsubyfan is offline   Reply With Quote
Old 05-24-2009, 12:41 PM   #11
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

you may have injectors that are stuck open. Your O2 sensor may be crappy and telling the ECU that you're running lean, causing it to fuel more. Have you cleaned your MAF sensor lately?
yarrgh is offline   Reply With Quote
Old 05-24-2009, 02:10 PM   #12
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default

MAF and 02's were you of the car for a while the 02 and the whole exhaust where sitting in the back yard for a while so those need to be checked and the MAF was sitting in the trunk for about a month so i'll clean that up too
bigjoshsubyfan is offline   Reply With Quote
Old 05-24-2009, 02:47 PM   #13
GrundleJuice
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

I'd replace the O2 if it was sitting in the elements, especially if it rained. moisture on the O2 sensor is bad when its not energized and fatal when its energized.
GrundleJuice is online now   Reply With Quote
Old 05-24-2009, 03:46 PM   #14
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default

I don't think it was ever exposed but i'll take a really good look at it and living in utah there isn't much moisture thanks though if you think of anything else please let me know the more things i eliminate the fewer things there are to check lol
bigjoshsubyfan is offline   Reply With Quote
Old 05-26-2009, 08:13 PM   #15
GrundleJuice
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

even if you dont see anything wrong visibly, you should test it. Find out what the P/N is any do some searching for how to test it. It is one of a few likely causes for your troubles.
GrundleJuice is online now   Reply With Quote
Old 05-27-2009, 12:03 PM   #16
AJ711
Scooby Specialist
 
Member#: 6178
Join Date: Apr 2001
Chapter/Region: MAIC
Location: Singletracks
Vehicle:
98 GM67 + 03 SG6
2 whls > 4 whls

Default

Replace the front O2 sensor and see what happens.

If not fixed, clean MAF sensor and see what happens.

If not fixed, start looking at injectors to see if one is seized open and pumping gas into the cylinder.
AJ711 is offline   Reply With Quote
Old 05-27-2009, 07:38 PM   #17
GrundleJuice
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

Quote:
Originally Posted by AJ711 View Post
Replace the front O2 sensor and see what happens.

If not fixed, clean MAF sensor and see what happens.

If not fixed, start looking at injectors to see if one is seized open and pumping gas into the cylinder.

The old shotgun approach... usually works eventually and costs you a bunch of $... but at least you get to replace old working parts with new working parts.
GrundleJuice is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Got my 98 RS running fishheadback Member's Car Gallery 11 06-27-2006 07:48 PM
Got my 98 RS running fishheadback Normally Aspirated with bolt-on Forced Induction Powertrain 2 06-27-2006 05:45 PM
01 rs kinda hesistating...running rich maybe? newbiescooby2.5rs Normally Aspirated Powertrain 3 04-06-2006 01:19 PM
Anyone running EManage on a 98 RS Tattoo Collector Normally Aspirated Powertrain 11 09-12-2005 10:01 PM
Running rich- very rich Hondaslayer Normally Aspirated with bolt-on Forced Induction Powertrain 19 04-12-2003 09:11 PM


All times are GMT -4. The time now is 11:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.