Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-17-2009, 03:49 PM   #1
GraimeG
Scooby Newbie
 
Member#: 64865
Join Date: Jun 2004
Vehicle:
1993 Impreza L AWD

Default Brake Lights - only work when headlights on

1993 Impreza L AWD
So my brake lights are being kind of finicky of late.

The bulbs are good
The fuse is good
Brake lights only work when headlights are on.
--Even then, the middle light (on rear windshield) sometimes lights up, sometimes not.
If the headlights are off, the brake lights do not work.

I don't think it's the pedal switch because the lights still DO work, just in specific situations. Any ideas with what could be causing the problem?
* Registered users of the site do not see these ads.
GraimeG is offline   Reply With Quote
Old 05-17-2009, 04:25 PM   #2
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

I would first suspect the grounding for the brake lights may be bad. You could prove that by making a jumper and tieing that between a good ground point and the ground side of one of the brake lights.
Cougar4 is offline   Reply With Quote
Old 05-18-2009, 04:01 PM   #3
GraimeG
Scooby Newbie
 
Member#: 64865
Join Date: Jun 2004
Vehicle:
1993 Impreza L AWD

Default

If the grounding points were bad, wouldn't that mean that the brake lights wouldn't work at all?
GraimeG is offline   Reply With Quote
Old 05-18-2009, 04:19 PM   #4
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

The trouble can be intermittent. It depends on the resistance of the bad connection at the time, which can change. By checking to see if the lights are getting power with a test light probe when you step on the brake will show you if the ground is bad or not.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
break lights on when headlights on kaio Electrical & Lighting 0 11-23-2007 06:15 PM
Horn only work when pressed on left side? Knightmare69 Service & Maintenance 3 11-20-2006 02:10 PM
Defi Gauges only on when headlights on - Help! JGary Electrical & Lighting 1 07-30-2006 03:33 PM
Greddy gauges only work when lights are off shotoyan Electrical & Lighting 5 06-04-2006 07:26 AM
STI center Brake light only HALF WORKING@!! ohforesti Interior & Exterior Modification 1 05-28-2006 11:38 PM


All times are GMT -4. The time now is 07:20 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.