Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-11-2009, 12:36 PM   #1
GeneralTJI
Scooby Specialist
 
Member#: 152680
Join Date: Jun 2007
Location: s366 Duramax self built/tuned
Vehicle:
I Parted out WRX
for my Pilots License :)

Default Holset powered 2.0 makes a couple passes down the track...

Some info/pics/video of my build: General's Homebuilt Holset

The quick run down on my project:

2002 WRX Wagon
Stock motor with just over 170,000 miles (heads have about 80,000)
Homebuilt Custom Rotated Holset setup (HE351)
Turbonetics EWG, ebay FMIC, E85, 07 STi tranny, lots of custom stuff (all piping, exhaust etc.) other mods *check that other thread, or my website: http://www.generaltji.com Car is full weight, full interior including spare.


I ran the car the other night at Bandimere. Elevation is 5900ft (5860 or something like that). It was a pretty decent time to run, but we had some headwind all evening).

I had terrible trouble getting off the line. That track hooks extremely well, but this caused issues for me because I couldn't get any tire spin. Tires at 47psi, LC at 6200. But with the 2.0, big turbo, and light flywheel it wasn't enough for a good launch. Had a best of like a 1.98 (at our other local track I've done some 1.6's, and 1.7's but it's easy to get a little spin there)

Anyway, I should have raised the LC some more, and played with my diff controller but I didn't get very many runs, it was packed.

Ran a best of a 12.3 and had a couple runs where I trapped in the 116.6mph area. I turned the boost up a little tiny bit each run.. but ended up getting my best launch in an earlier run. I need to check the slip but I think my 12.3 was at 114 or 115. I then made some 116mph passes with horrible 60ft's running a couple 12.4's.

I have the power, if this poor motor will hold together I just need 1 clean launch to do something good here! This isn't anything real exciting, but I figured I'd share.

Going to our other track where I do much better 60ft wise in about 2 weeks and we'll see what happens. Thanks for stopping by this post.
* Registered users of the site do not see these ads.
GeneralTJI is offline   Reply With Quote
Old 05-11-2009, 12:48 PM   #2
Astartes
Scooby Specialist
 
Member#: 183813
Join Date: Jul 2008
Chapter/Region: South East
Location: The REAL SC
Vehicle:
2006 WRX TR OBP
WRX STi SGM

Default

Grats man! Shoot for those 11s.
Astartes is offline   Reply With Quote
Old 05-11-2009, 01:34 PM   #3
CKxx
Scooby Specialist
 
Member#: 33458
Join Date: Feb 2003
Chapter/Region: Tri-State
Location: PA
Vehicle:
Your BOV sounds lame
93 RX7+09 Forester

Default

Nice times!
CKxx is offline   Reply With Quote
Old 05-11-2009, 02:02 PM   #4
cnstman
Scooby Specialist
 
Member#: 9548
Join Date: Aug 2001
Chapter/Region: RMIC
Location: Colorado Springs
Vehicle:
2004 WRX STi
10.266 @135.62 @ 7,520'DA

Default

nice. what day you going to PMI?
cnstman is offline   Reply With Quote
Old 05-11-2009, 02:23 PM   #5
GeneralTJI
Scooby Specialist
 
Member#: 152680
Join Date: Jun 2007
Location: s366 Duramax self built/tuned
Vehicle:
I Parted out WRX
for my Pilots License :)

Default

Planning for the 22nd. First fri night drags will probably be a crowded mess, but I'm going to try anyway

Are you thinking of going Aaron?

Last edited by GeneralTJI; 05-11-2009 at 02:28 PM.
GeneralTJI is offline   Reply With Quote
Old 05-11-2009, 02:26 PM   #6
evan_impreza
Scooby Specialist
 
Member#: 115276
Join Date: May 2006
Chapter/Region: MWSOC
Location: Joplin, MO
Vehicle:
04 PSM WRX -sold:(
98 RS- WRX swap complete!

Default

Nice! Ive been wanting to see more of your build! Keep up the good work man.
evan_impreza is online now   Reply With Quote
Old 05-11-2009, 02:27 PM   #7
cnstman
Scooby Specialist
 
Member#: 9548
Join Date: Aug 2001
Chapter/Region: RMIC
Location: Colorado Springs
Vehicle:
2004 WRX STi
10.266 @135.62 @ 7,520'DA

Default

Quote:
Originally Posted by GeneralTJI View Post
Planning for the 22nd. First fri night drags will probably be a crowded mess.

Are you thinking of going Aaron?
If I do it will be just to watch. transmission should be getting pulled this week or next for a rebuild, would like to get a few miles on the clutch before I run it.
cnstman is offline   Reply With Quote
Old 05-11-2009, 02:31 PM   #8
GeneralTJI
Scooby Specialist
 
Member#: 152680
Join Date: Jun 2007
Location: s366 Duramax self built/tuned
Vehicle:
I Parted out WRX
for my Pilots License :)

Default

Sounds good! I'm anxious to see your car run again... sob gets down
GeneralTJI is offline   Reply With Quote
Old 05-11-2009, 03:16 PM   #9
Phatron
Scooby Guru
 
Member#: 36033
Join Date: Apr 2003
Chapter/Region: SCIC
Location: Tuning Lab
Vehicle:
CEO PhatBottiTuning
2006 STi GTX3582 + Meth

Default

man....you should be golden 11's at sea level
Phatron is offline   Reply With Quote
Old 05-11-2009, 05:18 PM   #10
GeneralTJI
Scooby Specialist
 
Member#: 152680
Join Date: Jun 2007
Location: s366 Duramax self built/tuned
Vehicle:
I Parted out WRX
for my Pilots License :)

Default

Thanks guys!

I was hoping this Holset setup could get me an 11.9 and a 117mph trap (on the stock motor). The trap is right there, I could turn up the boost but I'm hoping to sneak in on a high 11 before I blow this 205 apart

Down the road, I'll finish putting together my built cammed motor and see how much power this turbo will make.

I was using the ignition cut LC when I first put my UTEC in.. it builds more boost and would have helped me get off the line. But I had to switch it back to fuel because I blew one of my remflex gaskets apart FFS w/ ign cut. Just a little too violent for those thick (and not very well re-enforced) gaskets

Eventually I'll go all copper exhaust gaskets, both shimless heads (instead of 1 ) , the good motor etc. and switch back to the ignition cut.... it's WAY more fun.
GeneralTJI is offline   Reply With Quote
Old 05-11-2009, 05:55 PM   #11
project_skyline
Scooby Specialist
 
Member#: 153880
Join Date: Jul 2007
Chapter/Region: RMIC
Location: Western Slope, Colorado
Vehicle:
03 Evo VIII
2011 STI

Default

Very nice. Maybe Ill see ya up there sometime!
project_skyline is offline   Reply With Quote
Old 05-11-2009, 06:55 PM   #12
jason miller
Scooby Specialist
 
Member#: 158313
Join Date: Sep 2007
Location: W Laf, In
Vehicle:
2003 WRX
PSM

Default

Ramflex gaskets are crap. What did you trap on your old t3/t4 setup?
jason miller is offline   Reply With Quote
Old 05-11-2009, 07:09 PM   #13
C J
Scooby Specialist
 
Member#: 132587
Join Date: Nov 2006
Location: Lincoln, NE
Vehicle:
2006 JrTuned STi
E85 GT3582r/10.83@126mph

Default

if you want to trap 117mph you should be deep into the 11s not 11.9x imo.
C J is offline   Reply With Quote
Old 05-11-2009, 07:12 PM   #14
jason miller
Scooby Specialist
 
Member#: 158313
Join Date: Sep 2007
Location: W Laf, In
Vehicle:
2003 WRX
PSM

Default

This is an ej205, not an ej257 with avcs. There have been two recent ej205's run 11.9's, and they were at 117.x and 119.x mph if I remember correctly. Coolrex went 11.6, but at 124.

Last edited by jason miller; 05-11-2009 at 07:17 PM.
jason miller is offline   Reply With Quote
Old 05-11-2009, 10:09 PM   #15
STi Mikey
Scooby Specialist
 
Member#: 114631
Join Date: May 2006
Chapter/Region: Tri-State
Location: TheShopCT / EFI LOGICS
Vehicle:
2009 GTR, 735whp
13' Benz, 15' WRX

Default

Quote:
Originally Posted by GeneralTJI View Post
Some info/pics/video of my build: General's Homebuilt Holset

The quick run down on my project:

2002 WRX Wagon
Stock motor with just over 170,000 miles (heads have about 80,000)
Homebuilt Custom Rotated Holset setup (HE351)
Turbonetics EWG, ebay FMIC, E85, 07 STi tranny, lots of custom stuff (all piping, exhaust etc.) other mods *check that other thread, or my website: http://www.generaltji.com Car is full weight, full interior including spare.


I ran the car the other night at Bandimere. Elevation is 5900ft (5860 or something like that). It was a pretty decent time to run, but we had some headwind all evening).

I had terrible trouble getting off the line. That track hooks extremely well, but this caused issues for me because I couldn't get any tire spin. Tires at 47psi, LC at 6200. But with the 2.0, big turbo, and light flywheel it wasn't enough for a good launch. Had a best of like a 1.98 (at our other local track I've done some 1.6's, and 1.7's but it's easy to get a little spin there)

Anyway, I should have raised the LC some more, and played with my diff controller but I didn't get very many runs, it was packed.

Ran a best of a 12.3 and had a couple runs where I trapped in the 116.6mph area. I turned the boost up a little tiny bit each run.. but ended up getting my best launch in an earlier run. I need to check the slip but I think my 12.3 was at 114 or 115. I then made some 116mph passes with horrible 60ft's running a couple 12.4's.

I have the power, if this poor motor will hold together I just need 1 clean launch to do something good here! This isn't anything real exciting, but I figured I'd share.

Going to our other track where I do much better 60ft wise in about 2 weeks and we'll see what happens. Thanks for stopping by this post.
Wow

Congrats on the motor holding up this long, that is damn impressive man and even more impressive that this project was home built. I know elevation is a killer but trapping 116 can yield mid-high 11 1/4 times.

EDIT: Did you try going through the water box to get some spin out of the tires?

Good luck next day out and congrats again!!

Last edited by STi Mikey; 05-11-2009 at 10:16 PM.
STi Mikey is offline   Reply With Quote
Old 05-12-2009, 01:41 AM   #16
GeneralTJI
Scooby Specialist
 
Member#: 152680
Join Date: Jun 2007
Location: s366 Duramax self built/tuned
Vehicle:
I Parted out WRX
for my Pilots License :)

Default

Quote:
Ramflex gaskets are crap. What did you trap on your old t3/t4 setup?
Yea they are not the greatest. Probably work well on an NA setup.

I trapped a best of 113mph, once. 112 usually.

Quote:
if you want to trap 117mph you should be deep into the 11s not 11.9x imo.
Getting a good 60ft could potentially bring my ET down a bunch. I was just stating I would be extremely happy to get this setup in the 11's whether it be an 11.99 or better. I need to get out of the hole harder (1.7 would be good enough), but I try not to beat my car and hopefully can avoid breaking the stock 170k axles / rear diff. A lot of 2.5 cars with a heavy flywheel and not so over-sized turbo seem to do some impressive stuff especially in the 1/8! my car seems to be more of a back half car at the moment lol.. with the Holset I picked up 28mph on most of those runs.




Quote:
Wow

Congrats on the motor holding up this long, that is damn impressive man and even more impressive that this project was home built. I know elevation is a killer but trapping 116 can yield mid-high 11 1/4 times.

EDIT: Did you try going through the water box to get some spin out of the tires?
Thank you!!

I didn't try that.. (DUH). I also didnt turn down my spiider diff controller very far (manual controller).. I have no idea what I was thinking while at the track.. just kept raising my LC thinking it would make enough difference
GeneralTJI is offline   Reply With Quote
Old 05-12-2009, 11:48 AM   #17
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

the 116 trap is a good sign
All4bSpinnin is offline   Reply With Quote
Old 05-12-2009, 11:57 AM   #18
Audiosavvy
Scooby Guru
 
Member#: 150794
Join Date: Jun 2007
Chapter/Region: SCIC
Location: Bakersfield, CA
Vehicle:
Qcab dakota 4x4
LT1 Formula Firebird

Default

116 at Bandimere is MOVING!!! Good job Todd!
Audiosavvy is offline   Reply With Quote
Old 05-12-2009, 07:54 PM   #19
TDagen
Scooby Specialist
 
Member#: 163648
Join Date: Nov 2007
Chapter/Region: MWSOC
Location: Minnesota, mpls
Vehicle:
2002 Wrx,2.5L,HTA86
E85,2007 6mt,No traction

Default

Nice work! That 2.0 just keeps putting out...lol... How are you digging the 07 6mt at the track?
TDagen is offline   Reply With Quote
Old 05-12-2009, 10:37 PM   #20
jmlaser
Scooby Specialist
 
Member#: 125529
Join Date: Sep 2006
Chapter/Region: MWSOC
Location: Central Ohio
Vehicle:
02 WRX 18G EJ205
1/4 mi stock block record

Default

Quote:
Originally Posted by jason miller View Post
This is an ej205, not an ej257 with avcs. There have been two recent ej205's run 11.9's, and they were at 117.x and 119.x mph if I remember correctly. Coolrex went 11.6, but at 124.
I was one of them,,... It was 11.9 @ 117
117 will get you there on the 5 speed,... maybe its that extra shift thats killing you? ( I am assuming you are shifting into 5th with your 6 ).
Anyhow these are great times! You would be wicked at closer to sea level
jmlaser is offline   Reply With Quote
Old 05-12-2009, 10:49 PM   #21
JSarv
Scooby Specialist
 
Member#: 163445
Join Date: Nov 2007
Chapter/Region: MWSOC
Location: Effingham IL (Central IL)
Vehicle:
l33t *******
12.07@115.9mph-EJ205

Default

No he has an 07 tranny he gets to leave it in 4th until just over 120

Todd - I'll have a v8 6mt in my car in a few weeks and going to go make a pass or two down the 1/8th!

Sweet times - To bad your not at sea level!!!


-Jerod
JSarv is offline   Reply With Quote
Old 05-12-2009, 11:19 PM   #22
jmlaser
Scooby Specialist
 
Member#: 125529
Join Date: Sep 2006
Chapter/Region: MWSOC
Location: Central Ohio
Vehicle:
02 WRX 18G EJ205
1/4 mi stock block record

Default

Quote:
Originally Posted by JSarv View Post
No he has an 07 tranny he gets to leave it in 4th until just over 120

Todd - I'll have a v8 6mt in my car in a few weeks and going to go make a pass or two down the 1/8th!

Sweet times - To bad your not at sea level!!!


-Jerod
Ooo I missed that, Sweet. I forgot about those,... makes me want one!
jmlaser is offline   Reply With Quote
Old 05-12-2009, 11:23 PM   #23
JSarv
Scooby Specialist
 
Member#: 163445
Join Date: Nov 2007
Chapter/Region: MWSOC
Location: Effingham IL (Central IL)
Vehicle:
l33t *******
12.07@115.9mph-EJ205

Default

I dunno gears are to long for my taste - I'm used to my Honda H with a close ratio trans.. I even hated the 5mt...

I'm a big fan of very long 1st (around 45-50mph) and then keep em close after that...

-jerod
JSarv is offline   Reply With Quote
Old 05-13-2009, 02:54 AM   #24
GeneralTJI
Scooby Specialist
 
Member#: 152680
Join Date: Jun 2007
Location: s366 Duramax self built/tuned
Vehicle:
I Parted out WRX
for my Pilots License :)

Default

Thanks for the comments guys

Quote:
Nice work! That 2.0 just keeps putting out...lol... How are you digging the 07 6mt at the track?

It's working out well. I'm just sneaking through the lights before I hit the rev limiter (7350)

I won't be able to trap much higher though without making a shift.. but I have a set of cams for my motor I'm putting together which should get a couple hundred more usable rpm's out of it in 4th.. so hopefully that will let me keep it in 4th even then. So basically it's pretty well geared for the sub 120 traps w/o cams.



EDIT Check out what I built tonight. (4" intake piping, huge AMSOIL fender filter) and the v-band cutout (other side of v-band is a plug).. oh these 11's are going to be mine! (maybe, if it doesn't sh$tcan that is) ... actually these mods probably won't make any noticeable difference right now....




Last edited by GeneralTJI; 05-13-2009 at 02:43 PM.
GeneralTJI is offline   Reply With Quote
Old 05-19-2009, 09:56 AM   #25
CoolRex
*** Banned ***
 
Member#: 85813
Join Date: Apr 2005
Chapter/Region: South East
Location: Myrtle Beach, SC
Vehicle:
2002 E46 M3
2006 RC51

Default

At that sea level you got 11's man easily. Do what I do....go through the water box. Get to the line back up and mini launch to sling the heavy water off. Then give er all ya got! You want those tires to spin but I understand with a big turbo it's hard!
CoolRex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple subbys at the track e2blade Member's Car Gallery 12 02-09-2010 01:00 PM
A couple pics from the track in my 06 bhhamblin Member's Car Gallery 31 03-14-2008 01:24 PM
looking to get the timebomb faster down the track... OMG_WTF Factory 2.5L Turbo Powertrain 47 11-29-2007 04:34 PM
06-07 Forester XT 5mt power handling limits? And a couple Qs about the recent 5MTs Davenow Transmission (AT/MT) & Driveline 12 05-02-2007 11:30 PM
('93-'01) Saw a couple WRXs at the track last night TTA89 Impreza Forum 3 08-09-2001 03:50 PM


All times are GMT -4. The time now is 09:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.