Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-21-2011, 05:01 PM   #501
httrdd
Scooby Newbie
 
Member#: 224180
Join Date: Sep 2009
Default

Very nice. I am going to copy your flares for my wide body H6 ok?!!! Lol.

Oh and the hood ram supports mod is a must!
* Registered users of the site do not see these ads.
httrdd is offline   Reply With Quote
Old 04-28-2011, 01:18 PM   #502
Huffer
Scooby Specialist
 
Member#: 36735
Join Date: May 2003
Chapter/Region: MWSOC
Location: Wellington,NZ / Willoughby,OH
Vehicle:
99 GF8 Impreza 2.0
2= 1998 BD + BK Legacy GT

Default

Right now, even with the sick engine-tranny combo you have, it's not a garage queen. Just sitting out in the open.

WOW.
Johann, you do some amazing stuff. Any clue as to why it won't run properly?
Huffer is offline   Reply With Quote
Old 04-28-2011, 03:12 PM   #503
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

Yeah the crank trigger is apparently the wrong one from an N/A post 2000 engine. It fires at a different degree before top dead center so I just need to swap it with a WRX one. I should be on the road Sunday fingers crossed.

Johann @ Girodisc
girodisc is offline   Reply With Quote
Old 04-28-2011, 06:22 PM   #504
httrdd
Scooby Newbie
 
Member#: 224180
Join Date: Sep 2009
Default

Good luck!
httrdd is offline   Reply With Quote
Old 05-02-2011, 06:26 PM   #505
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

So a bit of an update. Took the car apart to do the timing thing and it looked good but for sake of eliminating it all together I swapped the gear and installed a new timing belt with marks on it and triple checked it make sure the timing was spot on. Put it all back together and nothing changed. So to check if the ECU was bad I swapped a 2.5 hydra from a wrx in the car to see if it would start and it fired right up but wouldn't idle. Perplexed I waited till today and talk to Phil.

Together we have determined the possible reason for all this pain. My hydras harness is custom for the WRX swap so it has flying leads for the individual coilpacks. The injector pin-outs 1-4 coincide with the cylinders. Pin-out Injector 1 goes to piston 1 and so on. The spark for whatever reason is base on firing order so 1-1, 2-3, 3-2, 4-4 so we think that I have the 3rd and 2nd cylinder wired up backwards. This also has more weight because Phil says that the older hydras start the care by firing sequentially and the ver 2.5 hydras do a batch spark. Meaning that my hydra won't start my car because it not firing in the right order and the 2.5 will fire my car because it fires all the coils at the same time but won't idle because it the firing order is wrong. I don;t know for sure but I have the check the routing of my coils to make sure they are all good. If not then that should fix it. If they are then I am back at square one....

LOL I'll prolly dive into this on Wed since its the only sunny day of the week and the car is stuck out side.

Johann @ Girodisc
girodisc is offline   Reply With Quote
Old 05-02-2011, 08:50 PM   #506
nategr8ns
Scooby Specialist
 
Member#: 198413
Join Date: Dec 2008
Chapter/Region: NESIC
Location: Maine / Juanita, WA
Vehicle:
1999 Impreza OBS 5sp
Silver and Gray

Default

Lol, I wish I had the talent to deal with that sorta thing. I don't know nothin' about car wiring/computers.
nategr8ns is offline   Reply With Quote
Old 05-05-2011, 11:54 AM   #507
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

So I swapped the Coil Wires and she LIVES! starts right up and the engine sounds great no leaks no knock, just a bunch of fuel in the exhaust. So right now I am chasing a couple gremlins with a high idle. Trying to figure out if its tuning or a vacuum leak so I will keep you posted but I's say I should be driving her to work again starting Monday fingers crossed.

Johann @ Girodisc
girodisc is offline   Reply With Quote
Old 05-09-2011, 01:58 PM   #508
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

Drove her for the first time in almost 5 months Sat. Shes got good power but definitely needs a tune. Going in tomorrow at 10 for that. I am bringing the 2.5 hydra with me just in case the 2.14 keep giving me starting issues.

Johann @ Girodisc
girodisc is offline   Reply With Quote
Old 05-10-2011, 05:50 PM   #509
Newbuggy
Scooby Specialist
 
Member#: 152042
Join Date: Jun 2007
Chapter/Region: NWIC
Location: Lynden, WA
Vehicle:
2002 WRX
WRB

Default

I was just on a test drive and I saw her on a flat bed I hope everything is OK.
Newbuggy is offline   Reply With Quote
Old 05-11-2011, 06:02 PM   #510
BeBop86
Scooby Guru
 
Member#: 147776
Join Date: May 2007
Chapter/Region: NWIC
Location: Bellingham, WA
Vehicle:
'02 Impreza WRX
'85 Toyota Corolla

Default

He said while he was getting it tuned yesterday that the car got rod knock said and the engine is no good anymore.

Last I heard the 2.0l is going back in...
BeBop86 is offline   Reply With Quote
Old 05-11-2011, 06:11 PM   #511
Kraziken
Scooby Specialist
 
Member#: 38629
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Northwest
Vehicle:
1999 Legacy GT (STI)
White

Unhappy

Quote:
Originally Posted by BeBop86 View Post
He said while he was getting it tuned yesterday that the car got rod knock said and the engine is no good anymore.

Last I heard the 2.0l is going back in...
Lame
Kraziken is offline   Reply With Quote
Old 05-12-2011, 10:40 AM   #512
Newbuggy
Scooby Specialist
 
Member#: 152042
Join Date: Jun 2007
Chapter/Region: NWIC
Location: Lynden, WA
Vehicle:
2002 WRX
WRB

Default

damn it.
Newbuggy is offline   Reply With Quote
Old 05-12-2011, 11:51 AM   #513
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

Okay its been a long couple days. Got her to the dyno. Got about 5 pulls in and everything was going well. Made 281whp/ 305 ftlbs at 17ish psi and we were going to shoot for 19-21 psi and the rod in the 2nd cylinder let go. Tick tick tick and my day was done. Got the car towed home. and

Got the car on the lift and at 3:00pm we got started

Pulled all the crap
Pulled the engine
Striped it down to a short block
Grabed my other 2.0L stock WRX Block.
Reassmbled the engine and got it ready to put back in the Car.

1:00am Went to Bed

11:00am Wed after going to a few places to get parts we started again.

Made a new Up-pipe because I decided to swap the N/A Borla header and up-pipe out for a STI Turbo Header.
Re-plumbed my Wastegate to dump to atmos
Notched the Crossmeber to fit the new Up-pipe
Installed a new larger Intercooler core because the one I had in there was to small to make 300whp
Repainted my Intercooler Pipes
Re-installed EVERYTHING

11:00pm fired her up and drove her with great success. She runs and drives great and the only issue I have is that it hits ether fuel or boost cut in like forth if I put it to the floor but its still considerably faster at just 3/4 throttle. I will get it checked out when I go back to Doms. This should be good enough to get me to the Auto X in the condition its in but if I can get a slight alteration to my tune in time I will try and get this thing buttoned up for good.

Setup dosen't look much different except there is a stock intake manifold on it and everything is now wrinkle black.

Johann @ Girodisc
girodisc is offline   Reply With Quote
Old 05-12-2011, 05:53 PM   #514
BeBop86
Scooby Guru
 
Member#: 147776
Join Date: May 2007
Chapter/Region: NWIC
Location: Bellingham, WA
Vehicle:
'02 Impreza WRX
'85 Toyota Corolla

Default

New intake manifold wouldn't fit?

Can the new block handle over 20psi being an semi-closed deck?

Is the 2.2l block repairable?

Nice Job!!!
BeBop86 is offline   Reply With Quote
Old 05-12-2011, 06:03 PM   #515
monovich
Scooby Specialist
 
Member#: 8124
Join Date: Jul 2001
Location: Denver, Colorado
Vehicle:
1998 Old Grey Mule
Regacy Rype R

Default

wow. nice save! if only I could just swap an engine out like you can. bravo.
monovich is offline   Reply With Quote
Old 05-12-2011, 06:40 PM   #516
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

I donno about the 2.2L block but I am thinking of making a 2.4L stroker higher comp for more power and better suited for auto x. I'll prolly be around 19psi all tuned out. The new intake manifold is crap. I need to return it and bitch at them. I'll make my own after the move is done.

Johann @ Girodisc
girodisc is offline   Reply With Quote
Old 05-13-2011, 10:42 PM   #517
redlegacygt
Scooby Specialist
 
Member#: 82994
Join Date: Mar 2005
Chapter/Region: MAIC
Location: Danville, PA
Vehicle:
1997 Legacy GT
Rio Red

Default

i love how you turn adversity into a chance to go into a different direction, without being deterred.. lol your work truly is amazing, and i'm so glad your doing it all on a legacy! Keep up the great work man!
redlegacygt is offline   Reply With Quote
Old 05-16-2011, 11:49 AM   #518
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

So Auto Xing. Took my 1st win in the Lego and 2nd win for the season so far. The Lego performed very well. It had a couple issues but both can be resolved.

1st was my suspension. My stance coilovers have performed great for me and gotten me through 2 seasons of auto x and all the other **** I do to them but all the abuse has taken their toll. Once I got the car back on the road to do some shakedown testing I notice the car felt kinda floaty and I kept hearing a clunk every time I shifted the weight of the car. FInally figured out that the holes for the strut perch where the hub bolts to the coilover have started to wear and become oval shaped so my hub is clicking back and forth basically giving me live camber adjustment. So the remedy is the get new coilovers (I kinda wanted to upgrade to the Stance XRs) or new perches. We will see.

The second issue is the turbo. In the dry the car performed amazing on this course. This is one of our faster course and it was enough to put more over a second ahead of the competition with more room to shave time. But Yesterday the racers were given the opportunity to run the course again for test and tuning. It was pouring so I was there getting a fell for the Lego in the rain. The slower speeds took a toll on the Legos performance. Where I was getting a 54.7 with room to easily hit a low 54 or high 53 I was getting a 57.6 and giving it all I had (provided I had the suspension issue which was more apparent in the rain) but the biggest issue was that I would out of the boost curve. I have a VF39 on there now but I have a stock TD04 that I am going to port and install to get a better boost curve. It will be less power but on the track I will be able to utilize more of it then with my VF39.

So that's it. I have 3 vids I'll be posting up in the next day or two. 2 quick ones and a fun run for my my last run since I already had the win for my class.

Johann @ Girodisc
girodisc is offline   Reply With Quote
Old 05-16-2011, 12:02 PM   #519
BeBop86
Scooby Guru
 
Member#: 147776
Join Date: May 2007
Chapter/Region: NWIC
Location: Bellingham, WA
Vehicle:
'02 Impreza WRX
'85 Toyota Corolla

Default

:sigh: I had horrible results last autoX

You're car sounded freakin awesome though! They did get the decible meter out for your BOV lol (loudest part).
BeBop86 is offline   Reply With Quote
Old 05-16-2011, 02:14 PM   #520
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

Really? What did it hit? It will be louder next time with the smaller turbo because I will be at full 19psi more often. lol. The vids I have you can;t really hear it. Its prolly to high pitched I need to use the good camera next time.

Getting new coilovers. I just pulled the trigger on the XRs so that should be a huge improvement over what I have now. Much better damping, better rates, and a lot lighter. Once my suspension is in check and my smaller turbo is installed and I get tuned the Lego will be unstoppable.

Johann @ Girodisc
girodisc is offline   Reply With Quote
Old 05-16-2011, 02:25 PM   #521
BeBop86
Scooby Guru
 
Member#: 147776
Join Date: May 2007
Chapter/Region: NWIC
Location: Bellingham, WA
Vehicle:
'02 Impreza WRX
'85 Toyota Corolla

Default

Not sure, but it was pretty loud.

Yeah, the lower quality mic might not be able to record that range.

What are you doing with the old stances? use them on the GC sedan?
BeBop86 is offline   Reply With Quote
Old 05-16-2011, 03:39 PM   #522
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

Prolly put them in Kristens car. I'll put her stuff back in the Sedan. Or sell them to Dan. Kristen needs to buy them (not for very much) but I need to dampen the blow of the new Coils.

Johann @ Girodisc
girodisc is offline   Reply With Quote
Old 05-16-2011, 03:46 PM   #523
BeBop86
Scooby Guru
 
Member#: 147776
Join Date: May 2007
Chapter/Region: NWIC
Location: Bellingham, WA
Vehicle:
'02 Impreza WRX
'85 Toyota Corolla

Default

I'm selling my KYB AGX struts tonight (I read that they would lift the GC, so you'd probably not want them) but the guy is removing some Cusco Coilovers to replace them with... maybe you'd want those for the GC?
BeBop86 is offline   Reply With Quote
Old 05-16-2011, 04:51 PM   #524
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

meh looks like Dans going to pick them up. Unless Kristen really wants them. Looks like I am going to red line the ol CC this week. LOL

Johann @ Girodisc
girodisc is offline   Reply With Quote
Old 05-17-2011, 05:44 PM   #525
girodisc
Former Vendor
 
Member#: 177674
Join Date: Apr 2008
Chapter/Region: NWIC
Location: B-ham WA
Default

Got some Pics from the last auto X... I'll have the vids posted up tomorrow.



Little Drifting Action..







Still getting use to no ABS... LOL





And some nice pics at the end of the day.







Johann @ Girodisc
girodisc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My rs project rs420 Vancouver Impreza Club Forum -- VIC 31 06-07-2010 12:12 AM
Secret Lego Vault Of Every Lego Set. SonicScooby27 Off-Topic 64 07-04-2008 10:36 AM
lego indiana jones and lego batman migs76 Off-Topic 14 04-17-2008 09:56 AM
Lego project, target - reliability Hyper Factory 2.5L Turbo Powertrain 7 09-28-2004 08:10 AM


All times are GMT -4. The time now is 05:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.