Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
New England Subaru Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > New England Impreza Club Forum -- NESIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-15-2000, 04:06 PM   #1
IMPREZAmike
Scooby Newbie
 
Member#: 169
Join Date: Aug 1999
Location: Warwick and smAlbany NY
Vehicle:
98 black OBS
move bi*ch get out da way

Have a Nice Day? PLEASE READ!!!! need advise (is my clutch broke?)

Today i took my car to Concord Subaru to get my oil changed. Please note that my car was running perfect before my visit this morning. I picked up the car and went back to work, and everything semed fine. On my drive home from work, i noticed a burning rubber/clutch smell and when i shifted into 5th gear.....THERE WAS NO 5TH GEAR! The car just reved real high, but nothing happened. ***?!?!? I am going to drive around a bit more on the highway later to see if it is still messed up. If its stll the same, what can i do? What are my rights? Etc Etc? Is my clutch blown? damn concord subaru.
* Registered users of the site do not see these ads.
IMPREZAmike is offline   Reply With Quote
Old 12-16-2000, 09:47 AM   #2
BoomerRS
Scooby Specialist
 
Member#: 1271
Join Date: Apr 2000
Location: W Hartford, CT USA
Vehicle:
98 RS
****in Rally Blue

Post

weird.
concord subaru didnt drive your car at all did they?
i think that you potentially have a transmission problem, not a clutch problem. although the burning smell... hmmm. i have read some people having the fifth gear not work. did u check the tranny fluid level under the hood?
BoomerRS is offline   Reply With Quote
Old 12-17-2000, 05:33 PM   #3
BoomerRS
Scooby Specialist
 
Member#: 1271
Join Date: Apr 2000
Location: W Hartford, CT USA
Vehicle:
98 RS
****in Rally Blue

Wink

hey mike
still having problems.
5th gear is all the way to the right and up by the way .
BoomerRS is offline   Reply With Quote
Old 12-17-2000, 06:51 PM   #4
breaka19
Scooby Newbie
 
Member#: 2288
Join Date: Sep 2000
Location: Boylston, MA
Post

Boomer and his smart ass comments strike again.
breaka19 is offline   Reply With Quote
Old 12-17-2000, 07:26 PM   #5
JGard
pooptastic
 
Member#: 1904
Join Date: Jul 2000
Chapter/Region: TXIC
Location: Austin, TX
Vehicle:
2014 Lexus IS 350
01 Miata red

Post

yeah, if all your other gears work, but not 5th...then the clutch is fine. There is a problem with 5th gear. It blew, most likely, which isn't something i'd think to happen normally. That would be covered by warranty, i would think.
JGard is online now   Reply With Quote
Old 12-18-2000, 05:26 AM   #6
Mumbles
Scooby Guru
 
Member#: 248
Join Date: Sep 1999
Chapter/Region: NESIC
Post

Yeah i blew my entire tranny, all the bearings and stuff, now it's fine. All unser warranty.

-B
Mumbles is offline   Reply With Quote
Old 12-18-2000, 05:51 AM   #7
IMPREZAmike
Scooby Newbie
 
Member#: 169
Join Date: Aug 1999
Location: Warwick and smAlbany NY
Vehicle:
98 black OBS
move bi*ch get out da way

Post

Well, i drove it a bit this weekend.....as little as possible, but still got it on the highway a bit. The first time i shifted into 5th, the engin just reved, and i got this god-awful burning smell (like rubber...maybe clutch?) So i downshifted and slowed a bit and waited for the smell to go away (about 5 minutes) and then tried 5th again and this time it worked. I gave it several more attempts and it only happened once more, but i still got that nasty burning smell. Everything worked fine this morning too, but i got a little burning smell again....***?!?!? What is the waranty on the gears? Is it covered under drivetrain? (probablly a dumb question) not psyched on the smell, i'll tell you that!

thanks for that tip Boomer

//m
IMPREZAmike is offline   Reply With Quote
Old 12-18-2000, 09:50 AM   #8
BoomerRS
Scooby Specialist
 
Member#: 1271
Join Date: Apr 2000
Location: W Hartford, CT USA
Vehicle:
98 RS
****in Rally Blue

Post

i just wanted to make sure you werent going all the way to the right and down.

transmission is indeed part of the drivetrain.
BoomerRS is offline   Reply With Quote
Old 12-18-2000, 02:28 PM   #9
Jude DeMeis
Scooby Newbie
 
Member#: 491
Join Date: Nov 1999
Chapter/Region: NESIC
Location: Boston, Ma, USA
Vehicle:
1995 Legacy race car
Pan Am Blue

Wink

Brendan,

The Al Unser warranty? I thought drag racers were covered by the "Big Daddy" Don Garlits warranty?

THE JUDE
Jude DeMeis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unique AC Problem Please Read and Advise? (i did search!) jeffstar Service & Maintenance 11 05-15-2010 12:51 PM
Wastegate flutter??please read and advise.. sammyswrxsti Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 20 06-18-2007 07:45 PM
If you played atari please read! Need help!!! Sephro Off-Topic 29 12-08-2005 02:53 PM
Please Read!! Need Help subee13 Transmission (AT/MT) & Driveline 7 10-09-2005 11:11 PM
early 30k self-service.. please read and advise bailey454 South East Region Forum 19 12-11-2004 11:43 AM


All times are GMT -4. The time now is 12:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.