Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-24-2009, 06:01 AM   #1
STiRA-435
Scooby Newbie
 
Member#: 191564
Join Date: Oct 2008
Chapter/Region: International
Location: Auckland, NZ
Vehicle:
1999 WRX STi RA V-L
WRB

Default Part Identification Help

I was wondering if anyone could recognised this part. I assume it fell off something as I was removing my OEM struts for a coilover install as it was lying on the ground under the right rear of my car.





At first I thought it was part of the brake assembly but being made of soft rubber it would melt under the heat given off

Thanks for the help
* Registered users of the site do not see these ads.
STiRA-435 is offline   Reply With Quote
Old 05-24-2009, 05:26 PM   #2
kreitz3
Scooby Specialist
 
Member#: 100242
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: Ohio
Default

I'm going to guess it was some debris from the road that got flung up and was sitting on top of your spring pearch. It doesn't look like anything I have ever seen on my car.

Somebody correct me if I'm wrong.
kreitz3 is offline   Reply With Quote
Old 05-25-2009, 09:16 AM   #3
Turn in Concepts
NASIOC Vendor
 
Member#: 93646
Join Date: Aug 2005
Chapter/Region: MWSOC
Vehicle:
Many Track Records
Let us help you go fast!

Default

Never seen anything like that on a Subaru. I call road debris as well.

Tony
Turn in Concepts is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with part identification atlblu General Community 1 07-06-2008 10:34 AM
Engine part identification help... 02blueru Factory 2.0L Turbo Powertrain 2 05-12-2008 03:03 PM
Part identification help needed Trin_Starr Legacy Forum 4 03-28-2006 10:23 AM
Part Identification Help stimpy Subaru Conversions 16 08-24-2003 04:00 PM
part identification alphamale Interior & Exterior Modification 5 06-07-2002 03:06 PM


All times are GMT -4. The time now is 03:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.