Welcome to the North American Subaru Impreza Owners Club Thursday October 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > UTEC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-24-2009, 01:02 PM   #1
2.5racer
Scooby Newbie
 
Member#: 12482
Join Date: Nov 2001
Location: Lakewood, Co
Vehicle:
2000 RS w/ej20 & e85
94 RX-7 1/2bridge w/meth

Default Soooo... my utec fried :(

Very odd thing. I was cruising home from a bar, got about 2 miles with 2 miles left to go, when I hear a small pfffft sound. My engine died and I turned onto a side road quickly, then saw a good deal of smoke come from my ecu area. I pulled the ecu and utec apart and saw a good sized black mark on the back of the utec pcboard. I have no idea what could have caused this cause i've had this ecu for I think 4 years... and I haven't touched it in a long time.

This sucks and I doubt turboxs will help me out, since the warrenty is way past expired.
* Registered users of the site do not see these ads.
2.5racer is offline   Reply With Quote
Old 05-25-2009, 07:59 PM   #2
alberto95
Scooby Newbie
 
Member#: 211818
Join Date: May 2009
Location: Puerto Rico
Vehicle:
2003 Wrx
Silver

Default

Youre not alone, mine fried last week after just two weeks of owning it. tried to start the car and it wont start, kept starting it in confusion until i saw smoke coming from under the carpet, i ran and disconnect the battery.. pulled the carpet and smoke all over, took out the utec and it has a big black burnt spot on the board, its dead! after that car ran fine.. no clue!

turbo xs wont help, i just ordered another one...
alberto95 is offline   Reply With Quote
Old 05-26-2009, 12:43 PM   #3
2.5racer
Scooby Newbie
 
Member#: 12482
Join Date: Nov 2001
Location: Lakewood, Co
Vehicle:
2000 RS w/ej20 & e85
94 RX-7 1/2bridge w/meth

Default

Hmm I called turbo xs and they said they'd send me a new delta utec for 550 after they get mine.

Was yours brand new? or was it used?

The biggest bummer is that I'll have to do a full retune, because I don't have any of my maps saved to my computer... thats a mistake I'll never do again.
2.5racer is offline   Reply With Quote
Old 05-27-2009, 04:01 PM   #4
BlackJavaPearl04
Scooby Specialist
 
Member#: 198522
Join Date: Dec 2008
Chapter/Region: Tri-State
Location: Up State NY
Vehicle:
98 LGT Limited
00 LGT -WRX swap

Default

wow Ive always wondered about this possibility.

Luckily there is readily available in the nasioc classifieds section an abundance of old utecs for sale!
BlackJavaPearl04 is offline   Reply With Quote
Old 05-27-2009, 04:55 PM   #5
2.5racer
Scooby Newbie
 
Member#: 12482
Join Date: Nov 2001
Location: Lakewood, Co
Vehicle:
2000 RS w/ej20 & e85
94 RX-7 1/2bridge w/meth

Default

Yeah there are, however I've decided to go open source. I was kinda tired of the whole crossover lag when the utec takes control. Plus since I've decided to start doing my own tuning, I don't want to deal with tuning both the ecu and the utec (it's just one more thing that can go wrong).
2.5racer is offline   Reply With Quote
Old 05-27-2009, 07:07 PM   #6
BlackJavaPearl04
Scooby Specialist
 
Member#: 198522
Join Date: Dec 2008
Chapter/Region: Tri-State
Location: Up State NY
Vehicle:
98 LGT Limited
00 LGT -WRX swap

Default

I simply love the SD function, and by matching the crossover afr's and ecu timing a smooth trans can be had...not to mention launch control ffs and on the fly map switching! ...spare solenoids... shift lights... the list goes on

Of course in combo with open source makes it even better, to turn off certain cels and various other parameter adjustments.... flashing for big ass injectors. IMHO

I have not used any serious stand alone management systems. I'm far too much of an amateur tuner, which is why I like the utec...not knocking it or anything... after all it was created to be a User Tunable Engine Computer combined with logging software makes it kinda fool proof as long as you know your limits.

I could go on but everyone who uses a UTEC already knows why they still bother to keep it after all of the other choices on the market.
BlackJavaPearl04 is offline   Reply With Quote
Old 05-28-2009, 10:45 AM   #7
crampfan
Scooby Specialist
 
Member#: 74321
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: clarksville AR
Vehicle:
2004 wrx wag
black UTEC stg 4

Default

Quote:
Originally Posted by BlackJavaPearl04 View Post

I could go on but everyone who uses a UTEC already knows why they still bother to keep it after all of the other choices on the market.
+10!!
crampfan is offline   Reply With Quote
Old 05-28-2009, 11:52 AM   #8
ride5000
Scooby Guru
 
Member#: 32792
Join Date: Feb 2003
Chapter/Region: NESIC
Location: lincoln, ri
Vehicle:
2003 GGA MBP
12.9 / 105+

Default

i'm running almost completely SD on a utec because my maf sensor is toasted, and i don't feel like paying for another one.

anything above 1% tps is completely utec SD.
ride5000 is online now   Reply With Quote
Old 05-31-2009, 03:41 PM   #9
alberto95
Scooby Newbie
 
Member#: 211818
Join Date: May 2009
Location: Puerto Rico
Vehicle:
2003 Wrx
Silver

Default

bought mine used first time, and i liked it the short time i had it so i got another one used from a member of this forum. If it happens again im totally done with utecs! hope not...
alberto95 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
utec fried stamps31757 Other Engine Management 2 10-24-2009 11:12 PM
Soooo, my car wont start. Arctic Assassian Pre-2002 Factory Turbo Powertrain 2 08-09-2007 03:01 AM
so I think my utec is fried ZSensi18 UTEC 1 12-13-2006 05:14 PM
Stolen In Orange/anaheim My Ae86 Corolla :( :( :( variant Off-Topic 94 12-23-2004 01:34 PM
Gasoline spilled in my trunk! HELP :( :( Mrs.COS Off-Topic 19 06-21-2004 11:13 AM


All times are GMT -4. The time now is 12:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.