Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-27-2009, 01:45 AM   #1
rdp2401
Scooby Specialist
 
Member#: 156736
Join Date: Aug 2007
Chapter/Region: SCIC
Location: Simi Valley
Vehicle:
1993 Impreza L
burgundy

Default Headlight and foglight problem

i have a 2007 wrx, i noticed today that my driver's side headlight and foglight are not working. i checked the wiring and didnt see anything out of place. also looked at the fuse and found nothing. when i turn the car on i hear the light come on then stop. would something be wrong with the headlight relay? i am not familar at all with electrical, so please help.
* Registered users of the site do not see these ads.
rdp2401 is offline   Reply With Quote
Old 05-27-2009, 11:04 AM   #2
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

If the fuse is ok and power is passing through it then I would suspect the relay for that side has a problem.
Cougar4 is offline   Reply With Quote
Old 05-27-2009, 04:58 PM   #3
Big-E
NASIOC Supporter
 
Member#: 123843
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2006 WRX Sedan SGM
Let LED's light your way!

Default

Quote:
Originally Posted by Cougar4 View Post
If the fuse is ok and power is passing through it then I would suspect the relay for that side has a problem.
Yes, check the fuses.

Fog lights = 1 relay for both
Headlights = 1 relay per side

Possibly the connector to the headlamp assembly is bad?
Big-E is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlight and Foglight Problem emsmap Electrical & Lighting 11 09-21-2007 01:56 PM
Headlight and Foglight problems Baccata Electrical & Lighting 1 11-03-2005 12:06 AM
Headlight and Foglight Wattage??? nuburu2 Legacy Forum 10 05-30-2001 05:37 PM
Replacement Bulbs for the Headlights and Foglights c-shell Newbies & FAQs 8 11-14-2000 11:52 PM


All times are GMT -4. The time now is 11:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.