Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-29-2009, 01:56 AM   #1
XanRules
NASIOC Supporter
 
Member#: 157348
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Benghazi
Vehicle:
1996 JNCO Jorts
Stonewashed Denim

Default Need help wiring my GC Morettes

So I managed to pick up a set of Morettes. Here's the problem.

When I turn my lights on, the driver's side low beam lights up in full, the passengers' side is very dim. When I hit the stalk to turn the high beams on, the driver's side low beam stays on, the driver's side high beam does not come on. The passengers' side low beam goes off, the passengers' side high beam comes on in full.

I'm using the bulbs that came with the lights, I don't know how many miles are on them, etc. The relays and wiring looks correct from the diagrams I've seen. All the connections are good and clean.

Here are the questions.
Is this most likely a problem with
1. The wiring harness
2. The bulbs
3. The relays

and how do I fix this?
Thanks everyone in advance, every little bit helps.
* Registered users of the site do not see these ads.
XanRules is offline   Reply With Quote
Old 05-29-2009, 02:41 AM   #2
XanRules
NASIOC Supporter
 
Member#: 157348
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Benghazi
Vehicle:
1996 JNCO Jorts
Stonewashed Denim

Default

it's the bulbs, I've decided. I switched the two low-beam bulbs out and tried again. The driver's side doesn't come on at all, while the passengers' side came on full blast. Switching to high beams, the driver's side still doesn't come on - the high beam came on on the passengers' side, and the passengers' side low-beam stayed on. This leads me to conclude that the bulbs draw power from each other through the relays.
Neat. Figured my own problem out.
XanRules is offline   Reply With Quote
Old 11-02-2009, 01:03 PM   #3
voyagerman
Scooby Newbie
 
Member#: 42133
Join Date: Aug 2003
Location: Ciales,Puerto Rico
Vehicle:
2002 Impreza WRX
Rally Blue Pearl

Default

The morettes comes with three relays ,for subaru 2002,.check those relays,remove the caps, they are suceptible to damage due to poor water resistance .I get a similar problem and when i removed the caps of the relays two of the three relays were totally corroded.I begin to experiment intermittence and the lights begin to turn on and off or one side turn on while the other keeps off.
let me know what you find.
voyagerman is offline   Reply With Quote
Old 11-02-2009, 03:31 PM   #4
XanRules
NASIOC Supporter
 
Member#: 157348
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Benghazi
Vehicle:
1996 JNCO Jorts
Stonewashed Denim

Default

Quote:
Originally Posted by voyagerman View Post
The morettes comes with three relays ,for subaru 2002,.check those relays,remove the caps, they are suceptible to damage due to poor water resistance .I get a similar problem and when i removed the caps of the relays two of the three relays were totally corroded.I begin to experiment intermittence and the lights begin to turn on and off or one side turn on while the other keeps off.
let me know what you find.
I fixed this issue after the thread was posted in May.
I have since retrofitted the Morettes.
XanRules is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
i need help locating my battery wire veightkiller Electrical & Lighting 4 01-19-2006 04:38 PM
need help painting my morettes kinks19 Texas Impreza Club Forum -- TXIC 0 02-04-2005 10:28 PM
need help wiring my amp, Im a car audio n00b :( newb Car Audio, Video & Security 9 01-31-2004 11:19 AM
need help with my stock/morette lights!! gooter80 General Community 5 10-23-2002 10:17 AM
Need help wiring my antenna JGard Car Audio, Video & Security 6 02-05-2002 09:14 AM


All times are GMT -4. The time now is 02:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.