Welcome to the North American Subaru Impreza Owners Club Saturday July 4, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Motorsports

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-29-2009, 04:45 AM   #1
wopdeeze
Scooby Newbie
 
Member#: 148597
Join Date: May 2007
Vehicle:
00 GDA Jet Black
04 GGA PSM 10 SH5 XT

Default mishap at ebisu circuit

well winter has passed and time attack season has started again. couple things changed on my car this season. switched to a TD05H/16G, 235/45/17 RE070s, cusco rear adjustable trailing arms, cusco rear adjustable lateral links, whiteline roll center adjust kit, R32 GTR Calipers an 04 sti rotors with ebc yellow pads. everything was going fine, but it wasn't hitting as high of top speeds as the last time i was on the track. anyways after a couple popped off intercooler hoses i was getting in the groove with 1:09.35, 1:09.20. 1:08.90, coming around for a last lap before cool down my brake pedal got rock hard and i had no brakes. here is the carnage.











Well after all this, since i have to paint 2 doors and a fender, going to go wide body :-)
* Registered users of the site do not see these ads.
wopdeeze is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-29-2009, 07:40 AM   #2
rjrutzky
Scooby Specialist
 
Member#: 30367
Join Date: Nov 2002
Chapter/Region: South East
Location: nashville, tn
Vehicle:
2005 Legacy GT
NASA SE PTB Champ

Default

Quote:
Originally Posted by wopdeeze View Post
going to go wide body :-)
blessing in disguise. What happened with your brakes?
rjrutzky is offline   Reply With Quote
Old 05-29-2009, 08:12 AM   #3
boost junkie
Top Scoob 009
 
Member#: 68273
Join Date: Aug 2004
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
2012 WRX
GD Race Car in progress

Default

Sucks that it's damaged but in the grand scheme it looks like you got away with one. It could have been a LOT worse.
boost junkie is offline   Reply With Quote
Old 05-29-2009, 08:29 AM   #4
wopdeeze
Scooby Newbie
 
Member#: 148597
Join Date: May 2007
Vehicle:
00 GDA Jet Black
04 GGA PSM 10 SH5 XT

Default

Still don't know what happened with my brakes, after i got pulled out of the tires my brakes worked fine. it felt like i lost vacuum to the master cylinder booster. it did shake me up a little bit, after that i was in the 1:10's. you are right it could have been alot worse, i was heading straight for the wall head on at 140kph, lucky for me and the time of year in japan the ground stays pretty moist so my tires were able to dig through the dirt to slow me down a bit, plus a little e-brake to rotate the car slightly to setup for a side impact, as i got closer to the end of the pavement i realized an impact was inevitable so i figured a couple body panels is cheaper than another engine. messed up part about the whole thing, i won a full set of Spec C doors the night before, that i was bidding on for the glass.. moral of the story don't bid on something the night before, because you will probably need it sooner than you expected.
wopdeeze is offline   Reply With Quote
Old 05-29-2009, 08:32 AM   #5
HighwayStarPP
Scooby Specialist
 
Member#: 174548
Join Date: Mar 2008
Chapter/Region: South East
Location: FL
Vehicle:
2002 impreza
flat black

Default

sorry to hear about your accidents, what did you have to do to the r32 caliper to make it fit? custom bracket? or just bolt on.

sell me your headlights kthxbai
HighwayStarPP is offline   Reply With Quote
Old 05-29-2009, 09:56 AM   #6
MasterKwan
Scooby Guru
 
Member#: 98961
Join Date: Oct 2005
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2003 WRX
Black

Default

You're lucky, the times I've ever hit something on track always resulted in a totalled car... Maybe you should stick with Brembo's? Are the R32 brakes actually better than Brembo's?

I really want your fog covers too.
MasterKwan is offline   Reply With Quote
Old 05-29-2009, 10:26 AM   #7
wopdeeze
Scooby Newbie
 
Member#: 148597
Join Date: May 2007
Vehicle:
00 GDA Jet Black
04 GGA PSM 10 SH5 XT

Default

quit parting my car with your eyes!

r32 calipers use a bracket, i created a post about it in the technical forum. anyways if they are better than brembos they are about the same, just a smaller pad sweep on the rotor, but the fact that i can use z32/gtr/gtst/subaru 4 pot pads makes it a little easier on the wallet for me the fact that the sti brembos are still fetching a pretty penny (i assume the gold paint on them is real gold) the nissan calipers provides me the use of 324mm x 30mm rotors for much better cooling. if i could afford some decent 18's and tires i want to try the GTR vspec brembos, with my calculations i figure that i would use a 355mm rotor with them and the same brackets im using. just trying to find the 355mm rotor might be a problem though.
wopdeeze is offline   Reply With Quote
Old 05-29-2009, 12:54 PM   #8
mateospeed
Scooby Newbie
 
Member#: 116317
Join Date: May 2006
Chapter/Region: South East
Location: VIR, CMP, RRR
Vehicle:
2002 WRX...sold:-(

Default

Better count your blessings, dude... That's some pretty amazingly minor damage for a no-brakes off! I'm very impressed your escaped so unscathed!

Time to break out the buffer!

-Matt
mateospeed is offline   Reply With Quote
Old 05-29-2009, 01:06 PM   #9
DJSuperSoul
Scooby Specialist
 
Member#: 120004
Join Date: Jul 2006
Chapter/Region: NWIC
Location: beavertron
Vehicle:
2xx8 STI
grey

Default

check the hose to the master cylinder. hell, just get a new one.
DJSuperSoul is offline   Reply With Quote
Old 05-29-2009, 01:36 PM   #10
Homemade WRX
Scooby Guru
 
Member#: 33782
Join Date: Mar 2003
Chapter/Region: MAIC
Location: 3MI Racing LLC
Vehicle:
96 bastard child
search FIRST, then PM!!!

Default

wwoooo, glad you are ok and the damage is minimal. So when are you getting back stateside?
Homemade WRX is offline   Reply With Quote
Old 05-29-2009, 08:09 PM   #11
wopdeeze
Scooby Newbie
 
Member#: 148597
Join Date: May 2007
Vehicle:
00 GDA Jet Black
04 GGA PSM 10 SH5 XT

Default

yeah im going to replace the vacuum lines just as a precaution, car is 9 years old things get old before you know it.

thanks micha, not sure, really enjoy it over here having tracks on every corner is very nice ;-)
wopdeeze is offline   Reply With Quote
Old 05-29-2009, 09:09 PM   #12
elirentz
Scooby Specialist
 
Member#: 70082
Join Date: Sep 2004
Chapter/Region: South East
Location: charleston, sc
Vehicle:
2005 sti, 02 s2000
88 944 beater

Default

Yeah one of the few times you can say "It will buff right out" and for the most part mean it. Good quick thinking and a little luck went a long way.
elirentz is offline   Reply With Quote
Old 05-31-2009, 12:54 AM   #13
kursplat
Scooby Newbie
 
Member#: 89528
Join Date: Jun 2005
Vehicle:
2005 sti
crystal grey

Default

sure you wern't left foot braking and bled off the vacume?
kursplat is offline   Reply With Quote
Old 05-31-2009, 01:21 AM   #14
wopdeeze
Scooby Newbie
 
Member#: 148597
Join Date: May 2007
Vehicle:
00 GDA Jet Black
04 GGA PSM 10 SH5 XT

Default

yeah, i was only trying to brake will all my weight and nothing happened
wopdeeze is offline   Reply With Quote
Old 05-31-2009, 02:19 AM   #15
Wizzelt
Scooby Specialist
 
Member#: 107512
Join Date: Feb 2006
Vehicle:
2005 Audi S4
Moro Blue

Default

going straight when it happened or into the turn? Pad knock back possible?
Wizzelt is offline   Reply With Quote
Old 05-31-2009, 02:52 AM   #16
wopdeeze
Scooby Newbie
 
Member#: 148597
Join Date: May 2007
Vehicle:
00 GDA Jet Black
04 GGA PSM 10 SH5 XT

Default

going straight off throttle getting ready to go into the turn.
wopdeeze is offline   Reply With Quote
Old 06-01-2009, 05:59 PM   #17
PhantomPilot
Scooby Newbie
 
Member#: 202275
Join Date: Feb 2009
Chapter/Region: PRSIC
Location: Coral Springs, FL
Vehicle:
2003 Impreza WRX
Sedona Red

Default

Sorry to see a Suby wrinkled up, dosen't look that bad. That does look like you could buff it out, maybe touch-up paint.
PhantomPilot is offline   Reply With Quote
Old 07-27-2009, 08:23 PM   #18
wopdeeze
Scooby Newbie
 
Member#: 148597
Join Date: May 2007
Vehicle:
00 GDA Jet Black
04 GGA PSM 10 SH5 XT

Default

after the first coat of paint, still need to wet sand and spray some more color on it but im finally making some progress.



wopdeeze is offline   Reply With Quote
Old 07-27-2009, 10:15 PM   #19
Element Tuning
Former Vendor
 
Member#: 54918
Join Date: Feb 2004
Chapter/Region: MAIC
Location: Gaithersburg, MD
Vehicle:
673 WHP Element
Tuning Pro Comp Engine

Default

Glad you're ok. It sounds like your brake booster pressure/vacuum line came loose, the one way valve stuck open, or your booster is bad. At the very lease replace the line and valve with a new oem piece and check the booster for a leaking diaphram.

Typically for the pedal to go rock hard the booster has to see boost pressure which means the pedal still should have come back after a second or two unless your throttle was still open/stuck.

Thanks
Phil Grabow
Element
Element Tuning is offline   Reply With Quote
Old 07-28-2009, 12:14 AM   #20
wopdeeze
Scooby Newbie
 
Member#: 148597
Join Date: May 2007
Vehicle:
00 GDA Jet Black
04 GGA PSM 10 SH5 XT

Default

Quote:
Originally Posted by Element Tuning View Post
Glad you're ok. It sounds like your brake booster pressure/vacuum line came loose, the one way valve stuck open, or your booster is bad. At the very lease replace the line and valve with a new oem piece and check the booster for a leaking diaphram.

Typically for the pedal to go rock hard the booster has to see boost pressure which means the pedal still should have come back after a second or two unless your throttle was still open/stuck.

Thanks
Phil Grabow
Element

Phil,

Thanks, yeah i replaced both lines and i have another booster/mc just in case. havent had any problems since, but my nerves are still a little on edge the last time i went up to hakone for touge.

also for anybody deciding to use EBC yellow pads... dont waste your money, after this one event they are toast. ill post more when i get closer to the finish product.. and get my 255s mounted :-)
wopdeeze is offline   Reply With Quote
Old 07-28-2009, 07:28 PM   #21
parker/slc/gc8fan
Scooby Specialist
 
Member#: 46241
Join Date: Oct 2003
Chapter/Region: RMIC
Location: 4401 Procorpio Dr.
Vehicle:
- RIP
SDF-1

Default

Are those new wheels or just spacers?

good job and luck getting back out there, Hope I can do the same.
parker/slc/gc8fan is offline   Reply With Quote
Old 07-28-2009, 09:51 PM   #22
wopdeeze
Scooby Newbie
 
Member#: 148597
Join Date: May 2007
Vehicle:
00 GDA Jet Black
04 GGA PSM 10 SH5 XT

Default

Quote:
Originally Posted by parker/slc/gc8fan View Post
Are those new wheels or just spacers?

good job and luck getting back out there, Hope I can do the same.
Thanks! you too.
Same wheels with added spacers to fill in the 20mm front over fenders and the rear 50mm blister fenders.
wopdeeze is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Drags at Nago Circuit 9 Apr on Okinawa old_duwel Member's Car Gallery 25 05-02-2006 01:39 AM
endlink/swaybar installation mishap at dealer culturedetox Brakes, Steering & Suspension 25 10-21-2005 09:31 PM
Caught at Ebisu Circuit AVOjapan Member's Car Gallery 50 08-28-2005 02:41 PM
anybody wanna buy my spot at import circuit? suby ej25 Tri-State Area Forum 10 05-05-2004 09:14 AM
Hyper Meeting 2002 at Tsukuba Circuit - Impreza vs. Lancer [pics/link] j y Motorsports 0 05-15-2002 05:08 PM


All times are GMT -4. The time now is 01:39 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.