Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Motorsports > Autocross

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-01-2009, 06:05 PM   #26
distorto
Top Scoob 024
 
Member#: 56364
Join Date: Mar 2004
Chapter/Region: International
Location: houston, texas
Vehicle:
RIP stompr :(
bagged vulvva

Default

sending you a pm now.
* Registered users of the site do not see these ads.
distorto is offline   Reply With Quote
Old 06-01-2009, 07:59 PM   #27
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

PM received.
JamesWilson2 is offline   Reply With Quote
Old 06-03-2009, 04:13 PM   #28
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

Omni runs great...on ether from a can.

Bad fuel lines....replaced all with new. New larger fuel filter, the old one you could not pour fuel or carb cleaner through it, it was so old and nasty. Probably killed the fuel pump, it won't turn on when +12V is directly applied or run through the stock system.

WARNING: Subaru Content!

Getting a stock WRX pump and throwing it in the tank, a good cheap replacement. Maybe Walbro 255 in the future, but too rich for my blood.

Car: $50
Wal-Mart Paint: $8
Fuel Lines: $11
Fuel Filter: $10
Spark Plugs: $10
AutoZone Rewards: -$20
Mount Falken Azenis: $20
Sell one set of whees: -$40

TOTAL INVESTMENT: $49.00





somebody check my math haha
JamesWilson2 is offline   Reply With Quote
Old 06-03-2009, 04:55 PM   #29
PKer
Scooby Specialist
 
Member#: 27647
Join Date: Oct 2002
Chapter/Region: SCIC
Location: 69 Datsun SPL311
Vehicle:
06 MX-5-STR 03WRX
(ret), 08 Titan-Tow

Default

OMG that's so awesome!
PKer is offline   Reply With Quote
Old 06-03-2009, 05:01 PM   #30
BlkWRXWag
Scooby Specialist
 
Member#: 31821
Join Date: Jan 2003
Chapter/Region: SCIC
Location: Vorshlag Motorsports/Chase Cam
Vehicle:
2006 STR MX5
WRB BRZ Limited

Default

Funny, I remember that car as a Talbot Horizon in England.
BlkWRXWag is offline   Reply With Quote
Old 06-03-2009, 05:06 PM   #31
PKer
Scooby Specialist
 
Member#: 27647
Join Date: Oct 2002
Chapter/Region: SCIC
Location: 69 Datsun SPL311
Vehicle:
06 MX-5-STR 03WRX
(ret), 08 Titan-Tow

Default

Hey James: It looks like your lawn needs to be mowed.
PKer is offline   Reply With Quote
Old 06-03-2009, 05:40 PM   #32
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

Quote:
Originally Posted by PKer View Post
Hey James: It looks like your lawn needs to be mowed.
DONE, on Sunday . That was just after one week! Stupid something something Houston.
JamesWilson2 is offline   Reply With Quote
Old 06-03-2009, 10:34 PM   #33
Storm
Scooby Guru
 
Member#: 5218
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: SAUL'S Motorsports
Vehicle:
96L Most Over-
Developed Beater

Default

Quote:
Originally Posted by BlkWRXWag View Post
Funny, I remember that car as a Talbot Horizon in England.
Thank the lord that Chrysler changed the front end from the Talbot...... That was one ugly sumbich!

James, that is so awesome!!!! You totally have a future in the GRM 2009-2010 challenge!!!!

Jay
Storm is offline   Reply With Quote
Old 06-04-2009, 10:08 PM   #34
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

JamesWilson2 is offline   Reply With Quote
Old 06-04-2009, 10:14 PM   #35
doggieboy09
Scooby Newbie
 
Member#: 207629
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Norcal
Vehicle:
2009 had WRX stage 2
now own BRZ

Default

hell yeah! Goes Like Hell!
doggieboy09 is offline   Reply With Quote
Old 06-06-2009, 06:29 PM   #36
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

Well turns out the Hall Effect Pickup (HEP) is intermittant on this car, and it's $54. Looks like I'll have to wait until after the 15th for payday, was really hoping to have the car at the autocross tomorrow. Bummer.

It'll run for like 10 minutes and then the electronics in the HEP overheat...sits inside the distributor beneath the cap.
JamesWilson2 is offline   Reply With Quote
Old 06-08-2009, 06:56 AM   #37
Storm
Scooby Guru
 
Member#: 5218
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: SAUL'S Motorsports
Vehicle:
96L Most Over-
Developed Beater

Default

Check it for dirt before you go spending money. You can (at least I could on an 87 car) see the window the sensor looks though.

Jay
Storm is offline   Reply With Quote
Old 06-08-2009, 03:42 PM   #38
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

Cleaned both the pickups inside as well as both connectors...has to be something bad internally. A friend says he has a spare one that was barely intermittant (shows how crappy they are!) and it is for an '85, so I may borrow that one to check. Otherwise, the car is running and idling well. Yesterday's autocross course would have been awesome for the Omni, but it was better that I did not take the car down there-- ended up getting really sick all afternoon and evening, bummer. That, and we got news that one of our fellow autocrossers had died unexpectedly on Friday, really a huge loss for the community and I was really sad on Sunday
JamesWilson2 is offline   Reply With Quote
Old 06-10-2009, 11:40 AM   #39
miata_racer
Scooby Newbie
 
Member#: 109358
Join Date: Mar 2006
Chapter/Region: TXIC
Location: Pearland
Vehicle:
2007 STI
Blue

Default

I'm glad my old course got used. One of the more fun ones I have designed.

James I have a customer who owns this place and can get all the stuff you need for that car http://www.fwdperformance.com
miata_racer is offline   Reply With Quote
Old 06-10-2009, 04:28 PM   #40
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

Yup, went over to see Cindy at FWD Performance last Saturday, looks like I will be getting my coilovers and some other bits from them once the car is up and running. Gave her a bunch of my spares that I was not going to use, in exchange for future "help".
JamesWilson2 is offline   Reply With Quote
Old 06-14-2009, 11:58 PM   #41
miata_racer
Scooby Newbie
 
Member#: 109358
Join Date: Mar 2006
Chapter/Region: TXIC
Location: Pearland
Vehicle:
2007 STI
Blue

Default

yep she's a cool chick
miata_racer is offline   Reply With Quote
Old 06-15-2009, 12:01 AM   #42
XanRules
NASIOC Supporter
 
Member#: 157348
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Benghazi
Vehicle:
1996 JNCO Jorts
Stonewashed Denim

Default

interesting fact. The rear wheels will fit a Subaru. 5x100, correct offset and all.
XanRules is offline   Reply With Quote
Old 06-15-2009, 12:12 AM   #43
XanRules
NASIOC Supporter
 
Member#: 157348
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Benghazi
Vehicle:
1996 JNCO Jorts
Stonewashed Denim

Default

Also, forgot to mention. Nifty little car.
XanRules is offline   Reply With Quote
Old 06-15-2009, 10:22 AM   #44
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

Got it running again last night, but intermittantly dropping spark. Need to pick up a fuel pressure tester/gauge and spark tester this week. Put in a new HEP and nothing changed, may be an ASD Relay. When the family comes home from the hospital, I'll get back to working on it.
JamesWilson2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Differentials for an SM/SP car subydude Autocross 27 07-10-2013 02:49 PM
Oh Snap, my new car!(56k beware?) ScubaruImpreza05 Tri-State Area Forum 1 04-26-2006 03:44 PM
I bought an STI part today and my car is faster 2003 sedan Texas Impreza Club Forum -- TXIC 6 01-03-2003 09:56 PM
Oh snap! The car I have been looking for is for sale! stiguy555 Off-Topic 28 08-08-2002 01:39 AM
Oh my god! I just bought an EJ20! 22B_WannaBe General Forum Archive 25 08-03-2000 03:22 PM


All times are GMT -4. The time now is 06:11 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.