Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-02-2009, 02:11 PM   #1
nylions
Scooby Newbie
 
Member#: 179551
Join Date: May 2008
Location: Oregon
Vehicle:
2003 WRX
World Rally Blue

Default TURN SIGNALS? Nothing?

okay so here is the deal my wife has a 2006 impreza wagon and recently her turn signals just stopped working you hit the lever nothing on the outside and nothing on the inside in the dash? checked the fuses and they looked good? so what could be my problem? relay? please help
* Registered users of the site do not see these ads.

Last edited by nylions; 06-02-2009 at 02:49 PM. Reason: spelling
nylions is offline   Reply With Quote
Old 06-02-2009, 09:15 PM   #2
Spore
Scooby Specialist
 
Member#: 100117
Join Date: Nov 2005
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2009 Impreza 2.5i
Satin White Pearl

Default

It might be the turn indicator stalk with a loose connection (or malfunction). Have you check that yet?
Spore is offline   Reply With Quote
Old 06-03-2009, 12:33 AM   #3
nylions
Scooby Newbie
 
Member#: 179551
Join Date: May 2008
Location: Oregon
Vehicle:
2003 WRX
World Rally Blue

Default

not yet what do i have to pull to get to that?
nylions is offline   Reply With Quote
Old 06-03-2009, 02:27 AM   #4
nylions
Scooby Newbie
 
Member#: 179551
Join Date: May 2008
Location: Oregon
Vehicle:
2003 WRX
World Rally Blue

Default

check it and nothing????
nylions is offline   Reply With Quote
Old 06-03-2009, 04:19 PM   #5
SonicWRX
Scooby Specialist
 
Member#: 24464
Join Date: Sep 2002
Chapter/Region: MWSOC
Location: Cincinnasti
Vehicle:
2007 WRX STi (SWP)
Surgeline Tuned

Default

Try cycling the hazards button.

Turn it on: do hazards flash?

Turn it off: did they go off?

Now do the turn signals work?
SonicWRX is online now   Reply With Quote
Old 06-03-2009, 09:51 PM   #6
Spore
Scooby Specialist
 
Member#: 100117
Join Date: Nov 2005
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2009 Impreza 2.5i
Satin White Pearl

Default

Quote:
Originally Posted by nylions View Post
not yet what do i have to pull to get to that?
I can't recall in my memories and can't seem to find my technical manual for my bugeye. But you will need to remove the steering column covers and there should be a few screws that bolts the stalk in place.
Spore is offline   Reply With Quote
Old 06-04-2009, 01:15 AM   #7
bcware
Scooby Newbie
 
Member#: 190724
Join Date: Oct 2008
Chapter/Region: NESIC
Location: NH
Vehicle:
2008 2.5i Sedan
Lightning Red

Default

no one suggested checking the flasher? the flasher is just a relay that can eventually go bad. do the hazards work?
bcware is offline   Reply With Quote
Old 06-04-2009, 07:27 AM   #8
Cougar4
Scooby Guru
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

It is important to see if the flashers are working like SonicWRX and Bcware suggested. If not then the flasher needs to be replaced, if power has been verified that it is getting to the flasher first.
Cougar4 is offline   Reply With Quote
Old 06-04-2009, 06:48 PM   #9
nylions
Scooby Newbie
 
Member#: 179551
Join Date: May 2008
Location: Oregon
Vehicle:
2003 WRX
World Rally Blue

Default

the hazards do work i cycled them and nothing. weird that the hazards will make the turn signals work but they don't work from the column?
nylions is offline   Reply With Quote
Old 06-05-2009, 05:06 AM   #10
Cougar4
Scooby Guru
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

The hazard switch switches power to the turn signal module so be sure power is getting to the brn/red wire of the turn signal module. If that is ok then maybe the turn signal module is bad.
Cougar4 is offline   Reply With Quote
Old 06-05-2009, 10:52 AM   #11
423894
Scooby Newbie
 
Member#: 201438
Join Date: Jan 2009
Default

Did you recently do any sort of electrical modifications? If so you will need to plug in a code reader and reset the codes for your car. The same thing happened to me about 2 weeks ago.
423894 is offline   Reply With Quote
Old 06-05-2009, 12:35 PM   #12
Cougar4
Scooby Guru
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

Quote:
Originally Posted by 423894 View Post
Did you recently do any sort of electrical modifications? If so you will need to plug in a code reader and reset the codes for your car. The same thing happened to me about 2 weeks ago.
Resetting the codes will have nothing to do with the blinkers working. If that happened when you cleared yours it really wasn't due to that action.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Front turn signal, brake light, and running light won't turn off Floor it Electrical & Lighting 0 06-27-2009 11:34 PM
im sure its been beatin to death but my search turned up nothing pestysti Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 5 02-22-2004 06:01 PM
Turning the side marker light into a turn signal romanom Interior & Exterior Modification 3 03-20-2002 09:48 AM
('93-'01) WRX turn signal bulb size?????? BkylnWReX Impreza Forum 0 06-02-2001 06:19 PM


All times are GMT -4. The time now is 11:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.