Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-02-2009, 05:39 PM   #1
KitchenerWRX
Scooby Specialist
 
Member#: 79934
Join Date: Jan 2005
Chapter/Region: E. Canada
Location: Kitchener, Ontario
Vehicle:
02 WRX
MBP

Default Cruise Control Not Working (02 WRX)

Hey guys, I've had this problem for as long as I can remember and it's been bugging me a lot lately since I find myself doing more and more long road trips which I could actually use the CC.

I have a GC8 steering wheel installed with a WRX clock spring and was wondering if this had anything to do with it? I noticed the cruise control stalk is on the right side of the steering wheel now and I'm wondering if it's even working since it's a GC8 wheel?

The orange cruise light turns on, and the white nub on the clutch assembly is still in place and the button is pressed in when the clutch is released so it's not that.

What else could it be? What fuse should I be checking for in the pannel? I'm really stumped
* Registered users of the site do not see these ads.
KitchenerWRX is offline   Reply With Quote
Old 06-03-2009, 12:33 PM   #2
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

IIRC check fuse 6, 8, and 16 in your dash

if its not a fuse, it could be many things
the module in the kick panel could be back
the module in the engine bay could be bad
the switch in the steering wheel could be bad
even though the cruise light lights up, it could possibly be messed up

but the one i think it is if its not a fuse somewhere is probably the clutch/brake adjustments
Jncominco2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise control not working? whatawgn Texas Impreza Club Forum -- TXIC 11 11-16-2006 02:29 PM
Cruise control not working? whatawgn Texas Impreza Club Forum -- TXIC 6 11-16-2006 09:18 AM
Cruise Control not working (light comes on fine tho) neko Electrical & Lighting 5 09-17-2006 12:35 AM
'02 WRX Cruise Control NOT WORKING 02RallyWRX Service & Maintenance 8 06-26-2006 11:28 AM


All times are GMT -4. The time now is 12:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.