Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-04-2009, 11:24 AM   #1
lucky13_tc
Scooby Newbie
 
Member#: 203850
Join Date: Feb 2009
Location: NW suburbs of Chicago, IL
Vehicle:
09 Impreza OBS
Silver

Default 08 09 impreza mystery connectors...

I have an 09 OBS and I was messing around with some sound deadening and was ripping up the floor of the front passenger side. There was a black plate that I removed that was covering this:




First of all, what is that exactly?

But my main question, on top of the plate, before I removed it, there was this literally just hanging there:





They look like they will connect to each other but I didn't try to do that not wanting to find out the repercussions.
This doesn't seem like it goes into the box shown above though. Oh well...

WHAT ARE THESE GREEN CONNECTORS THAT I SEE HERE? HELP!

Thanks!
* Registered users of the site do not see these ads.
lucky13_tc is offline   Reply With Quote
Old 06-04-2009, 11:27 AM   #2
DreadScourge
Scooby Newbie
 
Member#: 201184
Join Date: Jan 2009
Chapter/Region: International
Vehicle:
2001 WRX

Default

I believe that's the ECU. Can anyone confirm?
DreadScourge is offline   Reply With Quote
Old 06-04-2009, 12:32 PM   #3
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by DreadScourge View Post
I believe that's the ECU. Can anyone confirm?
yaeh....and dont mess with any of the wiring unless you know exactly what it is and does
Uncle Scotty is offline   Reply With Quote
Old 06-04-2009, 09:00 PM   #4
danmezz
Scooby Newbie
 
Member#: 126339
Join Date: Sep 2006
Chapter/Region: South East
Location: Tampa, FL
Vehicle:
2003 WRX Wagon
WRB

Default

in 03 impreza wrx's that green plug is used when programming the ECU. If you plug them together (at least in 03's) the car goes into test mode and all sorts of lights and relays start flashing... I'd definitely leave it unplugged
danmezz is offline   Reply With Quote
Old 06-04-2009, 10:05 PM   #5
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

The box is indeed the ECU and the green plugs are for doing diagnostic testing. They should only be tied together when doing that.
Cougar4 is online now   Reply With Quote
Old 06-05-2009, 11:04 AM   #6
lucky13_tc
Scooby Newbie
 
Member#: 203850
Join Date: Feb 2009
Location: NW suburbs of Chicago, IL
Vehicle:
09 Impreza OBS
Silver

Default

Well thanks for the info! I will not plan on connecting them and nor did I plan on it. I was curious if it was for some sort of upgrade that was a plug and play or something.
lucky13_tc is offline   Reply With Quote
Old 06-05-2009, 01:14 PM   #7
skingfreak
Scooby Specialist
 
Member#: 152591
Join Date: Jun 2007
Chapter/Region: MWSOC
Location: Wisconsin
Vehicle:
2010 Jetta TDI Cup
Jet Black

Default

Quote:
Originally Posted by danmezz View Post
in 03 impreza wrx's that green plug is used when programming the ECU. If you plug them together (at least in 03's) the car goes into test mode and all sorts of lights and relays start flashing... I'd definitely leave it unplugged
^^^This. Same on the 04' WRX. You connect them to use an Access Port (ECU Reflash)
skingfreak is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 - 09 Impreza iPod Interface (no charge capability) sin13 Car Audio, Video & Security 28 07-08-2009 01:10 PM
DIY 08-09 Impreza iPod Mod SP.XVII Interior & Exterior Modification 23 01-23-2009 01:01 AM
Interesting new 08-09 Impreza wing Magic Marker Impreza Forum 5 12-23-2008 01:48 PM
08 - 09 Impreza warranty Recall Komd1ver Warranty Issues & SOA Problems 3 11-21-2008 04:53 PM
08/09 Impreza, no hitch? RightyTighty General Community 11 09-09-2008 02:42 PM


All times are GMT -4. The time now is 03:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.