Welcome to the North American Subaru Impreza Owners Club Wednesday October 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-08-2009, 05:12 PM   #1
vividwrx13
Scooby Specialist
 
Member#: 66402
Join Date: Jul 2004
Chapter/Region: SWIC
Location: Phoenix,AZ
Vehicle:
2005 STi Ver8
OBP

Default Gimmick Motorsports Thermostat 160*?opinions?

DELETE...did some reading and this will be ok
* Registered users of the site do not see these ads.

Last edited by vividwrx13; 06-08-2009 at 08:22 PM.
vividwrx13 is offline   Reply With Quote
Old 06-08-2009, 08:30 PM   #2
fastnoypi
Scooby Specialist
 
Member#: 6886
Join Date: May 2001
Chapter/Region: Tri-State
Vehicle:
MY01 EJ207 HTA35r
nothing to see, i'm stock

Default

your ecu wont go into limp mode but during winter months it cracks open too early so warmup takes way longer. Otherwise its fine any other time of the year
fastnoypi is online now   Reply With Quote
Old 06-09-2009, 01:07 PM   #3
Smoby
Scooby Specialist
 
Member#: 97642
Join Date: Oct 2005
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2002 Wrx Sedan
MBP

Default

Why are you avcs challenged fastnoypi? Says in your sig, I could prob help get it working what setup do you have?

I think I have the gimmick 170 and a koyo radiator and even in this heat it takes forever to heat up. Only bad part about that is my car is avcs challenged until it gets close to operating temp.
Smoby is offline   Reply With Quote
Old 06-09-2009, 01:29 PM   #4
fastnoypi
Scooby Specialist
 
Member#: 6886
Join Date: May 2001
Chapter/Region: Tri-State
Vehicle:
MY01 EJ207 HTA35r
nothing to see, i'm stock

Default

pm'd you smoby. my situation has nothing to do with operating temps.
fastnoypi is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Crucial Racing Thermostat 160degree iheartmysuby Engine/Power/Exhaust 13 10-24-2009 10:02 PM
NEW coolsafe thermostat 160* SAABARU_92x Engine/Power/Exhaust 2 09-17-2008 02:03 PM
Gimmick/Crucial Thermostat? White GDA Service & Maintenance 5 02-20-2008 04:11 PM
The Gimmick Motorsports 160 and 170 Degree Thermostat Group Buy!! IMPORTIMAGE Vendor 'Group Buy' Classifieds 41 08-28-2006 01:56 PM


All times are GMT -4. The time now is 11:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.