Welcome to the North American Subaru Impreza Owners Club Monday May 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-11-2009, 01:52 PM   #26
Prevent
*** Banned ***
 
Member#: 149114
Join Date: May 2007
Location: I'm too mainstream
Default

Hm, there's really no reason you should be idling poorly.... injectors and tgv's or not...

I know many people with TGV deletes and 850cc injectors it idles like stock. (Illinois residents)


Should talk to your tuner about it...
* Registered users of the site do not see these ads.
Prevent is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-11-2009, 03:04 PM   #27
Sb22284
Scooby Specialist
 
Member#: 168386
Join Date: Jan 2008
Chapter/Region: MWSOC
Location: LITH, IL
Default

Threw another P0457 again on my second tank of gas. Same mileage in as the first one ~45

and the idling is only bad when i first start the car.
Sb22284 is offline   Reply With Quote
Old 06-11-2009, 07:11 PM   #28
zeropsi
*** Banned ***
 
Member#: 175453
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: wilCO, IL
Vehicle:
AE86 GT-S coupe
i <3 alqonquin homosauce

Default

Quote:
Originally Posted by c'dalerider View Post
+1 on poor fuel economy, with any bigger injectors realy.
+1 , i expected better tq #s on an STi (cam timing), but the 07 maps are difficult and the tuner there is tops so i dont know.
+1, 850 injectors are not very good on cold start up and idle poor, especially PE's! DW's are much better for those issues. My car idles to wrong for me. Im changing things up asap.
i love my gt 30r kit on a DD 06 STI. Im tuned to 21.5 psi with meth and 418/403, high reading dyno. Boost almost comes on to quick and she just stops 'pulling' at 55k rpm..sortof...ha. Great powerban.
My PE800's are fine actually.

Stops pulling that early? Why would it do that? Your peak power should come in higher than that.

Quote:
Originally Posted by Prevent View Post
Hm, there's really no reason you should be idling poorly.... injectors and tgv's or not...

I know many people with TGV deletes and 850cc injectors it idles like stock. (Illinois residents)


Should talk to your tuner about it...
TGV deletes, 800cc injectors, a 73mm intake, and cams to be exact, and the only time I ever have issues with startup or idle was when I was running Motul 300V (15W50) and the first real cold snap hit last fall. Otherwise zero issues.
zeropsi is offline   Reply With Quote
Old 06-11-2009, 08:01 PM   #29
4ST-AIR
Scooby Specialist
 
Member#: 148681
Join Date: May 2007
Chapter/Region: MWSOC
Location: WI
Vehicle:
TBD Looking for STI
Back in the Game!

Default

Quote:
Originally Posted by Sb22284 View Post
Exactly what he said. I have no doubt there is room to grow. With what you have to spend on this kit to get where i am its tough to add in the price of a rebuild and clutch. I could buy a new cobalt for that price
Very Nice Jorge doing his thing as always

Your going to learn very quickly if you want to play you have to pay and that's the bottom line. I have invested in both; an AXIS Stage 3 SB and a Exedy Twin Disc.

Once you play daily at the 400WHP+ level on a DD you need to save $$$$$ because things do break and things like tires and brakes wear out very fast, almost seasonally.

Quote:
Originally Posted by woodys77 View Post
if you have a big maf its probably your culprit not the tgv delete.
Not true at all I have run the P&L Big MAF setup and the P&L CAI and never idle issues. I also have my TGV's deleted and P&P.

I run modded stock FI's benched at 920CC's and idle at 900rpms.
-Dan

Last edited by 4ST-AIR; 06-11-2009 at 08:07 PM.
4ST-AIR is offline   Reply With Quote
Old 06-12-2009, 03:58 PM   #30
woodys77
Scooby Specialist
 
Member#: 192147
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Maine
Vehicle:
2007 STI EfiLogics
422whp 421wtq fpgreen

Default

Quote:
Originally Posted by 4ST-AIR View Post
Not true at all I have run the P&L Big MAF setup and the P&L CAI and never idle issues. I also have my TGV's deleted and P&P.

I run modded stock FI's benched at 920CC's and idle at 900rpms.
-Dan
my aps 70mm starts fine when cold but when warm sometimes when i start it it idles ruff till i rev it up, with the stock air box installed(just to start not to drive) all is fine. but aps is not the same as p&l, maybe its just an aps thing? to the op try raising your idle a couple hundred rpm, it helped me.
woodys77 is offline   Reply With Quote
Old 06-12-2009, 10:10 PM   #31
TypeC
Scooby Guru
 
Member#: 9794
Join Date: Aug 2001
Chapter/Region: TXIC
Location: Texas
Vehicle:
02 2.5LWRX-Retired
335i w/twins

Default

Quote:
Originally Posted by Sb22284 View Post
First dyno runs we ran with the TGV still on. Car made about 350 and the motor on the TGV broke(due to heat?). This is a simple mod that some forget and it is a must. car put out 22HP more with it gone.
Did you remove just the butterflies, the butterflies and the rod, or did you install TGV deletes?
TypeC is offline   Reply With Quote
Old 06-30-2009, 02:27 PM   #32
Sb22284
Scooby Specialist
 
Member#: 168386
Join Date: Jan 2008
Chapter/Region: MWSOC
Location: LITH, IL
Default

butterflies and the rod

Update : Got the CEL codes cleared up. There was a loose vacuum hose going to the intake manifold. The idling issue has worked itself out and there is no more RPM bouncing

Im still working with Perrin to figure out something with the top mount. We've tried everything from brackets to spacers to bushings. Seems the Y pipe is hitting the power steering bracket. I zip tied the hell out of the AC lines to keep them in place and they are not getting all bent up anymore
Sb22284 is offline   Reply With Quote
Old 06-30-2009, 02:41 PM   #33
benw
Scooby Specialist
 
Member#: 103320
Join Date: Dec 2005
Location: Oklahoma City
Vehicle:
2005 wingless
aspen white

Default

you sure it wasn't the air pump? that's the only thing that runs at startup that would have an effect on your idle. TGV deletes don't do much. they will create a very small flat spot in the warmup process, but that's only for a minute or so.
benw is offline   Reply With Quote
Old 06-30-2009, 06:26 PM   #34
unclemat
Scooby Specialist
 
Member#: 114530
Join Date: May 2006
Chapter/Region: NESIC
Location: MA
Vehicle:
2005 LGT 6MT wagon

Default

Quote:
Originally Posted by my94saleen View Post
i didnt know that. on amr's dyno stock sti's put down 201whp 200 lb tq
Yeah, we know yet. Yet bigger turbos read higher on their dyno than on other dynos. Magic!
unclemat is offline   Reply With Quote
Old 06-30-2009, 08:29 PM   #35
CatfaceType-R
Scooby Guru
 
Member#: 81102
Join Date: Feb 2005
Chapter/Region: MWSOC
Location: CPH Tuning/Consulting
Default

Quote:
Originally Posted by Sb22284 View Post
For what its worth, i get 16.5 MPG sitting in Chicago traffic... lol
there is something wrong with your car..diagnose it, this is abnormal...i've even seen big turbo car's do this


before my fuel pump gasket went, I had really bad gas mileage..no idea why or how they are connected, technically speaking..but you do have a problem if your calculations are right about your avmpg
CatfaceType-R is offline   Reply With Quote
Old 06-30-2009, 10:47 PM   #36
STi Mikey
Scooby Specialist
 
Member#: 114631
Join Date: May 2006
Chapter/Region: Tri-State
Location: TheShopCT / EFI LOGICS
Vehicle:
2009 GTR, 735whp
13' Benz, 15' WRX

Default

Quote:
Originally Posted by soon2bblackongold View Post
there is something wrong with your car..diagnose it, this is abnormal...i've even seen big turbo car's do this


before my fuel pump gasket went, I had really bad gas mileage..no idea why or how they are connected, technically speaking..but you do have a problem if your calculations are right about your avmpg
I agree. I drive agressively and am always hard on the gas. I have 850's with an hta68 turbo, and still get 275 to a full tank, 325 if all highway.
STi Mikey is offline   Reply With Quote
Old 07-06-2009, 12:41 PM   #37
blk05wrx
Scooby Newbie
 
Member#: 180559
Join Date: May 2008
Chapter/Region: MWSOC
Location: Arlington Heights, IL
Vehicle:
2005 WRX Cobb Stg 2
Black

Default

Honestly 16.5MPG doesn't sound that bad for Chicago. I've averaged 18.5MPG for the last 4 years with a bone stock 05 WRX going back and forth to work.

On the highway it runs up to 27 or 28.

Sb22284, thanks for the quality used Cobb DP. I just had it installed and re-flashed to Stage2.

Your car sounds awesome. I'll look for you at the Thurs. meets. I've got to get a ride in that thing.
blk05wrx is offline   Reply With Quote
Old 07-06-2009, 02:38 PM   #38
zeropsi
*** Banned ***
 
Member#: 175453
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: wilCO, IL
Vehicle:
AE86 GT-S coupe
i <3 alqonquin homosauce

Default

Quote:
Originally Posted by blk05wrx View Post
Honestly 16.5MPG doesn't sound that bad for Chicago. I've averaged 18.5MPG for the last 4 years with a bone stock 05 WRX going back and forth to work.

On the highway it runs up to 27 or 28.

Sb22284, thanks for the quality used Cobb DP. I just had it installed and re-flashed to Stage2.

Your car sounds awesome. I'll look for you at the Thurs. meets. I've got to get a ride in that thing.
Another Subaru @ the Algonquin meet?

I definitely need a ride in it too, haven't had the pleasure.
zeropsi is offline   Reply With Quote
Old 07-06-2009, 02:46 PM   #39
mikewarlover
Scooby Newbie
 
Member#: 197803
Join Date: Dec 2008
Chapter/Region: VIC
Location: Richmond BC Canada
Vehicle:
2009 STI--->C63
Black--->White

Default

Good power smooth and nice flat torque curve
mikewarlover is offline   Reply With Quote
Old 07-07-2009, 02:43 PM   #40
Sb22284
Scooby Specialist
 
Member#: 168386
Join Date: Jan 2008
Chapter/Region: MWSOC
Location: LITH, IL
Default

sold !!!

Last edited by Sb22284; 07-07-2010 at 03:09 PM.
Sb22284 is offline   Reply With Quote
Old 07-08-2009, 10:34 AM   #41
blk05wrx
Scooby Newbie
 
Member#: 180559
Join Date: May 2008
Chapter/Region: MWSOC
Location: Arlington Heights, IL
Vehicle:
2005 WRX Cobb Stg 2
Black

Default

Quote:
Originally Posted by Sb22284 View Post
blk05wrx - Did you think about getting an aftermarket tune? I loved my cobb stage 2 but its worth the extra few bucks to get a map custom to your car.
I'm still thinking about it. I'm enjoying the new power for now. I might wait a few months to see if there's anything else I want to add before I get a custom tune. (Sti intercooler, SPT intake, etc.)

I'm a little concerned that a custom tune may get a little more horsepower by leaning the motor out a little more. I don't want to risk it just to squeeze out another 10 HP. Right now I have exactly what the Cobb Stage 2 notes call for. TBE and everything else stock.
blk05wrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS : 07 sti springs, 04 wrx springs shsjr89 SCIC Private Classifieds 8 02-16-2012 06:26 AM
FS : 02-07 STI Axleback muffler ai42 TXIC Private Classifieds 23 08-17-2010 09:53 AM
07 sti tranny scoobydoo914 Private 'Wanted' Classifieds 0 06-04-2010 06:14 PM
FS : FL 04-07 Sti Blitz throttle controller Imprezsti5 Engine/Power/Exhaust 5 06-03-2010 05:27 PM
FS/T: Roof Vane Spoiler, 07 STI headlight, 07 STi grill, 07 STI trunk and wings SD marrenr813 SCIC Private Classifieds 42 09-28-2007 10:59 AM


All times are GMT -4. The time now is 03:56 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.