Welcome to the North American Subaru Impreza Owners Club Monday September 26, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-09-2009, 08:18 PM   #1
turbored02
Scooby Newbie
 
Member#: 119471
Join Date: Jul 2006
Chapter/Region: SCIC
Location: Azusa, ca
Vehicle:
2002 Impreza
Sedona Red Pearl

Default So I have searched for days.(seriously) Hi Idle after 2.5 swap

So my problem is I have an idle of 2k when the car is warm. When the car is cold it idles at 1.5k. My mods are the 05 STi LB with the WRX intake manifold wiring and ecu. I also have a DBB Garrett GT3071r. STi pink 565(i think) injectors, 255 fuel pump. GReddy FMIC. Perrin Divorced Dp. And Tanabe Medalion exhaust. When I had the 2.0, all the supporting mods where tuned. Only things I have changed are the turbo and the TGV deletes. Back then I had a GReddy 18g. So when I got this new engine. I have been having little problems. 1 being the high idle. I got the cosworth BCS installed but no change. I have checked all of the vacuum lines but all are plumb. All hoses are new or not cracked/torn. I am waiting for the EMS to come in the mail. Maybe it's in the ECU and not a mechanical problem ? If anyone is in the Azusa/Glendora/Covina area that can help ? I could use a fresh set of eyes. Mine are burnt.
* Registered users of the site do not see these ads.
turbored02 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-10-2009, 10:00 PM   #2
norexyet
Scooby Specialist
 
Member#: 39149
Join Date: Jun 2003
Chapter/Region: Tri-State
Location: Wild Rides Race Cars
Vehicle:
11 elantra
yea i said elantra

Default

I would still do a smoke test to check for leaks. You could have a bad idle air control also
norexyet is offline   Reply With Quote
Old 06-11-2009, 05:41 PM   #3
turbored02
Scooby Newbie
 
Member#: 119471
Join Date: Jul 2006
Chapter/Region: SCIC
Location: Azusa, ca
Vehicle:
2002 Impreza
Sedona Red Pearl

Default

I shall check that tonight.
turbored02 is offline   Reply With Quote
Old 06-11-2009, 07:46 PM   #4
speedyHAM
Scooby Specialist
 
Member#: 48377
Join Date: Nov 2003
Chapter/Region: MWSOC
Location: "They eat fish soaked in lye"
Vehicle:
1996 Gutted, built
XP class Impreza L

Default

Have you checked the vacuum line under the front passenger side of the manifold? I had that one come off and it caused the same problems.

Another thing to check is the adjustment of the throttle cable. Just the slightest extra tension will cause a high idle.
speedyHAM is offline   Reply With Quote
Old 06-16-2009, 07:05 AM   #5
turbored02
Scooby Newbie
 
Member#: 119471
Join Date: Jul 2006
Chapter/Region: SCIC
Location: Azusa, ca
Vehicle:
2002 Impreza
Sedona Red Pearl

Default

I have checked all of the vacuum lines. Nothing is out of place. Is there a way I can test the IAC ? voltage ? or OHMs? something ?
turbored02 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem after 2.5 replacement swap, ej25 experts needed! shadymilkman129 Subaru Conversions 6 07-31-2007 02:26 PM
Problem after 2.5 replacement swap.. shadymilkman129 Normally Aspirated Powertrain 6 07-30-2007 07:12 PM
Hacking the 1.8 ecu after the 2.5 swap EcksJay Normally Aspirated Powertrain 7 06-16-2005 02:03 AM
Bouncing at 4500 rpms after 2.5 sti block swap DJIMPREZA Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 06-01-2004 10:56 PM
i cant find a job. i have searched for about 5 weeks now. STEALTH-WRX Off-Topic 52 05-14-2004 04:55 PM

All times are GMT -4. The time now is 11:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.