Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-11-2009, 01:06 AM   #1
impressions
Scooby Newbie
 
Member#: 190815
Join Date: Oct 2008
Chapter/Region: W. Canada
Vehicle:
1994 EJ22E, T225
Honda Blue

Default Any ideas on this? my reverse light is on when in gear.

Hi guys, i have a 93 impreza it is a manual gear box, but i just noticed that my reverse light is on whenever i am in gear, so everytime i switch gears my reverse light goes on. What could be the problem? any advice to check? a dirty connector? greatly appreciated.
* Registered users of the site do not see these ads.
impressions is offline   Reply With Quote
Old 06-11-2009, 01:59 AM   #2
trueno16v
Scooby Specialist
 
Member#: 175170
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Milwaukee, WI
Vehicle:
2005 WRX Wagon
owl + bungee cord= my a$$

Default

Pull out the bulbs, problem solved.
trueno16v is offline   Reply With Quote
Old 06-11-2009, 07:23 AM   #3
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Quote:
Originally Posted by trueno16v View Post
Pull out the bulbs, problem solved.
Not the correct answer.

If both reverse lights are on, most likely the reverse switch has failed. The switch is located on the transmission.
If only one side stays on and the other side operates normally, the problem is in the light assembly (bad connection, wrong bulb type or bulb installed incorrectly).
Mulder is offline   Reply With Quote
Old 06-12-2009, 01:26 AM   #4
impressions
Scooby Newbie
 
Member#: 190815
Join Date: Oct 2008
Chapter/Region: W. Canada
Vehicle:
1994 EJ22E, T225
Honda Blue

Default

Quote:
Originally Posted by Mulder View Post
Not the correct answer.

If both reverse lights are on, most likely the reverse switch has failed. The switch is located on the transmission.
If only one side stays on and the other side operates normally, the problem is in the light assembly (bad connection, wrong bulb type or bulb installed incorrectly).
Thanks i really don't want people to be scared to follow my car, the reverse switch is on the transmission so does that mean it would be always on? because it does turn off during neutral, only when i am in any gear, is there a ground that connects on the shifter?
impressions is offline   Reply With Quote
Old 06-12-2009, 01:14 PM   #5
Wires
NASIOC Supporter
 
Member#: 36677
Join Date: May 2003
Chapter/Region: South East
Location: North Georgia
Vehicle:
2003 WRX Wagon
Sedona Red

Default

Has any work been done to the transmission? That sounds like the reverse light wires are connected to the neutral switch. (off in neutral, on in an gear, provided your car has one that operates in this way, closed in gear)

Otherwise, it would be some sort of strange linkage problem that activated the reverse light switch in any gear, instead of reverse.
Wires is offline   Reply With Quote
Old 06-14-2009, 02:12 AM   #6
mowgli29
Scooby Specialist
 
Member#: 203438
Join Date: Feb 2009
Chapter/Region: MWSOC
Location: St. Louis, MO
Vehicle:
2002 WRX
PSM

Default

I'm having the same problem. I just dropped the tranny to replace the clutch, and while it was out, my dad replaced the 1st and 2nd gear synchros.

Did I do something when re-installing the tranny, or did he do something when re-assembling it?

EDIT: I've got an 02 WRX.
mowgli29 is offline   Reply With Quote
Old 06-27-2009, 10:04 AM   #7
rbimdxe
Scooby Newbie
 
Member#: 214102
Join Date: Jun 2009
Chapter/Region: International
Location: Brisbane Australia
Vehicle:
2000 WRX Evo 4
Yellow

Default

Bit late I know, but check the plugs on the Gearbox are correctly conencted.

Mate of mine had to replace his input shaft and afterwards his reverse lights stayed on. Dropped the tranny twice to try and figure it out. Then the idea hit us to swap the connections over.

Worked normally. You can swap them around with the car on jack stands without dropping the box to check.
rbimdxe is offline   Reply With Quote
Old 06-27-2009, 10:40 AM   #8
mowgli29
Scooby Specialist
 
Member#: 203438
Join Date: Feb 2009
Chapter/Region: MWSOC
Location: St. Louis, MO
Vehicle:
2002 WRX
PSM

Default

Quote:
Originally Posted by rbimdxe View Post
Bit late I know, but check the plugs on the Gearbox are correctly conencted.

Mate of mine had to replace his input shaft and afterwards his reverse lights stayed on. Dropped the tranny twice to try and figure it out. Then the idea hit us to swap the connections over.

Worked normally. You can swap them around with the car on jack stands without dropping the box to check.
Yup, turns out my switches were put in the tranny backwards, so I swapped them. Took all of about 10 minutes. Not hard at all.
mowgli29 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My Airbag light is on??? Mike7 Newbies & FAQs 7 03-04-2010 02:40 AM
Sti reverse lights staying on in every gear stoner Electrical & Lighting 9 06-17-2009 12:50 AM
did 6mt swap now my abs light is on akcel Brakes, Steering & Suspension 6 05-20-2007 02:23 PM
Got caught in the snow in lake tahoe..... now my abs light is on birenroy Service & Maintenance 4 03-01-2007 03:24 AM
No horn, Cruise control's bad and my Airbag light is on? Paxtonb Factory 2.0L Turbo Powertrain 14 07-04-2004 12:22 PM


All times are GMT -4. The time now is 09:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.