Welcome to the North American Subaru Impreza Owners Club Friday January 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-12-2009, 04:47 PM   #1
wrxwhat
Scooby Specialist
 
Member#: 87653
Join Date: May 2005
Chapter/Region: South East
Location: Orlando, FL
Vehicle:
500 hp STI / 1100hp
Supra T / Stock G35

Default Video at the track *Clutch slipping?*

I went to the track a couple weeks back but was running into some issues, I think its the clutch shuddering as I'm going into the next gear(2nd and 3rd), it's not wheel hop. What do you guys think?

it's an ACT 6 puck

* Registered users of the site do not see these ads.
wrxwhat is offline   Reply With Quote
Old 06-12-2009, 05:13 PM   #2
jpjester
Scooby Specialist
 
Member#: 153624
Join Date: Jul 2007
Location: Mount Joy,PA
Vehicle:
2009 WRX Hatchback
Mica Blue

Default

What was in the other lane that took off, is that a truck?
jpjester is offline   Reply With Quote
Old 06-12-2009, 05:18 PM   #3
wrxwhat
Scooby Specialist
 
Member#: 87653
Join Date: May 2005
Chapter/Region: South East
Location: Orlando, FL
Vehicle:
500 hp STI / 1100hp
Supra T / Stock G35

Default

Quote:
Originally Posted by jpjester View Post
What was in the other lane that took off, is that a truck?
I think it was an older POS mazda. I don't like being next to them racing so I just let them go, he cut a pretty good light anyway, looks like a .003
wrxwhat is offline   Reply With Quote
Old 06-12-2009, 06:18 PM   #4
godforbid67
Scooby Specialist
 
Member#: 137168
Join Date: Jan 2007
Chapter/Region: South East
Location: ummm..... Andrewtech ftmfw!
Vehicle:
06 Built SGM WRX
35r, PPG, 280's, PSS9.

Default

Hmmm certainly does look like wheel hop from the video. What does it feel like? what did you run? What boost set up where you on?
godforbid67 is offline   Reply With Quote
Old 06-12-2009, 07:02 PM   #5
arch4life
Scooby Newbie
 
Member#: 172588
Join Date: Feb 2008
Location: Ann Arbor, MI
Vehicle:
2005 saab 9-2x sti
Black

Default

thats wheel hop. when your clutch lets go, the rpm's take off, then grab as torque decreases
arch4life is offline   Reply With Quote
Old 06-12-2009, 07:12 PM   #6
wrxwhat
Scooby Specialist
 
Member#: 87653
Join Date: May 2005
Chapter/Region: South East
Location: Orlando, FL
Vehicle:
500 hp STI / 1100hp
Supra T / Stock G35

Default

Quote:
Originally Posted by arch4life View Post
thats wheel hop. when your clutch lets go, the rpm's take off, then grab as torque decreases
It's not wheel hop, I know what wheel hop is. It wheel hops in 1st gear then i shift 2nd, and it shudders bad, like the clutch is trying to grab but i'm just running through it, same goes with 3rd gear but not as bad. I seriously doubt I'm going to have wheel hop/wheel spin in 3rd gear.

I think I may need to adjust the clutch further out.
wrxwhat is offline   Reply With Quote
Old 06-12-2009, 07:13 PM   #7
wrxwhat
Scooby Specialist
 
Member#: 87653
Join Date: May 2005
Chapter/Region: South East
Location: Orlando, FL
Vehicle:
500 hp STI / 1100hp
Supra T / Stock G35

Default

Quote:
Originally Posted by godforbid67 View Post
Hmmm certainly does look like wheel hop from the video. What does it feel like? what did you run? What boost set up where you on?
Feels like the clutch is trying to engage but being a 6 puck it won't really allow it to slip. I think that was a mid-high 11 second pass, 19.6 psi
wrxwhat is offline   Reply With Quote
Old 06-12-2009, 09:28 PM   #8
arch4life
Scooby Newbie
 
Member#: 172588
Join Date: Feb 2008
Location: Ann Arbor, MI
Vehicle:
2005 saab 9-2x sti
Black

Default

what engine mounts/tranny mounts? stock?
arch4life is offline   Reply With Quote
Old 06-12-2009, 09:30 PM   #9
AK SloPok
Scooby Specialist
 
Member#: 56464
Join Date: Mar 2004
Chapter/Region: AKIC
Location: Anchorage, AK
Vehicle:
12 Ram
White

Default

It's hard to see the tach clearly but it's not jumping up so I would tend to think it isn't slip. Chatter perhaps if you are slowly lifting the clutch pedal, which also doesnt appear to be happening. I would guess traction issues.
AK SloPok is offline   Reply With Quote
Old 06-12-2009, 09:54 PM   #10
renosubby
Scooby Specialist
 
Member#: 152576
Join Date: Jun 2007
Chapter/Region: SWIC
Location: Reno, NV
Vehicle:
2006 STI 10.8@ 129
www.Mayhemtuning.com

Default

I think its wheel hop!
renosubby is offline   Reply With Quote
Old 06-12-2009, 11:58 PM   #11
hkerekes
Scooby Specialist
 
Member#: 66310
Join Date: Jul 2004
Chapter/Region: South East
Location: Removing passenger seat
Vehicle:
2012 Orange

Default

Broken pitch or another trans / motor mount
Wheel hop is probably more likely

If it was clutch related it should do it even more as the rpm's rise.
hkerekes is online now   Reply With Quote
Old 06-13-2009, 12:02 AM   #12
STimo
Scooby Specialist
 
Member#: 110273
Join Date: Mar 2006
Location: OC, California
Vehicle:
450 whp 30R STI
11.3@123, 10's a commin'

Default

I can see it wheel hop a tiny bit in first, 2nd and 3rd definately doesnt look like wheel hop. IMO i cant really see anything different or hear anything unusual, guess i'd just have to be there to feel it.. But your rpm/mph isnt fluctuating and it sounds good.. Id say either clutch chatter like some others have said, or perhaps it could be a broken mount..
STimo is offline   Reply With Quote
Old 06-13-2009, 03:04 AM   #13
FuJi K
Scooby Guru
 
Member#: 3687
Join Date: Jan 2001
Chapter/Region: MWSOC
Location: St. Paul, MN
Vehicle:
MY99 GF4 JDM 6spd
NF Performance

Default

That's how a 6puck grabs. Shuddering grabs. If that was an organic, it'd slip and you won't notice it. A 6puck it'll grab like that especially when the RPM's are going back up that quick during the 1-2 and 2-3 gear shift.

On my car it does that with wheel slip because I don't run a DCCD controller.
FuJi K is offline   Reply With Quote
Old 06-13-2009, 02:36 PM   #14
toyo764
Scooby Newbie
 
Member#: 142344
Join Date: Mar 2007
Chapter/Region: NESIC
Default

burned flywheel perhaps?
toyo764 is offline   Reply With Quote
Old 06-13-2009, 06:33 PM   #15
wrxwhat
Scooby Specialist
 
Member#: 87653
Join Date: May 2005
Chapter/Region: South East
Location: Orlando, FL
Vehicle:
500 hp STI / 1100hp
Supra T / Stock G35

Default

Quote:
Originally Posted by toyo764 View Post
burned flywheel perhaps?
Is that a symptom of that?
wrxwhat is offline   Reply With Quote
Old 06-14-2009, 06:50 PM   #16
Md05STI
Scooby Specialist
 
Member#: 76974
Join Date: Dec 2004
Chapter/Region: MAIC
Location: Hagerstown, MD
Vehicle:
2005 CGM STI
10.03 @ 135

Default

Is it a sprung or unsprung ACT 6 puck? And are you flat foot shifting the car? My unsprung 6 puck doesnt chatter shifting into any gear, but my friends unsprung 6 puck chatters horribly. If your not ffs you might be releasing the clutch at the right speed to cause it to chatter like someone else already said. Definately not a slipping clutch though, ive experienced quite a few of them and you show no symptoms of that problem.
Md05STI is offline   Reply With Quote
Old 06-14-2009, 07:03 PM   #17
wrxwhat
Scooby Specialist
 
Member#: 87653
Join Date: May 2005
Chapter/Region: South East
Location: Orlando, FL
Vehicle:
500 hp STI / 1100hp
Supra T / Stock G35

Default

It's sprung. I've never seen a pucked clutch "slip" like an organic type clutch though..

I'm not flat foot shifting.
wrxwhat is offline   Reply With Quote
Old 06-14-2009, 07:14 PM   #18
Md05STI
Scooby Specialist
 
Member#: 76974
Join Date: Dec 2004
Chapter/Region: MAIC
Location: Hagerstown, MD
Vehicle:
2005 CGM STI
10.03 @ 135

Default

Quote:
Originally Posted by wrxwhat View Post
It's sprung. I've never seen a pucked clutch "slip" like an organic type clutch though..

I'm not flat foot shifting.
My pucked Clutchmasters slipped like any other clutch. Only clutch ive ever had that didnt slip like normal was my twin disc and it still slipped like normal, just once they get so hot they weld themselves together.

If your not flat foot shifting im gonna lead towards your letting the clutch out at the right speed for it to chatter or its just that clutches nature. My buddies is one of the worst clutches i ever drove for chatter.
Md05STI is offline   Reply With Quote
Old 06-14-2009, 08:23 PM   #19
wrxwhat
Scooby Specialist
 
Member#: 87653
Join Date: May 2005
Chapter/Region: South East
Location: Orlando, FL
Vehicle:
500 hp STI / 1100hp
Supra T / Stock G35

Default

Quote:
Originally Posted by Md05STI View Post
My pucked Clutchmasters slipped like any other clutch. Only clutch ive ever had that didnt slip like normal was my twin disc and it still slipped like normal, just once they get so hot they weld themselves together.

If your not flat foot shifting im gonna lead towards your letting the clutch out at the right speed for it to chatter or its just that clutches nature. My buddies is one of the worst clutches i ever drove for chatter.
lol I dunno man, this is my 2nd ACT 6 puck and the first one was completely fine until 30,000 miles when it started chattering between fast shifts, like this one is doing right now
wrxwhat is offline   Reply With Quote
Old 06-14-2009, 10:34 PM   #20
jasv11
Scooby Specialist
 
Member#: 117862
Join Date: Jun 2006
Chapter/Region: E. Canada
Location: INNOVATIVE TUNING
Vehicle:
2006 STi 10.85@129.4
96 impreza 9.55e.t.146mph

Default

My act 6 puck clutch chattered so badly at launch in 1st gear it would pop out of first half the time.

My driving never changed from the 2 previous years of launching my car with the stock sti clutch and that never happened with the stocker.

i welded 2 act 6 puck clutches to the flywheel last year and now run a triple plate clutch(no more chatter)
jasv11 is offline   Reply With Quote
Old 06-14-2009, 10:43 PM   #21
jasv11
Scooby Specialist
 
Member#: 117862
Join Date: Jun 2006
Chapter/Region: E. Canada
Location: INNOVATIVE TUNING
Vehicle:
2006 STi 10.85@129.4
96 impreza 9.55e.t.146mph

Default

Did the first 6 puck clutch have peices broken off the pads when you removed it.

I ask this as I just remembered what mine looked like when they came off the car.

its almost as if peices get trapped between the flywheel and the pads that cause the chatter.

If you remove this one take a look and see if this is whats happening.

I'll see if I can find a pic of one of mine.
jasv11 is offline   Reply With Quote
Old 06-14-2009, 10:59 PM   #22
jasv11
Scooby Specialist
 
Member#: 117862
Join Date: Jun 2006
Chapter/Region: E. Canada
Location: INNOVATIVE TUNING
Vehicle:
2006 STi 10.85@129.4
96 impreza 9.55e.t.146mph

Default

this is my act 6 puck clutch that chattered so bad it popped out of first gear several times all by itself.











as you can see this clutch did not like to be slipped off the line launching it as it stuck to the flywheel from extreme heat.

My launching technic was the same for the 2 previous years with the stock clutch with no problems.
jasv11 is offline   Reply With Quote
Old 06-15-2009, 08:40 AM   #23
wrxwhat
Scooby Specialist
 
Member#: 87653
Join Date: May 2005
Chapter/Region: South East
Location: Orlando, FL
Vehicle:
500 hp STI / 1100hp
Supra T / Stock G35

Default

Hmm, thanks for the info jasv. I still have my original flywheel in there, I'm absolutely certain this is the problem.. I have to slip the clutch quite a bit launching it or it will just destroy my front axles, so I guess I should pick between the lesser of two evils.
wrxwhat is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Video, for all, my buddy piloting a Carrera GT at the track CBRDSpeedfactory General Community 14 06-17-2005 04:49 PM
BMW M6 at the track *video* roffle Off-Topic 29 11-28-2004 11:51 PM
Video of me at the Track ShaggyGT Proven Power Bragging 12 10-21-2002 09:37 PM
Video of my day at the track ScoobieSnaX Member's Car Gallery 3 06-08-2002 05:28 PM
what hp/tq does the stock clutch slip at? Eric SS Transmission (AT/MT) & Driveline 3 02-04-2002 07:26 PM


All times are GMT -4. The time now is 01:13 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.