Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-25-2009, 12:03 AM   #1
suub07
Scooby Newbie
 
Member#: 163702
Join Date: Nov 2007
Chapter/Region: TXIC
Location: Odessa TX
Vehicle:
2007 impreza 2.5
UGM

Default 95 legacy - issues

So the other day my girlfriend came home, pulled in, went to straiten out, and didn't realize that the car was still in drive, and when she gave it some gas to back out, she not only gave it a little much gas, but was still in drive... this sent her over the curb (as seen in the below pictures), and into the stairs and railing about 18 inches after the curb, pushing her drivers side quarter pannel back. Unfortunatly she didnt want to wait for me to get back to help her, and back off the stairs, which i guess is understandable. This tore a large portion of the bumper cover off.

I managed to get the splash guard into the origional position with some zip ties and unbending some of the metal supports that were pushed back. The spash guard was all good, I took the car for a drive around town, it drove just fine, and we though everything was great.

The next day, she was about a block from work when strange things began...

Her car went into limp mode (at least thats what I gathered from her description), her "AT OIL TEMP" light went on, along with the CEL, oil light, and other lights too. (She said that all of the warning lights went on. She pulled over, and got out the AAA info to call a tow truck, but decided to try to make it the block to work. She started the car, and all lights were off, and the car drove fine. After I got off, I went to pick her up, checked everthing out, and after seeing that all fluids were at the perfect levels, coolant looked fine (Probably not neccessary to check coolant, but why not?), and all that... the only think different was a small pannel on the drivers side, further in than the damage had flipped down. I put this back up, and we drove her car the 20 miles home. It ran great.

Yesterday, no problems what so ever.

Today, She had the same problems with the CEL, AT TEMP, and such. She stopped, restarted, the car was fine for about a mile, and then it happened again. (This happened before the engine was even warm)

Anyways, we are replacing the bumper tomorrow morning with a replacement I just got from a junkyard. I will try to pull the CEL code tomorrow if its going to be there (ill try either way).





And the railing/stairs. You can see how far her car went onto the stairs by how far back the rail is. This also lifted her car *slightly* up.

luckily, for anyone who is wondering, the stairs will be okay.



I am assuming this is an electrical issue, although im not sure. There were no mechanical componets that I can see any damage what so ever on.

I know its a long post to read, but I really appreciate anyone who can give any advice or direction. thanks for taking the time to read!
* Registered users of the site do not see these ads.
suub07 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
95 legacy issue - pics suub07 Normally Aspirated Powertrain 0 06-25-2009 12:15 AM
95 legacy ls trans issues xrturbo Transmission (AT/MT) & Driveline 1 06-13-2006 01:06 PM
95 Legacy Brighton tweeter, cd changer, and lighter issues Aflaedge Legacy Forum 9 01-29-2004 02:14 PM
95 manual trans into 95 legacy auto conversion ?'s legacy2003 Subaru Conversions 2 01-04-2004 05:51 AM
Gear ratios and differential ratio for 95 legacy and 95 imprezza ciper Transmission (AT/MT) & Driveline 0 06-14-2002 06:58 PM


All times are GMT -4. The time now is 11:49 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.