Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-27-2002, 09:22 PM   #1
froggert
Scooby Specialist
 
Member#: 768
Join Date: Jan 2000
Chapter/Region: Tri-State
Location: nj
Vehicle:
OB, legacy, 911,
ram 1500, 1098s, m620

Unhappy mrt cat toast after 9 months

well, it looks like there's something wrong with the cat in my headers back exhaust system from mrt. either that or something else fell off in the exhaust in front of the cat and is plugging it.

the system's been on the car since last august and been run maybe 7k miles. will update in the next few weeks when i get a chance to get the stock system swapped back in.

roger
* Registered users of the site do not see these ads.
froggert is offline   Reply With Quote
Old 04-27-2002, 09:25 PM   #2
Reciprocity
Scooby Specialist
 
Member#: 1165
Join Date: Mar 2000
Chapter/Region: BAIC
Location: Alameda, CA
Vehicle:
2012 dcrawford died
for your sins

Default

How do you know something is wrong? What happened?

NC
Reciprocity is online now   Reply With Quote
Old 04-27-2002, 09:37 PM   #3
m750
Scooby Guru
 
Member#: 2278
Join Date: Sep 2000
Chapter/Region: NESIC
Location: Pepperell MA
Vehicle:
8Sti | 07 allez
White | Comp

Default

interesting, my car has been running quite poorly lately too, what are your symptoms?
AO
m750 is offline   Reply With Quote
Old 04-27-2002, 09:40 PM   #4
froggert
Scooby Specialist
 
Member#: 768
Join Date: Jan 2000
Chapter/Region: Tri-State
Location: nj
Vehicle:
OB, legacy, 911,
ram 1500, 1098s, m620

Default

a few days ago, the car started not feeling right powerwise and a strange metallic sound showed up. the exhaust sounds more subdued than normal, too. got it up on a lift today and found, by hitting various parts under the car with a rubber mallet, that something is clanging either in or around the cat. nothing is loose on the outside, so it should be inside the exhaust.
froggert is offline   Reply With Quote
Old 04-28-2002, 12:09 AM   #5
GTBGUY
Scooby Specialist
 
Member#: 2003
Join Date: Aug 2000
Location: Calgary, Alberta, Canada
Vehicle:
'99 BGP Legacy GT
'98 QS Legacy L (auto)

Default

froggert - sounds likely the "wafers" which the catylist material could have overheated causing it to break from it's bond to the cat-housing. Should take off the header section and shake to see what comes out the end of the cat, that'll tell you if the cat is busted.
GTBGUY is offline   Reply With Quote
Old 04-28-2002, 02:32 PM   #6
MY99 2.5GT
Scooby Specialist
 
Member#: 5030
Join Date: Mar 2001
Chapter/Region: MAIC
Location: Martinsburg, WV, USA
Vehicle:
1999 Legacy 2.5GT
05 Legacy GT 06 Armada

Default

I did get word that mrt was redesigning their cats in conjunction with the aid of one of their US distributors. I forget which dealer it was.

The other day I noticed an odd metalic sound whenever I began excelerating. I took a look under the car and one of the spring bolts that attach my catback to the stock cat was missing. This allowed the midpipe to move out of its normal mounting position just slightly but enough for it to vibrate a couple of those heat shielding plates.

Brad
MY99 2.5GT is offline   Reply With Quote
Old 04-29-2002, 03:28 AM   #7
noahr
Scooby Newbie
 
Member#: 15434
Join Date: Feb 2002
Location: walla walla/t-town
Vehicle:
98 legacy gt
caucasian

Default

apparently the mrt cat's had problems which they are now fixing. many people have ceramic coated the headers of the full mrt system which has fixed the problem. you may want to try doing this, but since you are converting the car to stock, just fix it and sell it. mrt now ceramic coats the headers from the factory to fix this problem. you may want to e-mail them about the problem as you are not the only person that has had this problem.
noahr is offline   Reply With Quote
Old 04-29-2002, 12:58 PM   #8
m750
Scooby Guru
 
Member#: 2278
Join Date: Sep 2000
Chapter/Region: NESIC
Location: Pepperell MA
Vehicle:
8Sti | 07 allez
White | Comp

Default

it didn't fix my problem...
the coating that is... though, I reciently cleared my CE, about a week ago, and it hasn't come on yet. Which leads me to believe something has changed... what it is, I don't know. I'm going to pull my cat off and see what the deal is. luckily my cat has flanges at both ends so it's easy to check.
AO
m750 is offline   Reply With Quote
Old 05-10-2002, 10:55 AM   #9
m750
Scooby Guru
 
Member#: 2278
Join Date: Sep 2000
Chapter/Region: NESIC
Location: Pepperell MA
Vehicle:
8Sti | 07 allez
White | Comp

Default

I got my system re-freshed this week, a new set of exhaust gaskets, rewelded a bracket...
Guy at the shop 'thinks my cat is hollowed' accourding to the sound. Hrm... maybe it's time for a replace ment one. :-/
AP
m750 is offline   Reply With Quote
Old 05-10-2002, 02:11 PM   #10
froggert
Scooby Specialist
 
Member#: 768
Join Date: Jan 2000
Chapter/Region: Tri-State
Location: nj
Vehicle:
OB, legacy, 911,
ram 1500, 1098s, m620

Default

haven't had a chance to pull the mrt system yet, but the cat seems to have fixed itself. will update in a few weeks when i get the headers off and fish around inside to see what's in there.
froggert is offline   Reply With Quote
Old 06-10-2002, 11:27 AM   #11
MRT Performance
Vendor
 
Member#: 3321
Join Date: Dec 2000
Location: Sydney, NSW, Australia
Default

Please reply us if we can assist you

Cheers

Brett MRT P
MRT Performance is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
After 7 months I can finally show off my car! [9 ~130k pics] porque Member's Car Gallery 6 10-10-2004 09:30 PM
Laid off twice from the same job in 9 months driggity North West Impreza Club Forum -- NWIC 12 11-06-2003 09:59 PM
Porterfields are toast after 3 track days! vrm vrm Brakes, Steering & Suspension 20 04-29-2002 07:31 PM
Have had MRT Header-back for three months or more and still have CE. scootr Normally Aspirated Powertrain 2 09-13-2001 10:15 AM


All times are GMT -4. The time now is 02:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.