Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-26-2009, 11:44 AM   #1
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
DIY project: life
I need more TIME!

Default why am I misfiring now ??

installed my new block last may...and everything ran like a top. BUT every "blue moon" I had been getting misfire codes, probably once every month or 2. random cylinders each time. Now it has been getting MORE more freqeunt. and is ALWAYS cylinder 1. This is happening EVERY day as soon as I reset the ecu.

I have light weight ALT,crank & PS pulleys, as well as a LW flywheel. BUT my crankshaft has been balanced and blueprinted... wouldn't this fix the problem ??

My question is, Is my misfire CEL probably caused by the mods, or do you guys think its an actuall problem with my ingition system? IE, coil pack,plugs,wires etc...

I have put 16,000 miles on the new block so far, everything was changed when I installed it.(minus wires which are prolly 10k older)
* Registered users of the site do not see these ads.
IllNastyImpreza is offline   Reply With Quote
Old 03-26-2009, 07:14 PM   #2
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

oddly enough, my issue is similar. I put in a new short block last summer, and got the odd misfires on all cylinders, no performance loss, scared the hell out of me. Then I started to notice that it only occurred after I'd fill up, and cruising on the freeway(right about the time that the charcoal canister would open).

It wouldn't hurt to check the plugs, gaps, make sure wires are seated correctly. Then take the wires off the coil pack and check to see if anything is awry there. When's the last time you inspected the injectors? they can get dirty. Run a tank or 2 with injector cleaner thru there and see if it does anything.
yarrgh is online now   Reply With Quote
Old 03-27-2009, 11:46 AM   #3
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
DIY project: life
I need more TIME!

Default

yeah , might as well start with the small things

I'm prolly gonna change out the plugs and wires anyway just to be safe. I'll go grab some fuel injector cleaner while I"m @ it.
IllNastyImpreza is offline   Reply With Quote
Old 03-27-2009, 01:33 PM   #4
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

check the plugs

ditch the damned pulleys
Uncle Scotty is offline   Reply With Quote
Old 03-27-2009, 03:52 PM   #5
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

You are throwing the missfire due to the lightweight flywheel my friend. Nothing more, nothing less. Unless you have an odd plug issue, I bet you $1 zillion dollars that's the problem. Lightweight flywheel = CEL city.
Unabomber is offline   Reply With Quote
Old 03-27-2009, 04:39 PM   #6
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

....more like LW flywheel + pulleys = greater chance of a CEL. Since the pulleys are easier to get to, I would agree with Scotty and say ditch 'em.
Kean is offline   Reply With Quote
Old 06-30-2009, 03:08 PM   #7
lancereater
Scooby Newbie
 
Member#: 205723
Join Date: Mar 2009
Chapter/Region: W. Canada
Location: Calgary
Vehicle:
2007 Impreza 2.5i se
Newport Blue

Default

i have had my perrin lwp on my car for over 10,000 km and no problems then boom the other day i start getting misfires i checked all my wiring and plugs installed the stock pulley and i am still misfiring i am rattled
lancereater is offline   Reply With Quote
Old 06-30-2009, 07:27 PM   #8
kaisersouse
Scooby Specialist
 
Member#: 85900
Join Date: Apr 2005
Chapter/Region: NESIC
Location: Maine
Vehicle:
2001 Forester S
White

Default

Quote:
Originally Posted by Uncle Scotty View Post
check the plugs

ditch the damned pulleys
I thought crank was a no-no (learned from experience ) but accessory pulleys were okay?
kaisersouse is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Riddle me this, why am I misfiring? reddevil Built Motor Discussion 15 04-30-2007 07:32 PM
need help first misfiring now high exhaust temps KOPFJAGER Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 13 04-26-2006 07:27 PM
Where am I going, and why am I in this handbasket? NWWagon Off-Topic 19 01-10-2006 02:43 PM
Why am I finding that music I thought was crap years ago I now enjoy? Brady Off-Topic 6 01-23-2004 11:33 PM
i am a specialist now---least on nabisco i am HomeSlice Legacy Forum 11 10-28-2003 02:27 AM


All times are GMT -4. The time now is 04:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.