Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-08-2009, 08:33 PM   #1
tantric rex
Scooby Newbie
 
Member#: 163064
Join Date: Oct 2007
Chapter/Region: MAIC
Vehicle:
08 wrx
dark gray

Default Check engine, traction control, cruise control lights

Apologies if this is the wrong forum but I Started having some issues regarding my dash warning lights today.

It's a 2008 wrx. My front pax side turn indicator has been acting up so I removed the plastic intake piece which connects to the air filter box and the cable which also connects to the air filter housing.

I fiddled with the turn indicator then put everything back in place. I don't remember if I reconnected the cable to the air filte housing beforehand, but When I started the car, the following occurred:

1) check engine light remains on
2) traction control disabled light remains on
3) cruise control light flashes incessantly

I've tried pushing all the relevant buttons to get this light show to quit, but no luck. I haven't tried disconnecting/reconnecting the battery though.

Looking for some quick advice to see if this can be solved before I drop $200 at the dealer tomorrow.

Ideas?
* Registered users of the site do not see these ads.
tantric rex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light, VDC light is on, and cruise control light is flashing grimace09 Normally Aspirated Powertrain 7 08-09-2012 03:42 PM
Check engine light, VDC light is on, and cruise control and sport light is flashing Legacymun2k6 Factory 2.5L Turbo Powertrain 5 01-30-2010 12:47 PM
Check engine and blinking cruise light..O2 sensor Shot? LUKEWMC Factory 2.5L Turbo Powertrain 17 07-12-2008 12:22 AM
Check Engine On and Cruise light flashing..HELP! Drft4spd Factory 2.5L Turbo Powertrain 10 04-15-2008 02:28 PM
check engine and flashing cruise Subie 45 Factory 2.5L Turbo Powertrain 23 03-15-2006 11:03 AM


All times are GMT -4. The time now is 10:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.