Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-09-2009, 01:02 PM   #1
kekoa503
Scooby Newbie
 
Member#: 166591
Join Date: Dec 2007
Chapter/Region: NWIC
Location: oregon city
Vehicle:
02 wrx
black but blue in the sun

Default Overheating issues

I have a 98 out/legacy with 198k, just did timming and water pump plus thermostat, and it was installed correctly.
The problem is it is overheating I tried getting any air or bubbles out, I filled up the radiator then the block, I even tried Subaru's special conditioner. It stays at a good temperature as long as I run the heater full blast. any more suggestions would be helpful. Thanks
* Registered users of the site do not see these ads.
kekoa503 is offline   Reply With Quote
Old 07-09-2009, 03:17 PM   #2
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

are the fans plugged in? try again with burping the system.
yarrgh is offline   Reply With Quote
Old 07-09-2009, 04:09 PM   #3
kekoa503
Scooby Newbie
 
Member#: 166591
Join Date: Dec 2007
Chapter/Region: NWIC
Location: oregon city
Vehicle:
02 wrx
black but blue in the sun

Default

fans are plugged in and this is the second time I have tried burping it... Thanks for the reply.
kekoa503 is offline   Reply With Quote
Old 07-09-2009, 10:22 PM   #4
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

without sounding too much like a dick, I'm gonna have to say do a search on overheating. There are many causes, maybe it's been covered.
yarrgh is offline   Reply With Quote
Old 07-09-2009, 10:31 PM   #5
madmax718
Scooby Specialist
 
Member#: 172501
Join Date: Feb 2008
Default

is this a new to you car?
madmax718 is offline   Reply With Quote
Old 07-09-2009, 10:42 PM   #6
emsti2004
Scooby Newbie
 
Member#: 184335
Join Date: Jul 2008
Chapter/Region: South East
Location: Miami,Fl
Vehicle:
2004 STI
WRB

Default

did you time the car correctly?? some times when you don't time the car correctly it starts over heating... or it could be a defective thermostat that is not opening correctly...does the car overheat when running over 20 mph if it doesn't its probably the fan sensor that is not triggering the fans...

Last edited by emsti2004; 07-09-2009 at 10:49 PM.
emsti2004 is offline   Reply With Quote
Old 07-10-2009, 12:47 PM   #7
kekoa503
Scooby Newbie
 
Member#: 166591
Join Date: Dec 2007
Chapter/Region: NWIC
Location: oregon city
Vehicle:
02 wrx
black but blue in the sun

Default

It overheats after the thermostat kicks in so that tells me it is working, the timing belt is a possibility but i have done so many and turned it one rotation and all the lines matched up... thanks for the replies, no worries I did a search and came up with a few things to check but to no avail did they work. my next step is to replace the radiator I guess
kekoa503 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thermostat / overheating issues Sort of odd issue psychoskip Factory 2.5L Turbo Powertrain 6 12-15-2009 08:18 PM
2002 wrx overheating issue rotaman Factory 2.0L Turbo Powertrain 8 09-19-2006 06:09 PM
'97 2.5 GT with overheating issues StarryNights Legacy Forum 10 04-01-2006 09:07 PM
Overheating issue... MekoNY Legacy Forum 5 10-04-2004 12:46 PM
overheating issue jr34596 Legacy Forum 8 08-19-2002 02:19 AM


All times are GMT -4. The time now is 02:35 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.