Welcome to the North American Subaru Impreza Owners Club Thursday May 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-09-2009, 10:41 PM   #1
shoodoggy
Scooby Specialist
 
Member#: 135913
Join Date: Dec 2006
Chapter/Region: South East
Location: wellington, fl
Vehicle:
96' R33 Skyline

Default Windshield wiper problem

Not sure if this is the best place to post this but hopefully someone here can offer some words of advice. Recently my windshield wipers have been messed up as they wipe. The first couple of wipes are fine, normal up and down motion. But then the wipers start going too far. On the upstroke the wiper actually goes past the a-pillar, I can see it out my driver window. Then they both bounce on the bottom of the downstroke because they're going too far down. I'm pretty ignorant to how wipers operate within their normal parameters, does anybody have an idea of what could be the problem?
* Registered users of the site do not see these ads.
shoodoggy is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-12-2009, 09:48 PM   #2
surowrxa
Scooby Specialist
 
Member#: 102895
Join Date: Dec 2005
Chapter/Region: MAIC
Location: Pittsburgh
Vehicle:
'12 Forester
'08 Legacy

Default

surowrxa is offline   Reply With Quote
Old 07-13-2009, 05:17 PM   #3
shoodoggy
Scooby Specialist
 
Member#: 135913
Join Date: Dec 2006
Chapter/Region: South East
Location: wellington, fl
Vehicle:
96' R33 Skyline

Default

^thanks a lot man, i was just reading through it, i think it should help me out
shoodoggy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem w/ windshield wiper fluid thingy go0sebumpz Interior & Exterior Modification 3 12-30-2007 10:56 AM
Windshield Wiper Arms ( wipers arm ) FD777 Car Care & Detailing 16 12-21-2007 03:28 PM
Bizarre windshield wiper problem elijahwrx Service & Maintenance 7 04-03-2007 09:21 AM
Windshield Wiper Problems molehill84 Warranty Issues & SOA Problems 3 02-24-2007 02:41 PM
('93-'01) Where can i find a faster Windshield Wiper motor??? Fast like the WRC cars! SRI Performance Impreza Forum 1 04-11-2001 11:19 AM


All times are GMT -4. The time now is 04:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.