Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-11-2009, 12:42 PM   #1
kpalena
Scooby Specialist
 
Member#: 82431
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Battle Ground, WA
Vehicle:
2006 06 wrx limited
CGM

Default Am I in trouble?

I did my 30k service...well...30k miles ago. I am due for my 60k and have been seeing that the coolant conditioner is recomended for all models and all years. I did not put it in 30k miles ago. How bad was this oversight?

Edit....

Called SOA. They said that I do not need the conditioner....FWIW.
* Registered users of the site do not see these ads.

Last edited by kpalena; 07-11-2009 at 01:20 PM.
kpalena is offline   Reply With Quote
Old 07-11-2009, 06:16 PM   #2
RonJitsu
Scooby Specialist
 
Member#: 132301
Join Date: Nov 2006
Chapter/Region: Tri-State
Location: Central NJ
Vehicle:
07 WRX Limited 6MT
20G - SWP - SOLD

Default

SOA is correct, you do not need the conditioner. The conditioner was needed in non-turbo models because of diff headgaskets.
RonJitsu is offline   Reply With Quote
Old 07-11-2009, 07:03 PM   #3
kpalena
Scooby Specialist
 
Member#: 82431
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Battle Ground, WA
Vehicle:
2006 06 wrx limited
CGM

Default

Thank you. From the mood around here though I'd thought I had gone and killed my car...
kpalena is offline   Reply With Quote
Old 07-13-2009, 11:37 AM   #4
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

....a couple of years ago the coolant replacement procedure had been amended in the service manuals for all model years to include the recommendation for the use of the conditioner. I checked bak in early 2007 and found this snippet from the SOA site for the MY2007 schedule:

Quote:
To prevent cooling system leaks, always add Genuine Subaru Cooling System Conditioner (Part no. SOA635071) whenever the coolant is replaced.
....unless something has changed since that time.
Kean is offline   Reply With Quote
Old 07-15-2009, 01:56 PM   #5
crampfan
Scooby Specialist
 
Member#: 74321
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: clarksville AR
Vehicle:
2004 wrx wag
black UTEC stg 4

Default

I'm on my second subaru, and have never installed the conditioner. (stop leak) no problems
crampfan is offline   Reply With Quote
Old 07-16-2009, 03:20 PM   #6
leecea
Scooby Guru
 
Member#: 37359
Join Date: May 2003
Vehicle:
2003 WRX

Default

I believe the "conditioner" is just Radweld. I haven't used it in my car because I have no leaks.

I've certainly used Radweld on old beaters, to keep them going, but I'm hesitant to be putting Radweld in a newish car with every coolant change. That's just my opinion.
leecea is offline   Reply With Quote
Old 07-17-2009, 01:20 PM   #7
Nims
Scooby Newbie
 
Member#: 159085
Join Date: Sep 2007
Default

If it's been fine for the last 30k, I think you're in the clear!
Nims is offline   Reply With Quote
Old 07-17-2009, 04:30 PM   #8
blackfang
Scooby Specialist
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

Subaru revised their policy and Coolant conditioner is to be used in every coolant change regardless.

It is also listed in the cooling system FAQ on here too
http://forums.nasioc.com/forums/showthread.php?t=504002
blackfang is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
am i in trouble??? legacydreamz Off-Topic 8 04-20-2007 10:50 PM
am i in trouble? Jeff Moses Tire & Wheel 7 02-11-2007 09:27 PM
TXS Stage 4 + UTEC + 50 Mile One Way Freeway Commute = Am I In Trouble????? xfactor834 Factory 2.0L Turbo Powertrain 4 10-14-2002 03:40 PM
Am i in trouble?? Future Subaru Driver1 Normally Aspirated Powertrain 10 09-28-2001 11:39 PM
Rosecroft Raceway (Maryland)Autocross this weekend. Hoo boy..am I in trouble? El Kabong General Forum Archive 3 05-06-2000 12:36 AM


All times are GMT -4. The time now is 07:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.