Welcome to the North American Subaru Impreza Owners Club Saturday November 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 07-12-2009, 11:42 PM   #1
Scooby Newbie
Member#: 146275
Join Date: Apr 2007
Chapter/Region: MAIC
Location: PA
13 BRZ

Default Need AC help

Having some trouble with my AC. It works fine on a day to day basis, but on an extended road trip 2+ hours it will start to act weird.

The blower continues to blow at what ever speed you have it set at, 1-4, but slowly less and less air comes out of the vents until it basically just stops blowing air at all.

So if I have the blower set to its highest setting, you can hear it blowing really hard, but only a small amount of air will trickle out of the vents.

The air will also get warm like the AC is no longer working either. If I turn the AC off and continuing to run the blower it will slowly go back to the normal amount of air that should be coming out of the vents.

It is a really annoying problem and I think that it may have something to do with freezing, because the problem is usually accompanied by some mist or a small amount of fog coming from the vents as it happens.

Is humid air causing something to freeze shut?
* Registered users of the site do not see these ads.
Gordo52 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-13-2009, 12:14 AM   #2
Trust no one
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
02 WRX
15 WRX/05 GTO


The system is freezing up, it's a known issue with the 02/03's. See the TSB info in this thread and note if your VIN is within the affected range.
The fix as indicated is a replacement thermosensor and control module. I did this fix on my '02 a few years back and it works.
Mulder is offline   Reply With Quote
Old 07-13-2009, 12:15 AM   #3
Scooby Specialist
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
2001 2.5RS
Black Diamond Pearl


sounds like freezing. Do you have a cabin air filter? maybe it's getting time to change and the lack of flow means that your evaporator is slowly freezing up.
yarrgh is offline   Reply With Quote
Old 07-13-2009, 08:47 AM   #4
Scooby Newbie
Member#: 146275
Join Date: Apr 2007
Chapter/Region: MAIC
Location: PA
13 BRZ


that sounds exactly like what my problem is. Thank you so much.
Gordo52 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone have a pioneer avic u310bt need some help cosanostra Car Audio, Video & Security 5 06-04-2010 01:20 PM
help! need AC line Sputnik 5 Private 'Wanted' Classifieds 5 04-07-2009 03:20 AM
Need some help with booking a room at the Borgata in AC for my wedding night. Mud Pig Off-Topic 5 03-17-2009 06:36 PM
Help! Need AC Condensor pronto jonnysubby North West Impreza Club Forum -- NWIC 11 07-21-2005 08:48 PM
Need a help on installing/taking off stock AC line... alvyman Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 06-27-2004 11:03 PM

All times are GMT -4. The time now is 01:33 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.