Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-16-2009, 01:24 PM   #1
leeswrx
Scooby Newbie
 
Member#: 118295
Join Date: Jun 2006
Chapter/Region: AKIC
Vehicle:
05 STI
Blue

Default A/C compressor scuffing sound

I reciently noticed this after bringing my car down from alaska. When you turn on the a/c, it makes a scuffing/rubbing sound for about a second. Once in a while it might last for two. When im driving with the ac on, the sound will come and go. Also the temp of the air will be cool, then get warm for a couple seconds then go back to cold every so often. If any one help me out with this I would be really appreciate it. Its an 05 STI with about 20,000 miles on the new motor.I almost for got, When I brought it down here it was on an autotransport. It was VERY dirty. Dont know if dirt could get in there and cause some damage. Thanks.
* Registered users of the site do not see these ads.

Last edited by leeswrx; 07-16-2009 at 01:33 PM.
leeswrx is offline   Reply With Quote
Old 07-21-2009, 12:05 PM   #2
leeswrx
Scooby Newbie
 
Member#: 118295
Join Date: Jun 2006
Chapter/Region: AKIC
Vehicle:
05 STI
Blue

Default

Any ideas anyone?
leeswrx is offline   Reply With Quote
Old 07-21-2009, 12:46 PM   #3
crampfan
Scooby Specialist
 
Member#: 74321
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: clarksville AR
Vehicle:
2004 wrx wag
black UTEC stg 4

Default

sounds like the compressor clutch is giving up
crampfan is offline   Reply With Quote
Old 07-21-2009, 12:53 PM   #4
only1agam
Scooby Specialist
 
Member#: 56183
Join Date: Feb 2004
Chapter/Region: South East
Default

mines been doing this for a while +1 good question
only1agam is offline   Reply With Quote
Old 07-21-2009, 02:25 PM   #5
leeswrx
Scooby Newbie
 
Member#: 118295
Join Date: Jun 2006
Chapter/Region: AKIC
Vehicle:
05 STI
Blue

Default

should I go ahead and replace the clutch or the whole assembly? Thanks.
leeswrx is offline   Reply With Quote
Old 07-21-2009, 02:37 PM   #6
crampfan
Scooby Specialist
 
Member#: 74321
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: clarksville AR
Vehicle:
2004 wrx wag
black UTEC stg 4

Default

you might have someone look at it first. you should only need to replace the clutch, but I'm thinking that they only come with the compressor.
crampfan is offline   Reply With Quote
Old 07-21-2009, 04:40 PM   #7
rick-l
Scooby Specialist
 
Member#: 33868
Join Date: Mar 2003
Location: Chesterfield, MO
Vehicle:
2003 wrx
srp

Default

You might want to tighten the belt first
rick-l is offline   Reply With Quote
Old 07-22-2009, 07:24 PM   #8
vince72
Scooby Newbie
 
Member#: 89636
Join Date: Jun 2005
Chapter/Region: SCIC
Location: so-cal oc
Vehicle:
04 wrx
java black

Default

I have the same problem, when i called the dealer they only sell it as a complete unit. for about $500..convenient for them isnt it
vince72 is offline   Reply With Quote
Old 07-24-2009, 10:07 AM   #9
leeswrx
Scooby Newbie
 
Member#: 118295
Join Date: Jun 2006
Chapter/Region: AKIC
Vehicle:
05 STI
Blue

Default

Quote:
Originally Posted by rick-l View Post
You might want to tighten the belt first
I changed the belts not to log ago( 8 months.) I will try and tighten the belts up. Thanks for everyones input.
leeswrx is offline   Reply With Quote
Old 08-03-2009, 03:59 PM   #10
desiwrxpwr
Scooby Newbie
 
Member#: 33284
Join Date: Feb 2003
Chapter/Region: MWSOC
Location: Orland Park, IL
Vehicle:
2002 WRX
silver

Default

try to spray some wd-40 on the compressor wheel, I had the same problem, and I just did that and it worked, no more screaming horror from my car when the a/c is turned on.
desiwrxpwr is offline   Reply With Quote
Old 08-07-2009, 10:06 AM   #11
TixArmy
Scooby Specialist
 
Member#: 134248
Join Date: Dec 2006
Chapter/Region: SWIC
Location: Ahwatukee, AZ
Vehicle:
2007 STi-Stage2 -RIP
"Desert Sand on White"

Default

I am dealing with this issue too. However, I am in the middle of the 120 AZ Sun....

Check for leaks first and foremost. Mine had a small leak on the low side of the compressor. Low charge will cause both the squeak and the air to warm up fast.

How often does your compressor cycle? If it is often, then it has to re-charge the coolant. Again, check the levels.

For roughly $55 here I can get the system vacuumed out and topped off. I would highly recommend doing that.

You can replace the clutch by itself, though I am told it will void the rest of the compressor. General thinking is that if the clutch is going, the rest of the compressor is going too.


GL
TixArmy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Exhaust drone, vent holes in the trunk, and sound absorption ... need input Hokie-wrx wagon Interior & Exterior Modification 15 07-11-2013 06:36 PM
AC Compressor Scratchy Sound djoye Factory 2.0L Turbo Powertrain 7 12-10-2007 08:59 AM
A/C compressor startup sound IntraWRX Service & Maintenance 0 03-06-2007 04:56 PM
Compressor Surge sound and FMICs wgknestrick Factory 2.5L Turbo Powertrain 17 05-24-2004 11:05 PM
New FMIC and compressor surge sound? big_adventure Factory 2.0L Turbo Powertrain 76 03-30-2004 09:10 PM


All times are GMT -4. The time now is 11:17 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.