Welcome to the North American Subaru Impreza Owners Club Friday May 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-16-2009, 09:31 PM   #1
steveg_nh
Scooby Newbie
 
Member#: 217439
Join Date: Jul 2009
Vehicle:
2006 Legacy
Silver

Default A/C stopped work, compressor not engaging

Hi All,

I did a search and think I know the answer, but wanted to see what you all thought. I have a 2006 Legacy and this morning on the way to work, the A/C worked fine. No issues. I went on an errand at lunch, and it was hot, but I noticed that the compressor wasn't even engaging. When you pressed the a/c button you never felt or heard it engage. I'm guessing a leak that has tripped the low pressure switch, preventing it from engaging the compressor?

Should I bring it to the dealer, or do you think I'm safe to bring it to a local mechanic that does a/c work?

Thanks
* Registered users of the site do not see these ads.
steveg_nh is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-16-2009, 09:42 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Your guess is most likely correct. As long as you trust your local shop you can take it there, no need to pay dealer rates for an AC repair.
Mulder is offline   Reply With Quote
Old 07-19-2009, 09:06 PM   #3
steveg_nh
Scooby Newbie
 
Member#: 217439
Join Date: Jul 2009
Vehicle:
2006 Legacy
Silver

Default

Thanks for responding...Here's the verdict.

Got the call that they charged up the system to check for leaks, and refrigerant was blowing out of a hole in the condenser, likely caused by a rock on the highway. Nice hole in the condenser he said. Problem is, I can't see the hole. They have to order the part, so I have the car back. I have no reason not to trust this mechanic, as he's always done right by me, but considering the price of the condenser he's quoting is $350 (and I see them online for about 150 - I understand he has to make a profit, has the licenses, warranties the work and part, etc), I just want to be sure that's the problem and not just a simple replacement rather than troubleshooting. I'll certainly ask to see the hole, as he said I could see it, BEFORE I leave the car for the work.

I would think a condenser, given it's location, could take more than that though. Ever heard of this before?
steveg_nh is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Compressor Not Engaging Want_To_Buy Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 04-03-2010 09:17 AM
How not to fix a heater blower that stopped working 96WRX North West Impreza Club Forum -- NWIC 7 08-21-2009 08:26 PM
A/C Compressor not Engaging DB-STI Service & Maintenance 12 09-19-2008 04:49 PM
A/C compressor wont engage-EJ20 Blue02REX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 16 07-20-2008 07:14 PM
('93-'01) Reverse lights not engaging, 5speed OBSS Impreza Forum 3 04-10-2001 02:34 PM


All times are GMT -4. The time now is 09:46 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.