Welcome to the North American Subaru Impreza Owners Club Friday November 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-20-2009, 10:26 PM   #1
px_crstian
Scooby Newbie
 
Member#: 103332
Join Date: Dec 2005
Chapter/Region: MAIC
Location: Virginia Beach
Vehicle:
2004 WRX WAGON
PSM

Default AC needs new pulley and belts?

I have a 04 Subaru WRX wagon.

I noticed that the A/C just stopped working one day. So I checked the pressure I had more than enough Freon. I noticed that the A/C pulley wasn't moving and that the belts look kind of loose. I have 184k Miles and none of the belts have been changed in about 50k miles.

Has anyone had this problem before? Would it be the pulley seized up or is it the compressor? Thnx for any help.
* Registered users of the site do not see these ads.
px_crstian is offline   Reply With Quote
Old 07-21-2009, 01:19 AM   #2
madmax718
Scooby Specialist
 
Member#: 172501
Join Date: Feb 2008
Default

check the solinoid for activation.
madmax718 is offline   Reply With Quote
Old 07-23-2009, 09:36 AM   #3
px_crstian
Scooby Newbie
 
Member#: 103332
Join Date: Dec 2005
Chapter/Region: MAIC
Location: Virginia Beach
Vehicle:
2004 WRX WAGON
PSM

Default

Where would that be? It might be an electrical problem. Hmmmm...time to break out the ol multimeter!
px_crstian is offline   Reply With Quote
Old 07-24-2009, 10:42 PM   #4
Horkus
Scooby Newbie
 
Member#: 112667
Join Date: Apr 2006
Chapter/Region: VIC
Location: Coquitlam
Vehicle:
2002 WRX wagon
WRB

Default

A/C clutch gone
Horkus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: GFB lightened pulleys and belts Tuned New England Impreza Club Forum -- NESIC 11 09-11-2004 09:46 AM
Vishnu Underdrive Pulley and Belts Ken Levin Private 'For Sale' Classifieds 4 03-04-2004 11:15 PM
FS: VISHNU Underdrive Pulley and Belts WagonRX Bay Area Impreza Club Forum -- BAIC 4 02-10-2004 01:23 AM
Unorthodox Pulley and Belts Discjoshie Private 'For Sale' Classifieds 1 02-09-2004 05:34 PM
FS: Vishnu Underdrive pulley and belts bcristea Mid West Subaru Owners Club Forum -- MWSOC 0 01-11-2003 07:00 PM


All times are GMT -4. The time now is 02:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.