Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-23-2009, 04:00 PM   #1
mongo520
Scooby Newbie
 
Member#: 201563
Join Date: Jan 2009
Chapter/Region: International
Vehicle:
1998 impreza outback
two tone

Angry I Need Technical Help

I have a 1998 Subaru impreza outback sport, right now th eknock sencor keeps going off i thought it may have been the fule pressure so i replaced the pump but it didnt fix it, befor i go any further i would like to know if anyong knows the standard PSI for the fule system in this modle. I would also like to know if anyone knows the good/bad resistanes for the o2 sencor and the cam sencor.

thank you for your time my spelling sucks.
* Registered users of the site do not see these ads.
mongo520 is offline   Reply With Quote
Old 07-23-2009, 05:39 PM   #2
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

you may try asking in the NA powertrain forum, they may know better. If you can, post the actual code. If the car really is knocking, try a higher octane fuel and see if it goes away.

you can search for O2 resistances.
yarrgh is offline   Reply With Quote
Old 07-23-2009, 06:00 PM   #3
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

What do you mean by "going off" you are getting a knock sensor code? It is pretty common for them to go bad on that year vehicle.
munkis is offline   Reply With Quote
Old 07-23-2009, 08:02 PM   #4
mongo520
Scooby Newbie
 
Member#: 201563
Join Date: Jan 2009
Chapter/Region: International
Vehicle:
1998 impreza outback
two tone

Default

yes knock censor code, I've been using high octane for the car and it went away for about 5 months but now its back and wont stop
mongo520 is offline   Reply With Quote
Old 07-23-2009, 09:55 PM   #5
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by mongo520 View Post
yes knock censor code, I've been using high octane for the car and it went away for about 5 months but now its back and wont stop

this is a known issue

the sensor is almost certainly bad....replace the knock sensor and you will be fine
Uncle Scotty is offline   Reply With Quote
Old 07-23-2009, 11:20 PM   #6
06WRXturbo
Scooby Newbie
 
Member#: 157987
Join Date: Aug 2007
Location: VA
Vehicle:
2006 TR Sedan
black

Default

yeah just replace the knock sensor. Maybe $120+ tax OEM from a dealership. If you install it yourself, take careful note of it's position. There's a recess in the block that it sits in; you dont want it to touch the sides of the recess. One 12mm bolt. Torque spec should be 18-19 ft. lbs.
06WRXturbo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone have a pioneer avic u310bt need some help cosanostra Car Audio, Video & Security 5 06-04-2010 12:20 PM
Need technical help w/'window lock' switch wiring... UP2MTNS Electrical & Lighting 5 03-29-2010 12:57 PM
need technical help to turn my 04 into a 07 sti minus the front end ssweet08 Southern California Impreza Club Forum -- SCIC 27 01-09-2008 09:49 AM
22RE toyota truck. Need technical help. DoctorNick Off-Topic 9 09-30-2005 03:11 PM


All times are GMT -4. The time now is 03:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.