Welcome to the North American Subaru Impreza Owners Club Friday April 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-27-2009, 09:16 AM   #1
ForcedInductionPhool
Scooby Newbie
 
Member#: 217930
Join Date: Jul 2009
Chapter/Region: E. Canada
Location: Great White North :D
Vehicle:
2004 STI
WRB

Default Air Bag Light??

The car is a 2004 STI, I did not drive my car for a day and it just sat in a rainstorm all day. I got into my car to go to work today and noticed that the Air Bag light stayed on. I did a search on here to see what it could be but the only thing I would keep comming accross is a 3.3ohm resistor fix which I believe is for a 05+ with seat sensors. So my question is what are the more probable causes for this to stay on. Will a auto parts store scanner be able to pick up a code for it? Also as a side note my horn works perfectly and the CEL is not on (cruise is not flashing).

Thanks for any input.
* Registered users of the site do not see these ads.
ForcedInductionPhool is offline   Reply With Quote
Old 07-27-2009, 09:21 AM   #2
Mechie3
Scooby Guru
 
Member#: 120152
Join Date: Jul 2006
Chapter/Region: MWSOC
Location: Indy
Default

Mine does this. Check the connector under the driver seat. Sometimes they get a little loose, sometimes they corrode. Clean the connector and put it back. Mine will be on sometimes, off other times.
Mechie3 is offline   Reply With Quote
Old 07-27-2009, 10:14 AM   #3
ForcedInductionPhool
Scooby Newbie
 
Member#: 217930
Join Date: Jul 2009
Chapter/Region: E. Canada
Location: Great White North :D
Vehicle:
2004 STI
WRB

Default

Ok thanks I will check that out. Hopefully its just a loose connection. Anybody else have any suggestions?

Thanks,
ForcedInductionPhool is offline   Reply With Quote
Old 07-27-2009, 12:56 PM   #4
ForcedInductionPhool
Scooby Newbie
 
Member#: 217930
Join Date: Jul 2009
Chapter/Region: E. Canada
Location: Great White North :D
Vehicle:
2004 STI
WRB

Default

Well I went out and wiggled my yellow air bag wires under the seat and the next startup the Airbag light went off . I guess it was when I put the rear floor matt's in it must have worked them loose. Do you guy's suggest dielectric grease in the connection?

Thanks a bunch...
ForcedInductionPhool is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
STI front side air bag & Resistor to fix air bag light 02WRX_BLUE Interior & Exterior Modification 3 12-29-2004 09:16 AM
Help! Deleted Seat Air Bags & used 3.3 Ohm Resistors & getting Air Bag Light 2.2gotboost Electrical & Lighting 3 02-19-2004 09:36 AM
Valentine One causing air bag light to go on? McLaren Formula 1 Tri-State Area Forum 8 05-30-2003 04:45 PM
air bag light Aspenwhite02 Interior & Exterior Modification 8 01-15-2003 10:51 PM
('93-'01) air bag. light???? bratmantlz Impreza Forum 3 02-22-2002 09:29 AM


All times are GMT -4. The time now is 07:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.