Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-04-2009, 04:55 PM   #1
chanomatik
NASIOC Supporter
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default Spazzak's Boost Issue: Input Please

I'm posting this on behalf of Billboard2001 who's asking on behalf of spazzak (adam):

"adam has what sounds like a boost leak to me. he's not really hitting any boost until like 5k rpm and then even so it's a wimpy pull, not like it used to be. my guess is a leak in the turbo inlet tubes or vac. lines or somethin like that, or the wastegate arm may be loose. the turbo still spools and sounds normal, he's just not getting boost. I was doing some rough research trying to diagnose the problem and that's my guess. Lemme know if you have any other ideas or had anyone that had similar problems.
Thanks, Bill"

The car is a bugeye WRX sedan. Anyone have any ideas? You can pm Billboard2001 or spazzak direct or just reply here. Thanks guys.

-Chano
* Registered users of the site do not see these ads.

Last edited by chanomatik; 08-05-2009 at 04:55 PM. Reason: "What kind of car is it", he asks?
chanomatik is online now   Reply With Quote
Old 08-05-2009, 04:40 AM   #2
sol0
Scooby Specialist
 
Member#: 152976
Join Date: Jul 2007
Chapter/Region: AKIC
Location: UK
Vehicle:
MkVI Jetta TDI
EF6 CRX 1.5x

Default

I would get ahold of a intake system boost pressure tester. You can usually fab one up out of pvc, sealant, and a tire valve stem. I know that there are a few people on the board that have a few, but I forget exactly who.

Google is your friend if you want to try to make your own.

Hook up the tester to your system and using an air compressor, pressurize the system to specified psi (like 22psi). Listen for hissing, that is your problem. If its the wastegate arm, that won't show its ugly face because its obviously not on the cold side plumbing. GL with troubleshooting!
sol0 is offline   Reply With Quote
Old 08-05-2009, 05:30 AM   #3
TurboSetch
Scooby Specialist
 
Member#: 192358
Join Date: Oct 2008
Chapter/Region: AKIC
Location: Palmer,AK
Vehicle:
MANY P3 Import Auto
907 355 6655

Default

A leak that big you should be able to see or hear. Look for a big rip in the IC hose.

What kind of car is this? We need a little more info...

Go back to the basics. Worst case you have a bad turbo or damaged internals. Also leaking manifold exhaust or intake could cause this.

What does vac read at idle? Should be around 20 on the vac gauge?
TurboSetch is offline   Reply With Quote
Old 08-05-2009, 04:54 PM   #4
chanomatik
NASIOC Supporter
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

My bad. I knew I forgot something. It's a bugeye WRX sedan. I'll edit my OP.
chanomatik is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Grah! Compressor Calculations, RiftsWRX, Anybody Yer input please! sherifx Factory 2.0L Turbo Powertrain 9 05-07-2002 12:06 PM
Rifts your input please... sherifx Mid West Subaru Owners Club Forum -- MWSOC 20 04-22-2002 11:40 AM
Blitz FMIC/SBC owners - input please rayder Factory 2.0L Turbo Powertrain 1 04-11-2002 05:46 PM
Unsure of problem... input please. TFW Factory 2.0L Turbo Powertrain 12 03-27-2002 07:01 AM
your input please! wrx for sale! need advice! fooie8 General Community 6 12-29-2001 05:10 PM


All times are GMT -4. The time now is 01:46 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.