Welcome to the North American Subaru Impreza Owners Club Friday July 1, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-03-2009, 12:08 AM   #1
ICEEPUCK
Scooby Newbie
 
Member#: 174679
Join Date: Mar 2008
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2003 WRB WRX
Blue w/ black hoodscoop

Default Coolant leak...

This morning, on my way to work, my belt started to squeal. Turns out, it was coolant leaking from somewhere. Looks like radiator cap/reservoir area. We live in Wasilla, but work in Anchorage, and it was fine for the drive. I'm thinking maybe something just backed up. It was in the first 15 minutes of the car running.(thermostat stuck maybe?) Does anyone know if subarus have any habitual cooling system problems? I looked around and couldn't find much, but when I bought coolant at Schucks, the guy that rang me up said his friend's sti did the same thing. I just don't want the car to shut down on me randomly. Thanks in advance for any help given.
* Registered users of the site do not see these ads.
ICEEPUCK is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-03-2009, 02:42 AM   #2
Mrs. White
Scooby Newbie
 
Member#: 207314
Join Date: Apr 2008
Chapter/Region: AKIC
Location: Yay Summer, AK
Vehicle:
63 Impala Wagon

Default

I just saw a black 04/05 sti at a stop light with whitE smoke coming out of the grill yesterday, I hope coolant leaks aren't in the air...
Mrs. White is offline   Reply With Quote
Old 08-03-2009, 02:55 PM   #3
rack
Scooby Newbie
 
Member#: 32908
Join Date: Feb 2003
Chapter/Region: AKIC
Location: Alaska, Anchorage
Vehicle:
2005 Impreza WRX STI
BLUE

Default

My 05 STi has coolant leak, and sqealing belt as well. Conti hasn't been able to see any visual signs of the leaking yet though. While inspecting it, I don't see any either.

It is also only during the first few mins of start up, and the sqealing makes me sound like a beater with a heater =(

If you find out the issue, please post back, I would love to know what may be wrong with my STi.
rack is offline   Reply With Quote
Old 08-03-2009, 03:44 PM   #4
Mrs. White
Scooby Newbie
 
Member#: 207314
Join Date: Apr 2008
Chapter/Region: AKIC
Location: Yay Summer, AK
Vehicle:
63 Impala Wagon

Default

Nobody has succesfully done a pressure check? Go to a radiator specialist, try Dean's Radiator...
Mrs. White is offline   Reply With Quote
Old 08-03-2009, 09:33 PM   #5
ICEEPUCK
Scooby Newbie
 
Member#: 174679
Join Date: Mar 2008
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2003 WRB WRX
Blue w/ black hoodscoop

Default

Cracked radiator FTW!!!


found the problem


It was cracked dead center on the top front. Just to the left of the cap. I drove it hard on the way home last night. When I opened the hood, there was a nice little bubble trail about 4 inches long lengthwise on the top.

As for rack, I agree with Mrs. White. Get a pressure test done. They should be able to find it fairly easily. You prolly have a pinhole leak in a hose, possibly even a hole in the core caused by a rock. Honestly, it could be any number of things, so don't quote me. Your best bet is to pony up and have someone do a pressure test.
ICEEPUCK is offline   Reply With Quote
Old 08-03-2009, 09:59 PM   #6
missiceblast
Scooby Specialist
 
Member#: 142304
Join Date: Mar 2007
Default

woot major crisis missed!!!
missiceblast is offline   Reply With Quote
Old 08-03-2009, 10:07 PM   #7
ICEEPUCK
Scooby Newbie
 
Member#: 174679
Join Date: Mar 2008
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2003 WRB WRX
Blue w/ black hoodscoop

Default

Not really, my Jeep has a blown head gasket right now and won't run. I don't have the time to fix it, so I'll prolly just keep adding coolant until the Mishimoto gets here, and I get some time off.
ICEEPUCK is offline   Reply With Quote
Old 08-06-2009, 04:27 PM   #8
rack
Scooby Newbie
 
Member#: 32908
Join Date: Feb 2003
Chapter/Region: AKIC
Location: Alaska, Anchorage
Vehicle:
2005 Impreza WRX STI
BLUE

Default

Quote:
Originally Posted by Mrs. White View Post
Nobody has succesfully done a pressure check? Go to a radiator specialist, try Dean's Radiator...
Conti has done 2 or 3 pressue tests, and looked at it 2 or 3 times.

No luck for me.
rack is offline   Reply With Quote
Old 08-06-2009, 07:52 PM   #9
TurboSetch
Scooby Specialist
 
Member#: 192358
Join Date: Oct 2008
Chapter/Region: AKIC
Location: Palmer,AK
Vehicle:
MANY P3 Import Auto
907 355 6655

Default

Fix crack with JB weld or some sort of epoxy. Granted its a temp fix but it will work until you get time to fix properly. I also have a plastic welder if you want to give that a shot.
TurboSetch is offline   Reply With Quote
Old 08-06-2009, 07:57 PM   #10
ICEEPUCK
Scooby Newbie
 
Member#: 174679
Join Date: Mar 2008
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2003 WRB WRX
Blue w/ black hoodscoop

Default

I already had some epoxy in the car. I threw it on there as soon as I found the crack.
ICEEPUCK is offline   Reply With Quote
Old 08-06-2009, 09:25 PM   #11
rivman05
Scooby Specialist
 
Member#: 159986
Join Date: Sep 2007
Chapter/Region: AKIC
Location: YK Delta
Vehicle:
1994 Acura Integra
Milano Red

Default

if its only during start up, do the suby water pumps have a weep hole? maybe the mating faces arent perfectly flat, and leak when cold but once they expand a bit it quits?
rivman05 is offline   Reply With Quote
Old 08-06-2009, 09:27 PM   #12
Tiene Boost?
Scooby Newbie
 
Member#: 171826
Join Date: Feb 2008
Location: Nuevo Mexico
Vehicle:
2003 wrx
PSM

Default

2003 wrx radiator is natorious for caracking!!
Tiene Boost? is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
coolant leak, but without the leak iloveturbos Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 17 03-30-2003 12:30 AM
coolant leak drboost2002 Bay Area Impreza Club Forum -- BAIC 4 02-07-2002 02:15 AM
serious coolant leak ColinL Normally Aspirated Powertrain 12 11-21-2001 03:48 PM
Coolant Leak KKL Vancouver Impreza Club Forum -- VIC 2 11-03-2001 11:26 AM

All times are GMT -4. The time now is 01:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.