Welcome to the North American Subaru Impreza Owners Club Monday September 15, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Interior & Exterior Modification

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-31-2009, 05:13 PM   #76
tphskab
Scooby Specialist
 
Member#: 114466
Join Date: May 2006
Chapter/Region: RMIC
Location: South Jordan, UT
Vehicle:
Bowl of
white rice

Default

I want to do this so bad but have heard people say it fades to pink over time..
* Registered users of the site do not see these ads.
tphskab is offline   Reply With Quote
Old 08-31-2009, 05:13 PM   #77
09NewfieWRX
Scooby Newbie
 
Member#: 59036
Join Date: Apr 2004
Location: St. John's, NL./Canada
Vehicle:
2013 Outback
Venician Red

Wink

Quote:
Originally Posted by JGard View Post
Oh, another question. Those of you who did your third brake light...how? I can't get it out of the car, as the wires don't seem to have an accessible harness anywhere. I'm sure as hell not going to spray while they're on the car, either.
...you have to remove the rear spoiler.
It's held on with 2 nuts & 2 bolts. Disconnect the rear windshield washer hose and electrical for the LED then pop it off the rear hatch. Once you have this done, you can unbolt the LED to remove for painting.
09NewfieWRX is offline   Reply With Quote
Old 08-31-2009, 07:23 PM   #78
damanpaul23@aol.com
Scooby Newbie
 
Member#: 221969
Join Date: Aug 2009
Location: Agoura Hills
Vehicle:
09 WRX
Black

Default

ahhh im dying to do mine but i get soo lazy with that
damanpaul23@aol.com is offline   Reply With Quote
Old 08-31-2009, 10:14 PM   #79
homer_atl
Scooby Newbie
 
Member#: 210965
Join Date: May 2009
Vehicle:
2009 WRX

Default

hey all. you guys should check out iwsti for my original post on painting. tons of pics from others with different paints. i went testors and it's held up so far (since feb 09). but after seeing some of the guys w/ metalcast red i think i'm going to remove my paint and redo w/ metalcast.

http://www.iwsti.com/forums/gr-exter...her-one-2.html
homer_atl is offline   Reply With Quote
Old 08-31-2009, 10:16 PM   #80
homer_atl
Scooby Newbie
 
Member#: 210965
Join Date: May 2009
Vehicle:
2009 WRX

Default

i know how you feel. dont worry tho. it can be fixed. i redid mine a couple of times. it just takes a little time to undo the old paint.

Quote:
Originally Posted by Spindrift View Post
Tried it on my 06 and I think it looks like crap. Super flat, even with the clearcoat.

Fail?

homer_atl is offline   Reply With Quote
Old 09-01-2009, 09:35 AM   #81
wrx jay
Scooby Specialist
 
Member#: 201269
Join Date: Jan 2009
Chapter/Region: NESIC
Location: RI
Vehicle:
2009 Foz
Silver

Default

This mod is soo worth it on the newer WRX/STI's. I've said this before but this is how they should have came from the factory.
wrx jay is offline   Reply With Quote
Old 09-01-2009, 12:14 PM   #82
EGREX
Scooby Newbie
 
Member#: 219126
Join Date: Aug 2009
Chapter/Region: NESIC
Location: MA
Vehicle:
09 WRX Hatch
SSM

Default

I went the lamin-x route, stuff was pretty difficult to apply around the wave on the outside light. They look great but up close you see a few imperfections, overall look is much cleaner. If the paint holds up I may go that route in the future, figured I start with something removable...

EGREX is offline   Reply With Quote
Old 09-01-2009, 12:23 PM   #83
tphskab
Scooby Specialist
 
Member#: 114466
Join Date: May 2006
Chapter/Region: RMIC
Location: South Jordan, UT
Vehicle:
Bowl of
white rice

Default

has anyone had their tails painted for a while? AT LEAST 6 or 8 months? Any noticeable fading yet?
tphskab is offline   Reply With Quote
Old 09-01-2009, 12:28 PM   #84
Dan07WRX
Scooby Newbie
 
Member#: 154374
Join Date: Jul 2007
Chapter/Region: MWSOC
Location: Illinois
Vehicle:
2011 WRX Sedan Prem
Satin White Pearl

Default

Quote:
Originally Posted by JGard View Post
Oh, another question. Those of you who did your third brake light...how? I can't get it out of the car, as the wires don't seem to have an accessible harness anywhere. I'm sure as hell not going to spray while they're on the car, either.

I just cut the 2 wires in mine...... and just used but connectors to reconnect them...... easy enough.
Dan07WRX is offline   Reply With Quote
Old 09-01-2009, 12:50 PM   #85
dwf137
Scooby Specialist
 
Member#: 161333
Join Date: Oct 2007
Chapter/Region: NWIC
Location: Seattle
Vehicle:
'09 wrx
'14 Outback

Default

i painted and I'm NOT happy with the results.

It's just my painting skill, but there's air bubbles, and the thickness is variable, giving dark and light spots.

Switching over to laminx.
dwf137 is offline   Reply With Quote
Old 09-01-2009, 04:44 PM   #86
EGREX
Scooby Newbie
 
Member#: 219126
Join Date: Aug 2009
Chapter/Region: NESIC
Location: MA
Vehicle:
09 WRX Hatch
SSM

Default

Its $50-55 for the WRX kit, comes with the blade and a fine mist bottle. Do the inners first to get a feel for the film...the outers will be tough to get pefect.
EGREX is offline   Reply With Quote
Old 09-01-2009, 07:20 PM   #87
homer_atl
Scooby Newbie
 
Member#: 210965
Join Date: May 2009
Vehicle:
2009 WRX

Default

i've had mine for about 6 months. mine looks the same. i used the testors paint. my pics can be found at the link in my prior post... couple posts up frmo this one. the only thing with the pictures is it looks more opaque than it is in person. anyhow, i think some have said testors will fade, but metalcast is rated for higher temps, so it should be less likely to fade. anyhow your results on how it looks depends on how good you are with the spray can so results vary. good luck!



Quote:
Originally Posted by tphskab View Post
has anyone had their tails painted for a while? AT LEAST 6 or 8 months? Any noticeable fading yet?
homer_atl is offline   Reply With Quote
Old 09-01-2009, 08:17 PM   #88
tphskab
Scooby Specialist
 
Member#: 114466
Join Date: May 2006
Chapter/Region: RMIC
Location: South Jordan, UT
Vehicle:
Bowl of
white rice

Default

and I suppose worst case scenario, it fades and I paint it again.
tphskab is offline   Reply With Quote
Old 09-01-2009, 11:57 PM   #89
homer_atl
Scooby Newbie
 
Member#: 210965
Join Date: May 2009
Vehicle:
2009 WRX

Default

you can strip and paint again. personally i'd go for something w/ the temp resistance and then make sure to put on several clearcoat layers.
homer_atl is offline   Reply With Quote
Old 09-03-2009, 07:10 PM   #90
Ninjutsu PiloT
Scooby Newbie
 
Member#: 204449
Join Date: Mar 2009
Vehicle:
2011 STI
Blue

Default Not sure what happened

So I was working on this a few hours ago to fix these ugly lights and all was going well until I dropped something on one of the lights, smudging the paint and I have to strip it and repaint it (sucks for me) but I reconnected the battery after I reattached the lights and went to start my car and it didn't start.

I could get the starter to run but for whatever reason I didn't get it to turn over. I tried again and it worked and I drove around for a little bit in case the battery needed some charge but I don't know what caused this.
Ninjutsu PiloT is offline   Reply With Quote
Old 09-03-2009, 07:35 PM   #91
elwray
Scooby Specialist
 
Member#: 194826
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: Central NJ
Vehicle:
'09 WRX 5dr PP DGM
'07 VTX1300c, '03 VFR800

Default

Don't worry about it, I don't think.

I don't know if it's the fuel pump losing prime or what, but whenever you disconnect the battery it takes a few cranks before it fires.

The first time I ever disconnected the battery the same thing happened. FREAKED me out because I had just put in my Kenwood stereo and thought I botched something BIG TIME.

Also, every time I flash a new map to the ECU, the same thing happens.

I don't know exactly what it is that's happening, but just keep that key turned until it starts
elwray is offline   Reply With Quote
Old 09-04-2009, 10:00 AM   #92
redobs
NASIOC Supporter
 
Member#: 1501
Join Date: May 2000
Chapter/Region: NESIC
Location: Nashua, NH
Vehicle:
2009 WRX wagon
Dark grey

Default

How many coats of paint are you putting on?
redobs is offline   Reply With Quote
Old 09-04-2009, 07:22 PM   #93
boostin08wrx
Scooby Newbie
 
Member#: 166307
Join Date: Dec 2007
Location: Jersey
Vehicle:
2008 Impreza WRX
OBP

Default

Quote:
Originally Posted by elwray View Post
Don't worry about it, I don't think.

I don't know if it's the fuel pump losing prime or what, but whenever you disconnect the battery it takes a few cranks before it fires.

The first time I ever disconnected the battery the same thing happened. FREAKED me out because I had just put in my Kenwood stereo and thought I botched something BIG TIME.

Also, every time I flash a new map to the ECU, the same thing happens.

I don't know exactly what it is that's happening, but just keep that key turned until it starts
From what i was told disconnecting the battery for a little bit resets the ecu and takes awhile to reset itself... but im not saying thats your problem, just something i've heard.
boostin08wrx is offline   Reply With Quote
Old 09-04-2009, 07:26 PM   #94
elwray
Scooby Specialist
 
Member#: 194826
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: Central NJ
Vehicle:
'09 WRX 5dr PP DGM
'07 VTX1300c, '03 VFR800

Default

Well, it definitely does reset the ECU. Don't know why it keeps it from starting, but for whatever reason I stopped worrying about it... maybe I shouldnt?
elwray is offline   Reply With Quote
Old 09-04-2009, 11:18 PM   #95
Ninjutsu PiloT
Scooby Newbie
 
Member#: 204449
Join Date: Mar 2009
Vehicle:
2011 STI
Blue

Default Red on red

Unfortunately I have a bad schedule right now and I have had to work on this project in pieces but here is what it looks like on red, or excuse me, LIGHTNING red!



I painted the back of the light black instead of the light gray, I think it goes better with the flow of the car. This is 1 coat of paint, I don't think I need any more
Ninjutsu PiloT is offline   Reply With Quote
Old 09-06-2009, 05:23 PM   #96
nitroinsane
Scooby Newbie
 
Member#: 216027
Join Date: Jul 2009
Default

I did the same and my third brake light
nitroinsane is offline   Reply With Quote
Old 09-06-2009, 06:24 PM   #97
dwf137
Scooby Specialist
 
Member#: 161333
Join Date: Oct 2007
Chapter/Region: NWIC
Location: Seattle
Vehicle:
'09 wrx
'14 Outback

Default

Quote:
Originally Posted by EGREX View Post
Its $50-55 for the WRX kit, comes with the blade and a fine mist bottle. Do the inners first to get a feel for the film...the outers will be tough to get pefect.
yea, i can imagine with all of the contours.

I have a heat gun though, so i should be able to manage, I wrapped my mini cooper tail lights with tinted laminx just a few weeks ago, about a week before trading it in for the rex.

I'm happy with the look from a distance, but up close is where I'm unhappy..

dwf137 is offline   Reply With Quote
Old 09-06-2009, 09:11 PM   #98
NorthBayResident
Scooby Newbie
 
Member#: 204200
Join Date: Feb 2009
Chapter/Region: BAIC
Vehicle:
2008 Impreza 2.5i
DGM

Default

Quote:
Originally Posted by nhmtns View Post

The lights look awesome!

and not to throw this thread off topic, but what base racks are those and how much were they? I am in the market for a set, and right now the OEM crossbars just are not doin' it for me

Thanks
-NBR
NorthBayResident is offline   Reply With Quote
Old 09-07-2009, 04:05 PM   #99
tphskab
Scooby Specialist
 
Member#: 114466
Join Date: May 2006
Chapter/Region: RMIC
Location: South Jordan, UT
Vehicle:
Bowl of
white rice

Default

I am working on this right now. I am on the liner part of the hatch and the last two corners will not break loose! Getting a little frustrated! And sweaty
tphskab is offline   Reply With Quote
Old 09-07-2009, 08:37 PM   #100
tphskab
Scooby Specialist
 
Member#: 114466
Join Date: May 2006
Chapter/Region: RMIC
Location: South Jordan, UT
Vehicle:
Bowl of
white rice

Default

turned out great!
tphskab is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New! Clear Tail Light Mod... WRX Rally Style Subie Gal Member's Car Gallery 33 03-15-2011 07:08 AM
2009 WRX fog light mod Andrey Electrical & Lighting 8 04-24-2010 05:43 AM
WTT: my06 sti taillight for you 05 sti/wrx tail light + $20, local swap only, (FL) yenny Private 'Wanted' Classifieds 2 08-02-2009 01:39 AM
WTT 2006 WRX tail lights for 2005 WRX tail lights SCRAPPYDO TXIC Private Classifieds 4 12-04-2006 01:01 AM
WTT 2006 WRX tail lights for 2005 WRX tail lights flymordecai TXIC Private Classifieds 1 11-23-2006 01:07 AM


All times are GMT -4. The time now is 07:16 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.