Welcome to the North American Subaru Impreza Owners Club Thursday October 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-07-2009, 08:03 AM   #1
snook07wrx
Scooby Newbie
 
Member#: 214630
Join Date: Jun 2009
Chapter/Region: MWSOC
Location: Northern IL
Default CEL and cruise control light blinking...

I put in a larger TMIC last night and when I started it up it sputtered for a sec. then ran smooth, so I took it for a drive. Once I gave it a little gas and it started to boost you could hear it all escaping. I came right back, checked all the fittings, everything...it's all tight, nothing missing, etc. This morning on the way to work check engine light comes on (and stays on) and the cruise control light flashes on and off. After work I'm going today I'm going to take a closer look into the issue. For now just wondering if anyones has any input, etc. 2007, wrx, 2.5L MT, TBE and Cobb AP stg 2 are the only mods other then the new top mount. Thanks.
* Registered users of the site do not see these ads.
snook07wrx is offline   Reply With Quote
Old 08-08-2009, 11:15 AM   #2
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

There's a thing called a "carriage return". Use it.

It sure does sound like a boost leak. Do a search for blinking cruise, that may give you more info.
yarrgh is offline   Reply With Quote
Old 08-08-2009, 02:09 PM   #3
BxrRmble
Scooby Newbie
 
Member#: 214549
Join Date: Jun 2009
Chapter/Region: MAIC
Location: Arlington, VA
Vehicle:
2006 STi
OBP rollin on Gold

Default

As far as i know the cruise control light is only blinking to get your attention...correct me if im wrong tho.
BxrRmble is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control Light Blink but no CEL after Maddad Header install, please help. Treefolk Newbies & FAQs 3 07-31-2008 06:03 AM
Cruise control light blinking + CEL nikiSTI Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 28 02-22-2008 12:48 AM
CEL came on, and Cruise Control light is flashing 07Wagon Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 14 12-31-2007 12:12 PM
CEL and Cruise Control Blinking #17B STI AccessPort 3 11-26-2007 10:24 AM
HELP! Check Engine light on & Cruise Control Light Blinking STiURBO Southern California Impreza Club Forum -- SCIC 21 03-15-2007 01:54 AM


All times are GMT -4. The time now is 03:58 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.