Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-15-2009, 05:26 AM   #1
WRXMAN2004
Scooby Newbie
 
Member#: 190473
Join Date: Sep 2008
Default need help, just got into the subbies..

My car is blowing white smokes even when it's warm, what can cause it..
I asked couple of mechanic and they said, it runs to rich?..
* Registered users of the site do not see these ads.
WRXMAN2004 is offline   Reply With Quote
Old 08-15-2009, 07:17 AM   #2
Charlie-III
Scooby Specialist
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: 07456, North NJ
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper Wagon

Default

Engine diagnostics work the same for any engine.

If it's white coming from the exhaust, it sounds like steam. Steam can be condensation (which should clear up as the exhaust gets warm) or a bad head gasket.

White = steam (disappears quickly)
Blue = oil (lingers around, most noticeable during start up)
Black = rich on gas (lingers around)

1-What year & model car do you have
2-Are you losing coolant
3-What mods do you have
4-What knid of fuel mileage do you get
Charlie-III is offline   Reply With Quote
Old 08-15-2009, 10:28 AM   #3
WRXMAN2004
Scooby Newbie
 
Member#: 190473
Join Date: Sep 2008
Default

I have a 07 wrx tr.. Im not losing coolants, and it's all stock only a intake..
After I put 90's gas into my car, my buddy dumped octane boost in it..
after the next day morning i started it up, I notice even when they car get's warm the smoke still comes out alot..
WRXMAN2004 is offline   Reply With Quote
Old 08-15-2009, 10:32 AM   #4
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

If you hae never seen a stuck open fuel injector it will also prodcue a heavy cloud of white/grey smoke consistantly.

If you are not overheating, losing coolant. I would suspect that. Are you getting misfire codes?
munkis is offline   Reply With Quote
Old 08-15-2009, 10:45 AM   #5
WRXMAN2004
Scooby Newbie
 
Member#: 190473
Join Date: Sep 2008
Default

for missfire codes doesn't the check engine light comes on?.. because my lights doesn't comes on..
WRXMAN2004 is offline   Reply With Quote
Old 08-15-2009, 10:49 AM   #6
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

Have you run through a tank of gas yet and tried a different station? Are you losing oil?
munkis is offline   Reply With Quote
Old 08-15-2009, 11:02 AM   #7
WRXMAN2004
Scooby Newbie
 
Member#: 190473
Join Date: Sep 2008
Default

im not losing oil, no i haven't try different station yet.. i only go to chevron..but i'll try somewhere else next time..
WRXMAN2004 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help, need a bodyshop, just got into an accident Impr3zaGuy Southern California Impreza Club Forum -- SCIC 6 06-14-2004 11:09 PM
Just got into the area benjaminetanyahoo Mid Atlantic Impreza Club -- MAIC 10 11-17-2003 08:51 PM
need help just got ticket sinassassin New England Impreza Club Forum -- NESIC 11 04-25-2002 07:47 PM
Just got into accident...need advice KimchiHo New England Impreza Club Forum -- NESIC 28 09-23-2001 11:06 PM


All times are GMT -4. The time now is 12:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.