Welcome to the North American Subaru Impreza Owners Club Saturday May 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-18-2009, 07:08 PM   #1
jewski-bugI
Scooby Newbie
 
Member#: 186391
Join Date: Aug 2008
Chapter/Region: BAIC
Location: central cali!
Vehicle:
2002 impreza wrx
SRP

Default Why Is My Car Doing This!!!!????

i have a 2002 2.5 rs

i just replaced my motor with a REBUILT 2.5 motor from atarco.. so pretty much everything is brand new...

my car will not stop smoking, people say that it takes a while for your motor to brake in and for the pistons to settle.. but exactly how long cause this rebuilt motor has about 400 miles on it that i put on it..and its still smoking

idk if its because i halowed out my cats or what ...

but this is really bugging me..??

if anyone has had this situation let me know cause its driving me crazy seeing a huge cloud of smoke behind me everywere i go !!!!!

PLEASE HELP

THANKS
* Registered users of the site do not see these ads.
jewski-bugI is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-18-2009, 07:15 PM   #2
jetfan2207
Scooby Specialist
 
Member#: 61950
Join Date: May 2004
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
2008 Outback
big blue wagon

Default

Make sure you have the correct amount of oil, not too much.

Good Luck,
Steve
jetfan2207 is offline   Reply With Quote
Old 08-18-2009, 07:22 PM   #3
jewski-bugI
Scooby Newbie
 
Member#: 186391
Join Date: Aug 2008
Chapter/Region: BAIC
Location: central cali!
Vehicle:
2002 impreza wrx
SRP

Default

alright thanks!!!
jewski-bugI is offline   Reply With Quote
Old 08-18-2009, 08:19 PM   #4
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

whas this a complete motor? including heads and everything?

what was the problem with the old one?
munkis is offline   Reply With Quote
Old 08-18-2009, 09:45 PM   #5
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Where exactly is the smoke coming from? Are you sure it is coming from the motor and not from under the vehicle? Does it happen right away or after the engine is warmed up?
RexyGirl is offline   Reply With Quote
Old 08-19-2009, 02:55 AM   #6
WRrexu
Scooby Specialist
 
Member#: 217061
Join Date: Jul 2009
Chapter/Region: Tri-State
Vehicle:
2009 Wrx

Default

did a previous turbo burn oil . i had an old volvo that burnt oil in the turbo. and after i rebuilt the motor , and put a new turbo in . the exhaust had so much built up oil that it took nearly 1000 miles to burn off !!!
WRrexu is offline   Reply With Quote
Old 08-19-2009, 12:28 PM   #7
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Bailey, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

what color is the smoke?
yarrgh is offline   Reply With Quote
Old 08-28-2009, 11:20 AM   #8
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Any news?
RexyGirl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is my car doing this? thechickencow Mid West Subaru Owners Club Forum -- MWSOC 33 05-07-2008 03:09 AM
Why Is My Car Doing This ez-e Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 02-22-2007 05:26 PM
Why is my 4EAT doing this? SubaruImpreza_power Transmission (AT/MT) & Driveline 10 09-16-2006 02:38 PM
Why is my car doing this? Any ideas Tim Sanderson Mid West Subaru Owners Club Forum -- MWSOC 6 01-07-2004 09:36 AM
Why is my computer doing this? jasona Off-Topic 4 10-21-2003 12:41 AM

All times are GMT -4. The time now is 02:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.