Welcome to the North American Subaru Impreza Owners Club Monday May 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-18-2009, 08:40 PM   #1
nine7oh
Scooby Newbie
 
Member#: 208840
Join Date: Apr 2009
Chapter/Region: RMIC
Vehicle:
2004 FXT, White
18ged

Default Tranny Fluid Leak? Brand new axle seals just installed

Ok so about a weak ago i realized i was leaking tranny fluid from what was thought to be my axle seals. I had bought new axle seals and o rings for my 04 sti. I pulled my axles and i removed the plates on the tranny that the output shafts come out of so i could get to the seals and the o rings easier. I made tick marks on these plates and i counted the amount of rotations it took to get each plate off. When i was done i lowered the car off the jack stands and then i put 2 quarts of tranny fluid in. I then jacked the rear end of the car up so i could reconnect my exhaust and then the fluid started pouring out from the seals i had just put in. Are these seals not in correctly or is something else messed up.. I have no clue what to do from here so if any of you have any ideas as to what might be happening please let me know. I put everything back together to what i thought was correct and everything was greased and or lubed before it was put in and the pins in the axle were put back in... Again any advice is greatly appreciated. Thanks a ton
* Registered users of the site do not see these ads.
nine7oh is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-18-2009, 09:49 PM   #2
nine7oh
Scooby Newbie
 
Member#: 208840
Join Date: Apr 2009
Chapter/Region: RMIC
Vehicle:
2004 FXT, White
18ged

Default

Bump For Some Help Please!!!
nine7oh is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tranny Leak after installing brand new Axle Seals?? Please help nine7oh Transmission (AT/MT) & Driveline 7 08-20-2009 02:17 AM
Tranny fluid leak!! silence2-38554 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 04-02-2007 06:10 PM
Front Diff/Tranny fluid leak... Mohaj Transmission (AT/MT) & Driveline 0 06-24-2006 03:45 AM
Dealer installed center diff: all my tranny fluid leaked out on the way home! dcoty Transmission (AT/MT) & Driveline 4 10-20-2003 01:14 AM
tranny fluid leak? Mr Cheese Forester Forum 2 12-31-2002 04:33 PM


All times are GMT -4. The time now is 11:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.