Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-23-2014, 02:08 AM   #1
kevinlmiller06sti
Scooby Newbie
 
Member#: 399332
Join Date: Aug 2014
Subaru Banner HELP!!!! car is ****ed

So I have a 2006 subaru sti and I may have ****ed the engine up not sure I was off reading and got water all over my engine so I cleaned my maf and it idles at 2000 and will only Rev to 4500 rpms and the engine sounds really rough also since I cleaned my maf I have flames shooting out my exhaust turbo doesn't spool at all and it will go in to first but I have to keep giving it gas non stop to keep it running in first gear and wont go past 3 mph can anyone help
* Registered users of the site do not see these ads.
kevinlmiller06sti is offline   Reply With Quote
Old 10-23-2014, 02:13 AM   #2
Zefy
Scooby Specialist
 
Member#: 105104
Join Date: Jan 2006
Chapter/Region: VIC
Location: Coquitlam, BC, Canada
Vehicle:
1979 BRAT / 01 RSTI
99 2.5TS (DEAD) / 87 GL

Default

Slow down, make some sentences.

How did water get all over your engine while you were reading?

What did you clean the maf with?
Zefy is offline   Reply With Quote
Old 10-23-2014, 02:13 AM   #3
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2014 Porsche
GT3 (Currently on Fire)

Default

Slow down, make a good post. You have one giant run on sentence with little context.

Let's start small, do you have a CEL? What is it?
HinshawWRX is offline   Reply With Quote
Old 10-23-2014, 01:37 PM   #4
Local_Skater
Scooby Specialist
 
Member#: 117454
Join Date: Jun 2006
Chapter/Region: MAIC
Location: Winchester, VA
Vehicle:
2005 Forester XT
PSM PDX Stg II

Default

I'm assuming he meant to say off roading. In an STI. Probably through deep water.
Local_Skater is offline   Reply With Quote
Old 10-23-2014, 01:50 PM   #5
mj213
Scooby Newbie
 
Member#: 252218
Join Date: Jul 2010
Chapter/Region: SWIC
Location: Prescott
Vehicle:
2002 Forester
Paint colored!

Default

While reading "Where the Girls Aren't" on his Ipad 3.
mj213 is offline   Reply With Quote
Old 10-23-2014, 01:56 PM   #6
Brent22
Scooby Specialist
 
Member#: 350169
Join Date: Mar 2013
Chapter/Region: MAIC
Location: Lancaster, Pennsylvania
Vehicle:
2013 WRX Hatch
WRB

Default

Brent22 is offline   Reply With Quote
Old 10-23-2014, 02:25 PM   #7
acemastr
Scooby Newbie
 
Member#: 400510
Join Date: Sep 2014
Chapter/Region: South East
Location: Tampa, FL
Vehicle:
2015 WRX Limited CVT
World Rally Blue

Default

Worst troll post ever.
acemastr is offline   Reply With Quote
Old 10-23-2014, 02:52 PM   #8
Daniel Dudley
Scooby Specialist
 
Member#: 307610
Join Date: Jan 2012
Location: Far Out
Vehicle:
2004 WRX Wagon

Default

If what you are saying is true, you need to stop running your car IMMEDIATELY.

You are pumping gas out your exhaust, and you are going to wreck your cats or worse. Most likely you are running on three cylinders or less, and raw gas is passing the cylinder.

Stop driving, and tow it to a mechanic. You are way over your head.
Daniel Dudley is offline   Reply With Quote
Old 10-23-2014, 03:12 PM   #9
acemastr
Scooby Newbie
 
Member#: 400510
Join Date: Sep 2014
Chapter/Region: South East
Location: Tampa, FL
Vehicle:
2015 WRX Limited CVT
World Rally Blue

Default

the 'won't go past 3 mph' bit made it for me... good try OP
acemastr is offline   Reply With Quote
Old 10-23-2014, 07:35 PM   #10
I Like Cooters
Scooby Newbie
 
Member#: 394806
Join Date: Jun 2014
Default

He probably re-installed his MAF sensor backwards. Denso really should have designed them so there'd only be one obvious way to screw it down.
I Like Cooters is offline   Reply With Quote
Old 10-23-2014, 08:05 PM   #11
Badler
Scooby Guru
 
Member#: 133597
Join Date: Nov 2006
Chapter/Region: SCIC
Location: Orange
Default

Quote:
Originally Posted by I Like Cooters View Post
He probably re-installed his MAF sensor backwards. Denso really should have designed them so there'd only be one obvious way to screw it down.
Yup. The way it looks like it should go isn't the way that it goes.
Badler is offline   Reply With Quote
Old 10-23-2014, 10:26 PM   #12
pearljam11
Scooby Specialist
 
Member#: 113335
Join Date: Apr 2006
Location: Downingtown, Pa
Vehicle:
13 WRB BRZ Limited
05 STi AgileTuned 320/352

Default

Definite troll. Look at the time of posting too. If this was a real he'd be posting immediately after these issues started and I doubt he was off roading from 10-1 a.m.
pearljam11 is offline   Reply With Quote
Old 10-23-2014, 11:43 PM   #13
Dave D.
NASIOC Supporter
 
Member#: 130990
Join Date: Nov 2006
Chapter/Region: NWIC
Location: Menzel Lake, WA
Vehicle:
06 Red Ltd.Wagon
20g-xtr 410/395 JJtuned

Default

Quote:
Originally Posted by pearljam11 View Post
Definite troll. Look at the time of posting too. If this was a real he'd be posting immediately after these issues started and I doubt he was off roading from 10-1 a.m.
Maybe he had a light bar.
Dave D. is offline   Reply With Quote
Old 10-24-2014, 12:24 AM   #14
dark hawk
Scooby Newbie
 
Member#: 393025
Join Date: Jun 2014
Location: Cedar Rapids, IA
Vehicle:
2009 wrx
93 Oct Stage I

Default

This was his ONLY POST. I'm calling troll
dark hawk is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.