Welcome to the North American Subaru Impreza Owners Club Tuesday May 5, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-21-2009, 06:27 PM   #1
emsti2004
Scooby Newbie
 
Member#: 184335
Join Date: Jul 2008
Chapter/Region: South East
Location: Miami,Fl
Vehicle:
2004 STI
WRB

Unhappy 04 sti overheating...

i have a 04 sti with stg 2 mods...until today it wasn't giving me no problems at all...i live in Miami and the temp here in the summer are very high..
here are my symptoms:
when driving or at idle with the AC on, the car overheats.
the AC fan on the passenger side of the radiator doesn't work
the radiator fan on the drivers side of the radiator works fine when hot
when it overheats i turn on the heater and it starts cooling down wile driving and at idle..
coolant looks fine and it only overheats with the AC on..

what can it be??? can it be a bad thermostat or bad fan?
i already did my research and i cant find a answer to it..
thanks in advance...
* Registered users of the site do not see these ads.
emsti2004 is offline   Reply With Quote
Old 08-21-2009, 06:51 PM   #2
Deuce Cam
Scooby Specialist
 
Member#: 130444
Join Date: Oct 2006
Location: Chandler
Vehicle:
'85 AE86 GTS

Default

Quote:
Originally Posted by emsti2004 View Post
i have a 04 sti with stg 2 mods...until today it wasn't giving me no problems at all...i live in Miami and the temp here in the summer are very high..
here are my symptoms:
when driving or at idle with the AC on, the car overheats.
the AC fan on the passenger side of the radiator doesn't work
the radiator fan on the drivers side of the radiator works fine when hot
when it overheats i turn on the heater and it starts cooling down wile driving and at idle..
coolant looks fine and it only overheats with the AC on..

what can it be??? can it be a bad thermostat or bad fan?
i already did my research and i cant find a answer to it..
thanks in advance...

You might have answered your own question here. It's possible the passenger side fan is shot, the wiring for the fan has a bad connection, or the fuse for the fan has blown.
Deuce Cam is offline   Reply With Quote
Old 08-21-2009, 07:19 PM   #3
nicksamba_18
Scooby Newbie
 
Member#: 120770
Join Date: Jul 2006
Chapter/Region: South East
Location: Jax, FL
Vehicle:
2002 Subaru WRX
PSM

Default

LOLOLOLOLOLOLOLOLOLOL.

OT has got to see this.
nicksamba_18 is offline   Reply With Quote
Old 08-21-2009, 07:24 PM   #4
ed10
Scooby Specialist
 
Member#: 198026
Join Date: Dec 2008
Chapter/Region: South East
Location: Asheville/Fletcher, NC
Vehicle:
2002 Impreza WRX
Nulla Tenaci Invia EstVia

Default

Quote:
Originally Posted by emsti2004 View Post
i have a 04 sti with stg 2 mods...until today it wasn't giving me no problems at all...i live in Miami and the temp here in the summer are very high..
here are my symptoms:
when driving or at idle with the AC on, the car overheats.
the AC fan on the passenger side of the radiator doesn't work

the radiator fan on the drivers side of the radiator works fine when hot
when it overheats i turn on the heater and it starts cooling down wile driving and at idle..
coolant looks fine and it only overheats with the AC on..

what can it be??? can it be a bad thermostat or bad fan?
i already did my research and i cant find a answer to it..
thanks in advance...

I think it's because your tires are too low...check the tire pressure!!!
ed10 is offline   Reply With Quote
Old 08-21-2009, 07:56 PM   #5
[27]
Scooby Specialist
 
Member#: 9731
Join Date: Aug 2001
Location: Parkin Harder than Jewpac can.
Vehicle:
2k2 wrx '13 Audi S4
Midnight Gray

Default

blinker fluid
[27] is offline   Reply With Quote
Old 08-21-2009, 07:57 PM   #6
MistaOctamopus
Scooby Newbie
 
Member#: 53561
Join Date: Jan 2004
Chapter/Region: MWSOC
Location: Tentacles!
Vehicle:
2004 WRX
Aspen White

Default

This will require a change of pants.
MistaOctamopus is offline   Reply With Quote
Old 08-21-2009, 08:38 PM   #7
BlackJavaPearl04
Scooby Specialist
 
Member#: 198522
Join Date: Dec 2008
Chapter/Region: Tri-State
Location: Up State NY
Vehicle:
98 LGT Limited
00 LGT -WRX swap

Default

dude fix your fan!
BlackJavaPearl04 is offline   Reply With Quote
Old 08-21-2009, 08:46 PM   #8
I25
NASIOC Supporter
 
Member#: 66501
Join Date: Jul 2004
Chapter/Region: International
Vehicle:
12"
Baltimore Blacksnake

Default

Quote:
Originally Posted by nicksamba_18 View Post
LOLOLOLOLOLOLOLOLOLOL.

OT has got to see this.
LONot...
I25 is offline   Reply With Quote
Old 08-22-2009, 03:06 PM   #9
emsti2004
Scooby Newbie
 
Member#: 184335
Join Date: Jul 2008
Chapter/Region: South East
Location: Miami,Fl
Vehicle:
2004 STI
WRB

Default

i just took care of the problem..it was the AC fan fuse..lol..
emsti2004 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: 04 STi 6 speed tranny morgue Private 'Wanted' Classifieds 0 06-04-2010 09:06 AM
04 STI HELP! Overheating/Overfilling and Spilling acmw Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 21 05-07-2010 03:24 PM
04 STi Overheating Drewbiehd Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 22 04-02-2010 07:10 AM
04 STi overheating. Need help diagnosing problem! BGPKR Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 35 04-08-2009 04:15 AM
04 STI A/C causing overheating g00dhum0r Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 07-24-2008 02:47 PM


All times are GMT -4. The time now is 01:15 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.