Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-07-2002, 09:36 PM   #1
Redline8k
Scooby Specialist
 
Member#: 2968
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Elgin,Illinois
Vehicle:
Beat it to fit,
Paint it to match!

Default sulfur smell after WOT runs?

I get a strong sulfur smell when Im running the car wot. All I have done is a BPM tt turboback exhaust. Is this normal? I know the car is running rich but I cant seen to find out why. My a/f meter almost pegs when I run through the gears. What could cause this and how do I fix it??

Jorge I fixed the boost tap and the smell seems to be less but still present, Ill talk to you more on thursday.....

Any help would be great.
thanks
-nick
* Registered users of the site do not see these ads.
Redline8k is offline   Reply With Quote
Old 05-07-2002, 09:37 PM   #2
titsataki
Scooby Specialist
 
Member#: 4402
Join Date: Feb 2001
Chapter/Region: NESIC
Location: New Haven, Connecticut
Vehicle:
2009 Outback XT
DGM

Default

smell from the Catalytic Converter?
titsataki is offline   Reply With Quote
Old 05-08-2002, 12:57 AM   #3
rwjcp721
Scooby Newbie
 
Member#: 14129
Join Date: Jan 2002
Location: Plano, TX
Default

Quote:
Originally posted by titsataki
smell from the Catalytic Converter?
This is my guess also. My car (no muffler) does this if I floor it repeatedly on the highway....smells horrible
rwjcp721 is offline   Reply With Quote
Old 05-08-2002, 01:27 AM   #4
neurotic
Scooby Specialist
 
Member#: 8161
Join Date: Jul 2001
Default

I have the some problem but I have an aftermarket BOV installed which I figured was just causing me to run rich... seems alot of people notice this.
neurotic is offline   Reply With Quote
Old 05-08-2002, 02:07 AM   #5
Redline8k
Scooby Specialist
 
Member#: 2968
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Elgin,Illinois
Vehicle:
Beat it to fit,
Paint it to match!

Default

yea I was talking this over with some of the guys out by me and jermey said that some of the gas is diluted(sp) with sulfur. I did change gas stations and the smell did seem to get better. Oh well I guess Ill have to deal if everyone else is having some of the same problems.
thanks and keep the comments coming!
-nick
Redline8k is offline   Reply With Quote
Old 05-08-2002, 02:34 AM   #6
marvd00d
Scooby Newbie
 
Member#: 10917
Join Date: Oct 2001
Location: san diego, CA
Default

i get this every once in awhile when i floor it in fourth. all i have is unichip and catback. i also remember back when i had my civic i would always get that smell if i ran my car. (i unbolted my muffler too haha)
marvd00d is offline   Reply With Quote
Old 05-08-2002, 02:43 AM   #7
Cublime
Scooby Newbie
 
Member#: 11897
Join Date: Nov 2001
Location: Scottsdale, AZ
Vehicle:
2002 WRX
Blue

Default

From the clutch burnout experience I had it sounds like its ur clutch.. The WRX clutch has the absolute worst sulfer smell.. Now I'm not an expert on this, but I did have to have one replaced already from dragging...
Cublime is offline   Reply With Quote
Old 05-08-2002, 03:01 AM   #8
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

It's most likely your brand of gas. If you're in one of the areas mentioned on this page - http://cleanerfuels.bp.com//usa/main.htm - consider trying either BP Super 93 or Crystal Clear Amoco Ultimate which will be low-sulfur blends.
Jon [in CT] is offline   Reply With Quote
Old 05-08-2002, 04:19 PM   #9
Redline8k
Scooby Specialist
 
Member#: 2968
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Elgin,Illinois
Vehicle:
Beat it to fit,
Paint it to match!

Default

I dont think it my clutch, I know what that smells like, Ill have to try that new gas. Like I said before it do get better after I went to amoco
thanks
-nick
Redline8k is offline   Reply With Quote
Old 05-10-2002, 01:15 AM   #10
gbaby
Scooby Newbie
 
Member#: 16175
Join Date: Mar 2002
Location: Northwest Territories
Vehicle:
2002 WRX
Midnight Black

Default

Yeah, there's something up with the WRX's and the smells. I'm getting it too. I've driven clutch my whole life and never smelt burning clutch, even when i was learning. I've heard topics with people saying it took them a while to get used to the WRX clutch.... semi-experienced manual drivers and normal to hard driving should not be getting this! Especially with our price tag! Maybe if you're stuck and riding the clutch to get out you might get burn. But not normal road driving with occasional slips and such.

HOWEVER, i don't think my smell or yours is clutch in this case anyway...... and it ain't no "use a different gas" thing. Even if that is a solution it's the wrong type of solution for a $25 grand car! This should not be happening! I've got a stock exhaust system right now, 1400km, and i'm thinking it's a fuel or exhaust smell. One day i was in the car after leaving it idling for awhile and it smelt like propane..... which i would think exhaust.... however the usual smell i'm getting after driving for awhile seems like a gas smell.... it doesn't go away. The smell is embarrasing.... and when you have someone sitting in the car with the smell and them knowing you paid (one more time) $25k for the car.... it's damn embarasing and something Subaru should be addresssing.
gbaby is offline   Reply With Quote
Old 05-10-2002, 02:05 AM   #11
kenchan
Scooby Guru
 
Member#: 15106
Join Date: Feb 2002
Default

blown o2 sensor?
kenchan is offline   Reply With Quote
Old 05-10-2002, 02:19 AM   #12
Mach5WRX
Scooby Specialist
 
Member#: 17060
Join Date: Mar 2002
Location: hellifornia - Turboculture.com
Default

Quote:
Originally posted by titsataki
smell from the Catalytic Converter?
Good chance that's it. Do you still have all 3?
Mach5WRX is offline   Reply With Quote
Old 05-11-2002, 08:30 PM   #13
Redline8k
Scooby Specialist
 
Member#: 2968
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Elgin,Illinois
Vehicle:
Beat it to fit,
Paint it to match!

Default

No I removed one of the cats with the exhaust... do you really think its cause of the removed cat? Do they make that much a difference??
-nick
Redline8k is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant smell after WOT. awdguy Factory 2.0L Turbo Powertrain 2 01-10-2009 11:18 PM
Engine Temp Needle lower after WOT runs? shoooter_j Factory 2.0L Turbo Powertrain 6 01-07-2006 01:56 PM
('93-'01) Gas/sulfur smell in cabin when I punch it dingo dave Impreza Forum 7 03-19-2004 12:03 PM
sulfur smell phatroksek Normally Aspirated Powertrain 7 04-11-2002 12:05 PM
('93-'01) sulfur smell with high revs? (going too fast too quick?) nkodemus82 Impreza Forum 5 04-18-2001 05:44 PM


All times are GMT -4. The time now is 06:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.